The NetBSD Project

CVS log for src/lib/librefuse/fuse_internal.h

[BACK] Up to [cvs.NetBSD.org] / src / lib / librefuse

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.5 / (download) - annotate - [select for diffs], Sat Jan 22 08:09:39 2022 UTC (2 years, 1 month ago) by pho
Branch: MAIN
CVS Tags: netbsd-10-base, netbsd-10-0-RC5, netbsd-10-0-RC4, netbsd-10-0-RC3, netbsd-10-0-RC2, netbsd-10-0-RC1, netbsd-10, HEAD
Changes since 1.4: +24 -1 lines
Diff to previous 1.4 (colored)

lib/librefuse: Implement all sorts of compat tweaks to appease various file systems

ReFUSE now supports all the FUSE API variants from FUSE 1.1 to FUSE
3.10. Sorry for the freaking giant patch. I could not break it down
any further.

Revision 1.4 / (download) - annotate - [select for diffs], Sat Jan 22 08:05:35 2022 UTC (2 years, 1 month ago) by pho
Branch: MAIN
Changes since 1.3: +6 -1 lines
Diff to previous 1.3 (colored)

Support the FUSE option -ho

It is supposed to print a help message without the usage
line. Although it is deprecated and has been removed as of FUSE 3.0,
filesystems in the wild still use it.

Revision 1.3 / (download) - annotate - [select for diffs], Sat Jan 22 08:01:12 2022 UTC (2 years, 1 month ago) by pho
Branch: MAIN
Changes since 1.2: +3 -3 lines
Diff to previous 1.2 (colored)

Change the way how FUSE_*_VERSION are handled

* FUSE_MAKE_VERSION(maj, min) now generates a 3-digits number if the
  version is higher than 3.9. This is needed to support FUSE 3.10 API.

* FUSE_{MAJOR,MINOR}_VERSION no longer have a fixed value but are
  derived from FUSE_USE_VERSION specified by the user code. This is
  needed to support more FUSE filesystems in the wild.

Revision 1.2 / (download) - annotate - [select for diffs], Sat Jan 22 07:53:06 2022 UTC (2 years, 1 month ago) by pho
Branch: MAIN
Changes since 1.1: +16 -1 lines
Diff to previous 1.1 (colored)

lib/librefuse: Implement FUSE session API and its signal handling functionality

Revision 1.1 / (download) - annotate - [select for diffs], Sat Dec 4 06:42:39 2021 UTC (2 years, 2 months ago) by pho
Branch: MAIN

librefuse: Preparation of a proper API versioning; no more #ifdef woes in user code

The goal is to fully support FUSE API version 3.0 while maintaining
API/ABI compatibility with code written for 2.6 (or even older).

* <fuse.h> now emits a compiler warning if it's included without
  defining FUSE_USE_VERSION. It had been silently defaulted to the
  latest supported version prior to this change. This is permissive
  compared to the original FUSE, as it emits an error instead.

* <fuse.h> now emits a warning if FUSE_USE_VERSION is higher than what
  can be provided.

* Added a macro FUSE_MAKE_VERSION(maj, min). It was missing from
  librefuse <fuse.h>.

No actual API updates have been made (yet).

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>