[BACK]Return to UPDATING CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / src

Please note that diffs are not public domain; they are subject to the copyright notices on the relevant files.

Diff for /src/UPDATING between version 1.187 and 1.203

version 1.187, 2009/01/11 03:32:44 version 1.203, 2009/11/02 01:09:21
Line 16  See also: BUILDING, build.sh, Makefile.
Line 16  See also: BUILDING, build.sh, Makefile.
 Recent changes:  Recent changes:
 ^^^^^^^^^^^^^^^  ^^^^^^^^^^^^^^^
   
   20091101:
           After updating, it may be make the 'cleandir' target in
           src/tools/yacc/ and in src/usr.bin/yacc/ before a 'build.sh
           -u tools' or 'build.sh -u distribution'.
   
   20091001:
           An error will create a ./usr/X11R7/lib/X11/xkb/compiled/xkb
           symlink, failing the build.  Delete the link, and the subdir
           it is in, and retry your build.
   
   20090718:
           libc build changed so that strchr() provides the extra entry
           point for index(). Update build of libc.a (and libc_pic.a)
           may fail because the archive contains the unwanted index.o.
           (Similarly for strrchr() and rindex().)
   
   20090709:
           Native Xorg was upgraded again.  Builds will probably fail again
           without a clean objdir, at least for src/external/mit/xorg.
   
   20090616:
           Native Xorg was upgraded.  Builds will need a clean objdir for
           src/external/mit/xorg.  Upgrading a system from sets will not
           work properly yet as the /usr/X11R7/lib/X11/xkb/symbols/pc
           subdirectory has been changed into a file, and this needs to
           be manually "rm -r"'ed before installing xbase.tgz.
   
   20090501:
           Several new functions were added to string.h/libc, and this
           can cause autoconf problems during the tool build for people
           who fail to clean out their tools objects properly. If you
           note messages about stpcpy, stpncpy or strnlen accompanying a
           failure during the tool build, clean out all your tools
           objects and start again.
   
   20090325:
           The i386 port was switched to i486 default toolchain.  This requires
           cleaning your src/tools directory and $TOOLDIR and rebuilding them.
   
   20090126:
           The __posix_fadvise50 system call changed assembly stub type. You need to
           'rm -f __posix_fadvise50.*' in the libc build directory to avoid using
           the old assembly stub.
   
   20090202:
           pkg_install now depends on the pkgdb cache for automatic conflict
           detection.  It is recommented to rebuild the cache with
           ``pkg_admin rebuild''.
   
 20090110:  20090110:
         time_t and dev_t have been bumped to 64 bit quantities. To upgrade:          time_t and dev_t have been bumped to 64 bit quantities. To upgrade:
         1. Make sure your kernel has COMPAT_50 in it. Build and install.          1. Make sure your kernel has COMPAT_50 in it. Build and install.
              This is needed even in the MODULAR kernel because there is
              conditionally compiled code in rtsock.c.
         2. make sure build.sh completes and the binaries in a chroot work          2. make sure build.sh completes and the binaries in a chroot work
            before installing.             before installing.
         3. If you don't use build.sh and you build directly to root, and          3. If you don't use build.sh and you build directly to root, and
Line 28  Recent changes:
Line 79  Recent changes:
            libraries in src/lib and src/gnu/lib and install them. Once             libraries in src/lib and src/gnu/lib and install them. Once
            the new libraries are installed, you can restart the build.             the new libraries are installed, you can restart the build.
         4. If you compile packages and you notice link time warnings,          4. If you compile packages and you notice link time warnings,
            you'll need to bump them and rebuild them.             rebuild the required packages to update their shared libraries.
              Any package you rebuild will require rebuilding all the packages
              that depend on it.
         5. Next time you run pwd_mkdb with the new binary, the file          5. Next time you run pwd_mkdb with the new binary, the file
            will be upgraded and it will not be backwards compatible.             will be upgraded and it will not be backwards compatible.
         6. The utmpx/wtmpx files have been versioned, and there is          6. The utmpx/wtmpx files (/var/run/utmpx and /var/log/wtmpx, see
            a heuristic for utmp. You are better off removing the             lastlogx(5)) have been versioned, and there is a heuristic
            old files after upgrading.             for utmp. You are better off removing the old files after
              upgrading.  The automated clearing of /var/run during
              boot, and the automated rotating of files in /var/log by
              newsyslog(8), may mean that you do not have to remove the
              files manually.
           7. The optional accounting file (/var/account/acct, see
              accton(8)) has not been versioned, and will need to be
              removed.  The automatic rotation of the accounting file by
              /etc/daily limits the bad consequences of failure to remove
              the file.
           8. Application software that writes time_t to binary files on
              disk will break or need attention. Most notably: if you are
              using PostgreSQL < 8.4, you need to dump your databases,
              rebuild PostgreSQL with the new time_t, then restore.
   
 20081219:  20081219:
         config(1) has been updated, and one of the files it creates -          config(1) has been updated, and one of the files it creates -
Line 74  Recent changes:
Line 140  Recent changes:
         MKDEBUG build was broken because the .depend files did not know          MKDEBUG build was broken because the .depend files did not know
         about .go files. You need to remove all .depend files and rebuild.          about .go files. You need to remove all .depend files and rebuild.
   
   20080802:
           A regression in binary compatibility for pthread_mutex_t has
           been fixed. Unfortunately, the price is breaking compatibility
           for -current.
   
           Threaded programs (using libpthread) and C++ programs (using
           libstdc++) compiled after 20070907 and before 20080802 need to
           be recompiled.
   
           One way to find affected pkgsrc packages:
   
             $ grep REQUIRES=/usr/lib/libpthread /var/db/pkg/*/+BUILD_INFO
             $ grep REQUIRES=/usr/lib/libstdc++ /var/db/pkg/*/+BUILD_INFO
   
 20080731:  20080731:
         WAPBL (metadata journaling support) has been added, but at this          WAPBL (metadata journaling support) has been added, but at this
         time isn't backwards compatible with pre-WAPBL aware kernels          time isn't backwards compatible with pre-WAPBL aware kernels
Line 150  Recent changes:
Line 230  Recent changes:
         and userland are from after 20070913.          and userland are from after 20070913.
   
 20070703:  20070703:
         nbinstall has been renamed as it calls the target specific and          nbinstall has been renamed ${MACHINE_GNU_ARCH}-install. It
         the logic to pass down STRIP from mk been removed.  This forces          calls the target-specific strip program, and the logic to pass
         a re-installation of tools.          down STRIP from make has been removed.  This requires a
           re-installation of tools.
   
 20070422:  20070422:
         The way OS emulations lookup filenames inside the emulation root          The way OS emulations lookup filenames inside the emulation root

Legend:
Removed from v.1.187  
changed lines
  Added in v.1.203

CVSweb <webmaster@jp.NetBSD.org>