[BACK]Return to UPDATING CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / src

Please note that diffs are not public domain; they are subject to the copyright notices on the relevant files.

Diff for /src/UPDATING between version 1.187 and 1.189

version 1.187, 2009/01/11 03:32:44 version 1.189, 2009/01/14 15:53:29
Line 19  Recent changes:
Line 19  Recent changes:
 20090110:  20090110:
         time_t and dev_t have been bumped to 64 bit quantities. To upgrade:          time_t and dev_t have been bumped to 64 bit quantities. To upgrade:
         1. Make sure your kernel has COMPAT_50 in it. Build and install.          1. Make sure your kernel has COMPAT_50 in it. Build and install.
              This is needed even in the MODULAR kernel because there is
              conditionally compiled code in rtsock.c.
         2. make sure build.sh completes and the binaries in a chroot work          2. make sure build.sh completes and the binaries in a chroot work
            before installing.             before installing.
         3. If you don't use build.sh and you build directly to root, and          3. If you don't use build.sh and you build directly to root, and
Line 28  Recent changes:
Line 30  Recent changes:
            libraries in src/lib and src/gnu/lib and install them. Once             libraries in src/lib and src/gnu/lib and install them. Once
            the new libraries are installed, you can restart the build.             the new libraries are installed, you can restart the build.
         4. If you compile packages and you notice link time warnings,          4. If you compile packages and you notice link time warnings,
            you'll need to bump them and rebuild them.             rebuild the required packages to update their shared libraries.
              Any package you rebuild will require rebuilding all the packages
              that depend on it.
         5. Next time you run pwd_mkdb with the new binary, the file          5. Next time you run pwd_mkdb with the new binary, the file
            will be upgraded and it will not be backwards compatible.             will be upgraded and it will not be backwards compatible.
         6. The utmpx/wtmpx files have been versioned, and there is          6. The utmpx/wtmpx files have been versioned, and there is
            a heuristic for utmp. You are better off removing the             a heuristic for utmp. You are better off removing the
            old files after upgrading.             old files after upgrading. The accounting file has not
              been versioned, and will need to be removed.
   
 20081219:  20081219:
         config(1) has been updated, and one of the files it creates -          config(1) has been updated, and one of the files it creates -

Legend:
Removed from v.1.187  
changed lines
  Added in v.1.189

CVSweb <webmaster@jp.NetBSD.org>