[BACK]Return to UPDATING CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / src

Please note that diffs are not public domain; they are subject to the copyright notices on the relevant files.

Diff for /src/UPDATING between version 1.178.2.1.2.1.2.1 and 1.187

version 1.178.2.1.2.1.2.1, 2010/04/21 05:15:01 version 1.187, 2009/01/11 03:32:44
Line 16  See also: BUILDING, build.sh, Makefile.
Line 16  See also: BUILDING, build.sh, Makefile.
 Recent changes:  Recent changes:
 ^^^^^^^^^^^^^^^  ^^^^^^^^^^^^^^^
   
 20090530:  20090110:
         pkg_install now depends on the pkgdb cache for automatic conflict          time_t and dev_t have been bumped to 64 bit quantities. To upgrade:
         detection.  It is recommented to rebuild the cache with          1. Make sure your kernel has COMPAT_50 in it. Build and install.
         ``pkg_admin rebuild''.          2. make sure build.sh completes and the binaries in a chroot work
              before installing.
         audit-packages.conf(5) has been superseded by pkg_install.conf(5).          3. If you don't use build.sh and you build directly to root, and
         The default configuration is the same.  Support for pkg_view(1) has             your build breaks in the middle, don't despair. Make sure headers
         been retired.  The functionality of audit-packages(1) and             are installed properly, and start building libraries first libc
         download-vulnerability-list(1) has moved into pkg_admin(1), wrapper             and libutil, install them and then continue building all the
         scripts that handle the common use cases are provided.             libraries in src/lib and src/gnu/lib and install them. Once
              the new libraries are installed, you can restart the build.
           4. If you compile packages and you notice link time warnings,
              you'll need to bump them and rebuild them.
           5. Next time you run pwd_mkdb with the new binary, the file
              will be upgraded and it will not be backwards compatible.
           6. The utmpx/wtmpx files have been versioned, and there is
              a heuristic for utmp. You are better off removing the
              old files after upgrading.
   
   20081219:
           config(1) has been updated, and one of the files it creates -
           swapnetbsd.o - has changed format.  You need to rebuild config
           (done automatically by build.sh) and then you need to rerun
           config on all kernel configuration files before rebuilding those
           kernels.
   
 20081205:  20081205:
         If you build with MKX11=no, you should remove /etc/rc.d/xdm and          If you build with MKX11=no, you should remove /etc/rc.d/xdm and
         /etc/rc.d/xfs from DESTDIR because those files were moved to the xetc          /etc/rc.d/xfs from DESTDIR because those files were moved to the xetc
         set and will appear as extra files for MKX11=no update builds.          set and will appear as extra files for MKX11=no update builds.
   
   20081122:
           On i386, various kernel options(4) in GENERIC including
           file systems have been disabled and moved into kernel modules.
           Before trying a new GENERIC kernel, you have to prepare the
           following files as well as a new GENERIC kernel:
   
           - build and install kernel modules from src/sys/modules
   
           - install the latest bootloader, which will load a module
             for the file system from which the kernel is loaded automatically
   
           If you have to load your kernel from a file system which is not of
           the same type as the root file system, you have to load the necessary
           file system module manually on the boot prompt or in the boot.cfg file.
   
 20080827:  20080827:
         If you built and installed a libc from sources between          If you built and installed a libc from sources between
         2008/08/20 and 2008/08/26 you got a broken strtouq(3)          2008/08/20 and 2008/08/26 you got a broken strtouq(3)
         which results in false errors reported by lint(1).          which results in false errors reported by lint(1).
         Since this breaks the libc build itself, manual help is          Since this breaks the libc build itself, manual help is
         needed -- lint must be disabled temporarily, e.g:          needed -- lint must be disabled temporarily, e.g.:
           $ (cd lib/libc && make MKLINT=no dependall install)            $ (cd lib/libc && make MKLINT=no dependall install)
   
 20080813:  20080813:

Legend:
Removed from v.1.178.2.1.2.1.2.1  
changed lines
  Added in v.1.187

CVSweb <webmaster@jp.NetBSD.org>