[BACK]Return to UPDATING CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / src

Please note that diffs are not public domain; they are subject to the copyright notices on the relevant files.

Diff for /src/UPDATING between version 1.125 and 1.187

version 1.125, 2004/07/22 03:55:33 version 1.187, 2009/01/11 03:32:44
Line 16  See also: BUILDING, build.sh, Makefile.
Line 16  See also: BUILDING, build.sh, Makefile.
 Recent changes:  Recent changes:
 ^^^^^^^^^^^^^^^  ^^^^^^^^^^^^^^^
   
 20040715:  20090110:
         The rc.d/sendmail script now uses a heuristic to determine          time_t and dev_t have been bumped to 64 bit quantities. To upgrade:
         if sendmail should be started at boot time.  It checks the          1. Make sure your kernel has COMPAT_50 in it. Build and install.
         contents of /etc/mailer.conf, /etc/mail/submit.cf, and the          2. make sure build.sh completes and the binaries in a chroot work
         owner and mode of the sendmail binary to see if any changes             before installing.
         to the mail infrastructure have been made.  If no changes          3. If you don't use build.sh and you build directly to root, and
         are detected, it will start an SMTP listener.             your build breaks in the middle, don't despair. Make sure headers
              are installed properly, and start building libraries first libc
         Setting sendmail=NO in /etc/rc.conf will override this.             and libutil, install them and then continue building all the
              libraries in src/lib and src/gnu/lib and install them. Once
         If you are only using sendmail by default and only for             the new libraries are installed, you can restart the build.
         local delivery, it is important that you also update your          4. If you compile packages and you notice link time warnings,
         sendmail.cf so that the SMTP listener only listens on the             you'll need to bump them and rebuild them.
         loopback interface.          5. Next time you run pwd_mkdb with the new binary, the file
              will be upgraded and it will not be backwards compatible.
 20040715:          6. The utmpx/wtmpx files have been versioned, and there is
         The method by which athhal-elf.o gets pulled into i386             a heuristic for utmp. You are better off removing the
         kernel builds has been changed again.  The latest version             old files after upgrading.
         of bsd.files.mk is no longer required.  
   20081219:
 20040621:          config(1) has been updated, and one of the files it creates -
         Due to the recent rototill of tools/compat it's crucial one starts          swapnetbsd.o - has changed format.  You need to rebuild config
         from a clean objdir under tools/*.          (done automatically by build.sh) and then you need to rerun
           config on all kernel configuration files before rebuilding those
         This is mostly due to generated files (yacc and lex sources) needing          kernels.
         to be generated with new rules from bsd.hostprog.mk.  
   20081205:
         The safest course is to rm -rf all objects under tools before building.          If you build with MKX11=no, you should remove /etc/rc.d/xdm and
           /etc/rc.d/xfs from DESTDIR because those files were moved to the xetc
 20040516:          set and will appear as extra files for MKX11=no update builds.
         The end-user modifiable X11 configuration has been moved  
         from /usr/X11R6/lib/X11/<dir> to /etc/X11/<dir>.  20081122:
         Ensure that src and xsrc is up to date, and run          On i386, various kernel options(4) in GENERIC including
         "make cleandir" in src/x11 before your next build.          file systems have been disabled and moved into kernel modules.
           Before trying a new GENERIC kernel, you have to prepare the
 20040426:          following files as well as a new GENERIC kernel:
         Support for the original dynamic sysctl node structure has  
         been removed in favor of the newer layout.  This affects          - build and install kernel modules from src/sys/modules
         consumers of the create and delete interface, as well as  
         the dynamic discovery mechanism.  This is believed only to          - install the latest bootloader, which will load a module
         be the sysctl(8) binary itself, at this point in time, so            for the file system from which the kernel is loaded automatically
         the only effect of this should be that a sysctl binary  
         built from sources dated between 2003/12/04 and 2004/03/24          If you have to load your kernel from a file system which is not of
         will not work on a kernel built from sources dated after          the same type as the root file system, you have to load the necessary
         2004/04/25.  If you need a new sysctl binary but build.sh          file system module manually on the boot prompt or in the boot.cfg file.
         does not work, make sure that your revision of  
         src/sys/sys/sysctl.h is 1.112 (or later), and then the  20080827:
         do the following:          If you built and installed a libc from sources between
           2008/08/20 and 2008/08/26 you got a broken strtouq(3)
         cd /usr/src (or wherever your source tree is)          which results in false errors reported by lint(1).
         make USETOOLS=no includes          Since this breaks the libc build itself, manual help is
         cd lib/libc          needed -- lint must be disabled temporarily, e.g.:
         make USETOOLS=no dependall install            $ (cd lib/libc && make MKLINT=no dependall install)
         cd ../../sbin/sysctl  
         make USETOOLS=no dependall install  20080813:
           MKDEBUG build was broken because the .depend files did not know
         If you are using older sysctl binary, GNU autoconf would fail to          about .go files. You need to remove all .depend files and rebuild.
         identify your machine architecture, and tries to build binary for  
         "unknown-unknown-netbsd20F" or something like that.  if that happens,  20080731:
         make sure to follow the above steps.          WAPBL (metadata journaling support) has been added, but at this
           time isn't backwards compatible with pre-WAPBL aware kernels
 20040425:          and userland (fsck_ffs in particular).  Please make sure you
         The ffs superblock issues listed below under 20040109 and 20030402          don't use a journaled filesystem with an older kernel/userland,
         are now automatically addressed by the /etc/rc.d/fixsb script or by          especially an uncleanly mounted journaled filesystem.  WAPBL
         sysinst when it checks a a filesystem. The manual fsck_ffs -b16 -c4          also requires the super block to be in the UFS2 format.  You
         invocation mentioned below will continue to work and is now          can use fsck_ffs -c 4 to update the superblock format.
         automated by those scripts.  Note that under certain circumstances,  
         affected filesystems upgraded to a -current kernel first before  20080721:
         upgrading their userland with the fixsb and fsck_ffs fixes may          Assembler warnings are now fatal if $WARNS>0 and $NOGCCERROR
         encounter a 'freeing free inode' panic when writing to the affected          isn't defined.
         filesystem, so it is a good idea to repair the filesystem as soon as  
         possible.  For more details on the fixsb script, see pr install/25138.  20080531:
           The ioctl number of DRVSUSPENDDEV command on /dev/drvctl changed
 20040418:          from 125 (conflicted with DRVCTLCOMMAND) to 129. The drvctl(8)
         statfs(2) and friends have been replaced with statvfs(2). Before          utility needs to be rebuilt and reinstalled as older binaries
         installing a newly build userland make sure that you are running          won't work correctly. The following sequence of commands:
         a newly built kernel with COMPAT_20 set. In addition your libc  
         build might not work (undefined SYS_statfs symbol) because make            $ (cd sys/sys/ && nbmake-$arch includes)
         clean does not know how to remove files it does not know about            $ (cd sbin/drvctl/ && nbmake-$arch clean)
         anymore. Manually remove all generated .S sources and objects            $ (cd sbin/drvctl/ && nbmake-$arch all)
         from the libc build directory.  
           leaves new drvctl utility in sbin/drvctl build directory.
 20040326:  
         The method by which athhal-elf.o gets pulled into i386 kernel builds  20080503:
         has been changed. The file is now stored as a uuencoded file in CVS          The <bsd.lib.mk> variable MKPRIVATELIB was renamed to LIBISPRIVATE.
         and the generated Makefile will use the new .uue rules from bsd.file.mk  
         to build it.  20080521:
           For a while, unprivileged UPDATE builds would fail to
         This means you must have the latest bsd.files.mk installed when          succeed at the checkflist stage, complaining that
         building a kernel without USETOOLS=yes.          ${DESTDIR}/stand/<arch>/ did not exist.  A fix for this
           problem was committed to share/mk/bsd.kmodule.mk, revision 1.9.
 20040318:          If you already hit this problem, update the .mk file,
         A bug in the cgd(4) blowfish code was corrected, without          remove ${DESTDIR}/stand/<arch>, and re-run the build.
         provision of backwards compatibility, after several public  
         notices over several months. Users of cgd with blowfish cipher  20080303:
         ONLY must dump their data before updating their kernels, and          Linker warnings are now fatal if $WARNS>0.
         recreate cgd's and restore data using the new kernel. See  
         (recent message to current-users, URL when mail-index has updated)  20080126:
           The posix_fadvise system call has been changed from an assembly
 20040313:          stub, to a c file that calls an assembly stub. You need to
         On acorn32, the opms and qms drivers have been withdrawn, and          'rm -f posix_fadvise.* .depend' in the libc build directory to
         the old wsqms driver is now called qms.  Kernel config files          avoid using the old assembly stub.
         will need updating.  See the ones in sys/arch/acorn32/conf  
         for examples.  20071209:
           The acpiec(4) driver has been split into two attachments. If you
 20040125:          get ACPI errors before the attachment, please update your kernel
         On acorn32, the beep and sysbeep devices are no longer          configuration file appropriately or see GENERIC for more details.
         needed, and will need to be deleted from kernel configuration  
         files.  20071115:
           The it(4) driver has been renamed to itesio(4) and the old port
 20040109:          argument specified in the kernel configuration file is not valid
         Compatibility for old ffs superblock layouts has been          anymore. The itesio(4) driver now uses the Super I/O address port
         added, and the restrictive fsck checks have been reenabled          rather than the EC address port. Please update your kernel
         when using those layouts.  If you have been using -current          configuration file appropriately or see GENERIC for more details.
         since 20030402, you may find that fsck again signals fatal  
         superblock mismatches.  To repair, make sure you have  20071028:
         an updated fsck_ffs and then you can use fsck_ffs -b 16 -c 4          The pccons(4) driver has been removed from the NetBSD/shark port.
         to complete the filesystem upgrade.  A message has          You need to update any custom kernel configuration file you have
         been added to the kernel which should detect this problem.          to remove any references to pccons (which includes removing the
         See the following discussion for more information:          now useless XSERVER option) and replace them with the correct
         http://mail-index.NetBSD.org/current-users/2004/01/11/0022.html          entries for the wscons driver.  See the GENERIC configuration file
           for more details.
 20031203:  
         New binutils builds may fail due to old dependencies.  20070913:
         It's necessary to "make cleandir" to ensure that          A latent bug in dhclient/dhcpd that caused it to be unable to
         the dependencies will be rebuilt correctly.          enumerate interfaces was fixed.  The bug began to cause
           problems after 20070911 when the kernel's SIOCGIFCONF
 20031111:          implementation was repaired.  From 20070529 to 20070911 racoon
         A newer mkdep is needed.  Error noting that is          could not enumerate interfaces.  (These are noted because
                 cc: Ambiguous abbreviation --          normal kernel/userspace version matching hygiene is not
           sufficient to avoid this problem.)  Ensure that both kernel
 20031008:          and userland are from after 20070913.
         /usr/include/sys/disklabel_mbr.h was removed.  
         It's necessary to "make cleandir" to ensure that  20070703:
         the dependencies will be rebuilt correctly.          nbinstall has been renamed as it calls the target specific and
           the logic to pass down STRIP from mk been removed.  This forces
 20031007:          a re-installation of tools.
         A sign exension bug was fixed which set all the high bits  
         of our newly expanded ffs fs_flags.  This should only  20070422:
         affect users who installed or upgraded in September of 2003.          The way OS emulations lookup filenames inside the emulation root
         A small utility program was posted to tech-kern which          has been changed.  Rather than modify the pathname (and copy back
         should fix this problem, and a warning message was added          to userspace) namei() and lookup() directly check the emulation
         to the kernel which should discover and warn about it.  See          root. One side effect is that absolute symlinks inside the emulated
         http://mail-index.NetBSD.org/tech-kern/2003/10/07/0005.html          root file system will be relative to that file system - unless they
           start /../ this is useful when the emulated root is a real install
 20030906:          that has such links.
         With the addition of siginfo support the old signal trampoline          This might affect symlinks that have been added to reference outside
         code has been deprecated to COMPAT_16. Make sure that your running          the emulated root.
         kernel has COMPAT_16 enabled before building userland.  
   20070412:
 20030801:          The pckbc driver on sgimips IP32 has been removed. Use macekbc
         With the new openssl, there is some header and library shuffling.          instead. See the GENERIC32_IP3x kernel configuration for an
         rm -f /usr/include/des.h /usr/include/kerberosIV/* /lib/libdes* \          example.
         /usr/lib/libdes* before building.  
   20070319:
 20030703:          src/lib/libc/Makefile revision 1.129 broke libc and ld.elf_so
         Texinfo was updated to 4.6.  To avoid failures when trying to          on many platforms due to incorrect flags settings.  If you
         build the included texinfo files, do:          updated and built after about 20070315, do "nbmake-$arch
           cleandir" in src/lib/libc and src/libexec/ld.elf_so to force a
         cd src/gnu/usr.bin/texinfo          rebuild of object files that might have been built
         make MKINFO=no dependall install          incorrectly, and ensure that you have at least
           src/lib/libc/Makefile 1.130.
 20030630:  
         Groff was updated to 1.19; it's probably necessary to do  20070210:
                 cd share/mk && make install          src/sys/sys/{sa.h,savar.h} were removed.
                 cd src/gnu/usr.bin/groff            find ${OBJDIR} \( -name .depend -o -name '*.d' \) -print \
                 make MKMAN=no dependall install                | xargs egrep -l '/sa.h|/savar.h' | xargs rm
         (untested).          will allow dependencies on those files to get get rebuilt
   
 20030516:  20070209:
         Due to bugs in the export handling code, invalid export lines          The threading model was changed when the newlock2 branch
         were accepted before and caused the kernel to panic when          was merged to NetBSD-current.  If you boot with a new
         mountd got restarted because it freed memory that had already          kernel (version 4.99.10), then you also need a new pthread
         been freed. This has been fixed and the kernel checks          library (/usr/lib/libpthread.so.0.7).  If you boot with
         export addresses very strictly. If you upgrade your kernel,          an old kernel, then you need the old pthread library
         make sure you also upgrade mountd, because if your export          (/usr/lib/libpthread.so.0.6).  Provided you keep the kernel and
         file contains lines with an old inet4 address syntax (i.e.          the pthread library in sync, old threaded applications should
         a.b.c or a.b or a), they will get rejected by the new kernel.          continue to work with an old or new kernel.  Note that named(8)
           is the only threaded application in the base system.
 20030402:  
         The superblock layout for FFS was changed.  If you have 1.6  20061214:
         fsck binaries, they will signal a fatal superblock mismatch          Following the move of string_to_flags() and flags_to_string()
         with the first alternate, because they compare too many          from the bin/ls/ sources to libutil, users doing UPDATE builds
         fields (even ones that aren't useful).  If possible, upgrade          will need to do a "make cleandir" in
         your fsck_ffs binary before using a new kernel.                  tools/mtree/, tools/makefs/, tools/binstall/, tools/pax/,
         None of this signals actual filesystem damage.                  bin/pax/, bin/ls/, usr.sbin/mtree/, usr.sbin/makefs/,
                   usr.bin/xinstall/, libexec/ftpd/, rescue/, as well
 20030324:                  as the installation images in distrib/
         sendmail version 8.12.8 was imported.  Since sendmail is          in order to excise stale references to the old stat_flags.h header
         now setgid to the smmsp group, and runs in "collection"          file in the ls sources -- stat_flags.h has been removed.
         mode for most common activities, there is a new config  
         file called submit.cf that needs to live in /etc/mail.  20061108:
         The generic submit.cf sample in /usr/share/sendmail/cf          The configure script used in the src/tools/gcc compiler has been
         is named netbsd-msp.cf.  Upgrading your regular sendmail          changed to indicate that our libc has ssp support built-in and
         configuration file is also strongly advised.          does not depend on -lssp and -lssp-nonshared. You'll need to
           make clean in src/tools/gcc first to rebuild the compiler.
         See the section named "MESSAGE SUBMISSION PROGRAM" in  
         the updated /usr/share/sendmail/README file for more  20061009:
         information.          The sysctl variables net.inet{,6}.tcp{,6}.newreno are no longer
           available. Use net.inet{,6}.tcp{,6}.congctl.selected instead.
 20030117:  
         Texinfo was updated to 4.3.  To avoid failures when trying to  20060814:
         build the included texinfo files, do:          The vt, vidcconsole, kbd, and rpckbd drivers on acorn32 have been
           withdrawn.  Use vidcvideo and pckbd instead.  See the GENERIC
         cd src/gnu/usr.bin/texinfo          kernel configuration for an example.  X servers from the last
         make MKINFO=no dependall install          few years should cope.
   
 20021223:  20060703:
         The METALOG format changed slightly, to remove the leading          MPACPI is no more. We always configure PCI interrupts using ACPI
         "${DESTDIR}" from path names.          if we have an ACPI kernel. The option MPACPI_SCANPCI has been renamed
         This only affects people building with UNPRIVED.          to ACPI_SCANPCI. Thanks to work from fvdl.
         For complete safety, remove the DESTDIR entirely and  
         update tools/mtree, before running make build.  20060627:
           socket(2) has changed, and its system call has been versioned.
 20021219:          For userlands with the old version of socket(2), make sure that
         CVS repository layout was changed.  See the following for details          your kernel has 'options COMPAT_30' set, or else 'bad system call'
         if you are using (anonymous) cvs to update your tree.          errors will result.
   
         http://mail-index.NetBSD.org/netbsd-announce/2002/12/19/0000.html  
   
 20021219:  
         install(1) had a '-N dbdir' option added, to specify an  
         alternate location to look up users & groups (instead  
         of the host system passwd(5) and group(5) databases).  
   
         The build system was modified to take advantage of  
         this option (using ${NETBSDSRCDIR}/etc), so if you  
         use USETOOLS==no, you may have to rebuild and  
         reinstall usr.bin/xinstall first.  
   
 20021130:  
         fparseln(3) moved from libutil to libc.  
         If building to DESTDIR=/, reinstall the includes  
         and rebuild libc:  
                 make includes  
                 make do-lib-libc  
         If using build.sh, "cd tools/compat && make clean"  
         before rebuilding the tools.  
   
 20021126:  
         The mk.conf(5) variable SYS_INCLUDE has been deprecated,  
         including the optional "SYS_INCLUDE=symlinks" support.  
         All header files, including <sys/*.h> are copied into  
         /usr/include.  
   
 20021121:  
         The C run-time support files crtbegin.o and crtend.o  
         (and their companions crtbeginS.o and crtendS.o) were  
         split up, with new crti.o and crtn.o files resulting.  
         This means that libtool needs to be rebuilt once the  
         new libraries are installed.  The process of rebuilding  
         libtool will cause it to automatically notice the new  
         required files, but it *must* be rebuilt in order to  
         do this.  
   
         An out-of-date libtool will result in shared libraries  
         which lack _init() and _fini() routines, which means that  
         their global contructors/destructors will not be invoked.  
   
 20021121:  
         A bug related to how ARM ELF objects were tagged has been  
         corrected.  
   
         NetBSD ARM ELF uses the soft-VFP floating point model by  
         default.  However, the assembler lacked support for marking  
         objects as using the VFP floating point format, and the  
         compiler was not properly passing the flag indicating "soft-VFP"  
         to the assembler.  
   
         Unfortunately, this means that the linker will now consider  
         old (i.e. not marked "softvfp") NetBSD ARM ELF objects to be  
         incompatible with new (properly marked) objects.  
   
         The problem will only manifest itself if you attempt to compile  
         a new program using the fixed toolchain, and link that program  
         against old libraries which do not have the proper "softvfp"  
         markings.  ALL OF YOUR EXISTING BINARIES AND SHARED LIBRARIES  
         WILL CONTINUE TO WORK PROPERLY.  
   
         The only work-around for the problem is to recompile all of  
         the libraries on the system.  The easiest way to do this for  
         system libraries is to install a binary snapshot; they are  
         generally available on releng.NetBSD.org.  Any packages you  
         have installed which supply libraries will have to be recompiled  
         if you wish to link new programs against those libraries.  
   
         If you have questions about this matter, please contact  
         port-arm@NetBSD.org.  
   
 20021011:  
         Systrace has been improved to support privilege elevation.  
         Updating the kernel requires the userland part of systrace  
         to be rebuilt.  
   
 20021010:  
         The config(8) grammar was changed to allow options to register  
         dependencies on attributes, as well as other options.  Users  
         must update and reinstall usr.sbin/config before building a new  
         kernel.  
   
 20021009:  
         A new attribute dependency syntax was introduced to config(8),  
         which is now used by the SCSI configuration description.  Users  
         must update and reinstall usr.sbin/config before building a new  
         kernel.  
   
 20021003:  
         Several changes have been made to the autoconfiguration  
         framework.  Users must update and reinstall usr.sbin/config  
         before building a new kernel.  
   
 20021001:  
         The i386mp branch has been merged.  To compile a kernel, users  
         will need to add the option 'cpu* at mainbus?' to their configuration  
         file.  Multiprocessor kernels will need  
         ioapic*         at mainbus? apid ?  
         options         MULTIPROCESSOR  
         options         COM_MPLOCK  
   
 20020922:  
         MKDYNAMICROOT=yes enabled by default, which means that  
         certain shared libraries are installed into /lib, the shared  
         linker is installed into /libexec, and all programs in /bin  
         and /sbin are dynamically linked.  
         If you do not use "make build", you should ensure that  
         you have the libraries and shared linker in the new locations,  
         with:  
                 make do-lib-csu do-lib-libc do-lib do-gnu-lib do-ld.elf_so  
   
 20020917:  
         USE_NEW_TOOLCHAIN has been replaced with:  
             -   TOOLCHAIN_MISSING -- set to "yes" on platforms for which  
                 there is no working in-tree toolchain (hppa, ns32k, sh5,  
                 x86_64).  
             -   EXTERNAL_TOOLCHAIN -- if defined by the user, points to the  
                 root of an external toolchain (e.g. /usr/local/gnu).  This  
                 enables the cross-build framework even for TOOLCHAIN_MISSING  
                 platforms.  
   
 20020906:  
         gehenna-devsw has been merged into the trunk. Need to update and  
         reinstall usr.sbin/config before building the kernel.  
   
 20020822:  
         Crunched rescue tools (contents of /bin and /sbin, plus others)  
         are now provided in /rescue.  
   
         To ensure that these are built statically linked (no matter  
         what the setting of LDSTATIC is), use a crunchgen(1) built  
         from sources newer than 20020820 (see the next entry).  
   
 20020820:  
         crunchgen(1) changed to ensure that the generated program  
         is statically linked.  
   
         Solution: update and reinstall usr.bin/crunch  
   
 20020605:  
         smmsp user/group has been added for sendmail.  
   
         Add the following into /etc/group:  
   
         smmsp:*:17:  
   
         and the following to /etc/master.passwd (via vipw):  
   
         smmsp:*:17:17::0:0:Sendmail Message Submission Program:/nonexistent:/sbin/nologin  
   
 20020515:  
         sshd user/group has been added.  Need to hand add this in, or sshd  
         will not let you log in (with default, or UsePrivlegeSeparation=yes)  
   
         Add the following into /etc/group:  
   
         sshd:*:16:  
   
         and the following to /etc/master.passwd (via vipw):  
   
         sshd:*:16:16::0:0:& pseudo-user:/var/chroot/sshd:/sbin/nologin  
   
         Also /var/chroot/sshd directory needs to be present (digged as part of  
         the build process).  
   
 20020426:  
         NBUILDJOBS obsoleted in favor of just using -j.  
   
 20020426:  
         etc/postinstall added, which performs various checks for  
         configuration file updates and changes, and can fix most of  
         the problems identified.  
         This should make it much easier to upgrade a system's  
         configuration from earlier systems (as far back as NetBSD 1.5).  
   
 20020320:  
         <bsd.lib.mk> needs a new install(1) for its "-a cmd" support.  
         Build and install at usr.bin/xinstall before the build.  
   
 20020319:  
         Raw IPv6 socket now makes strict checking for sa_family and sa_len  
         on send(2) operation.  Be sure to have sbin/rtsol and usr.sbin/rtsold  
         newer than November 2001 when you upgrade the kernel.  
   
 20020311:  
         ssh configuration files were moved from /etc to /etc/ssh.  Beware  
         if you restart your machine from remote.  Note that sshd.conf needs  
         to be changed (due to the use of "/etc" inside).  
   
 20020223:  
         Users of the VAX port will need to rebuild and install gas  
         so it deal with the now present register prefix used in all  
         the VAX assembly files.  
   
 20020118:  
         ntpd user/group has been added.  Need to hand add this in or builds  
         will break as mtree aborts early.  
   
         Add the following into /etc/group:  
   
         ntpd:*:15:  
   
         and the following to /etc/master.passwd (via vipw):  
   
         ntpd:*:15:15::0:0:Ntpd pseudo-user:/var/chroot/ntpd:/sbin/nologin  
   
 20011207:  
         If you're attempting to build a snapshot on sparc64 and are getting  
         reloc errors from the toolchain groff binary this means your native  
         toolchain has some broken C++ bits.  
   
         To fix:  
   
         Build a new toolchain (i.e. build.sh -t)  
         Use the new toolchain to build and install natively (i.e. /usr/lib)  
   
         gnu/lib/libgcc  
         gnu/lib/libstdc++  
   
         After this a snapshot will be able to be built.  
   
 20011201:  
         In order for a sparc64 build to work you must have a working awk. If  
         you've built and installed a system with the new toolchain up to this  
         point you do not have a working awk as its ability to do floating  
         point is broken.  
   
         To build:  
   
         remake and install gnu/lib/libgcc  
         remake and install gnu/usr.bin/gawk into /usr/bin (make sure it links  
         against the new libgcc.a)  
   
 20011128:  
         Kernel config information was changed to use defflag in  
         the various "files" files.  Bug fixes to config(8) are  
         required in order for this to work properly.  Make sure  
         to build and install in usr.sbin/config before attempting  
         to build a new kernel.  
   
 20011030:  
         libc/locale/wcstod.c now needs new lint(1). Update lint(1)  
         before building libc.  
   
 20011029:  
         The new document BUILDING.mdoc (view with nroff | more, or  
         see pre-generated .txt and .html versions) describes the build  
         procedure in great detail.  BUILDING, and the USE_NEW_TOOLCHAIN  
         build process, are intended in the long run to replace this  
         manual update log.  
   
         Users building a USE_NEW_TOOLCHAIN system should read the  
         BUILDING document for caveats.  Generally, BUILDING supersedes  
         UPDATING for these systems, as tool updating is taken care of  
         by the new build system.  
   
 20011028:  
         src/etc/Makefile now needs install to be able to handle  
         symlinks that point to nowhere. A bug in install that  
         prevented this was corrected.  
   
         Solution: update and reinstall usr.bin/xinstall  
         Better Solution: Use the new toolchain and it will just work  
         for you.  
   
 20011006:  
         /etc/mtree/NetBSD.dist has been updated to take advantage of  
         absolute path support added to mtree(8). Older mtree(8)s don't  
         understand the format.  
   
         Solution: update and reinstall usr.sbin/mtree  
   
 20011004:  
         Crunchgen has been updated to work via reach-over makefiles. Updating  
         is suggested before running a snapshot build  
   
 20010915:  
         The new "ubcperf" code committed by Chuck Silvers removed  
         a header file, uvm/uvm_vnode.h.  There may be stale .depend  
         files that still reference this file.  
   
         Solution: "make cleandir && make dependall" in affected  
         directories.  
   
 20010803:  
         grep.info is now built from grep.texi using makeinfo.  Since it  
         requires makeinfo v4.0, you need to install new texinfo before  
         building gnu/usr.bin/grep.  To install new texinfo, please follow  
         the instruction described in 20010726 entry.  
   
 20010803:  
         (i386 only): i386 kernel now uses new instructions like  
         `fxsave' which old gas doesn't understand.  To build the  
         kernel successfully, you need to build and install a new toolchain,  
         (i.e., build.sh -t) or  (temporarily) comment out "options I686_CPU"  
         from your kernel configuration until you rebuild your userland.  
         See 20011029 above and BUILDING file in this directory for more information.  
         [updated 20020630 since i386 gas moved when USE_NEW_TOOLCHAIN enabled]  
   
 20010731:  
         Bootloader update on ELF platforms.  DDB in kernels from before  
         this will be unable to read symbol tables provided by newer  
         bootloaders.  
   
 20010726:  
         Texinfo was updated to 4.0.  To avoid failures when trying to  
         build the included texinfo files, do:  
   
         cd src/gnu/usr.bin/texinfo  
         make MKINFO=no dependall install  
   
 20010718:  
         Enabled correct .init/.fini processing in crt0.  The way this  
         was done was to change a -I directive to cc(1), which means  
         make(1) will have a stale dependency (it will be checking the  
         timestamp on the wrong "dot_init.h").  
   
         The symptom you will see is that new programs die with SIGSEGV  
         if you have a stale dependency.  
   
         Solution: "make cleandir" in both lib/csu and libexec/ld.elf_so  
         before starting your build.  
   
 20010628:  
         A construct was added to uvm_page.h that uncovered a bug  
         in lint(1).  If you get a warning/error about a non-portable  
         bitfield, update your lint(1) before proceeding.  
   
 20010226:  
         Added named user/group to system. Need to hand add this in or builds  
         will break as mtree aborts early.  
   
         To work around add by hand:  
   
         named:*:14:  
   
         to /etc/group and add:  
   
         named:*:14:14::0:0:Named pseudo-user:/var/named:/sbin/nologin  
   
         to master.passwd (use vipw for instance if doing by hand).  
   
         Now a make build should progress.  
   
 20010219:  
         get/setprogname() added. Any hostprogs that may use this will need  
         to be bootstrapped manually until the host system is current.  
   
         Known problems: sys/arch/macppc/stand/fixcoff  
                         usr.sbin/config (adding -DMAKE_BOOTSTRAP to  
                           CFLAGS and rebuilding should work)  
                         usr.sbin/mdsetimage - Build a static copy if  
                           building a snapshot before fully bootstrapped.  
   
 20010204:  
         prepare the code to compile with stricter gcc flags. in  
         particular start eliminating redundant declarations. Yacc  
         needs to be installed before make build.  
   
 20010114:  
         introduce .if commands(target) in make(1). You need to  
         bring everything up-to-date first, then without installing  
         anything make and install in usr.bin/make, then proceed  
         with make build.  
   
 20010101:  
         bsd.subdir.mk committed 20001230 had a bug which caused  
         afterinstall targets to run too soon; update again.  
   
 20001230:  
         New share/mk files needed to support .WAIT in SUBDIR variables.  
         If you get make errors,  
                 (cd share/mk; make install)  
         Also, PRINTOBJDIR has changed and is now used more heavily.  
   
 20001019:  
         The `ca' device driver has been replaced by `ld'; although the  
         major and minor numbers haven't changed, you should update your /dev  
         directory.  
   
 20000929:  
         The following make directives are obsoleted.  
         MKCRYPTO_RSA NOCRYPTO_RSA NOCRYPTO_RC5 NOCRYPTO_IDEA  
         By default, RSA is built into libcrypto.  IDEA and RC5 will not be  
         built into libcrypto.  By using MKCRYPTO_{RC5,IDEA}, you can build  
         additional library libcrypto_{idea,rc5}.  
   
   
 Hints for a more successful build:  Hints for a more successful build:
 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
     Use build.sh, but do not use its "expert mode":      Use build.sh, but do not use its "expert mode":
         This will will automatically build the tools in the          This will automatically build the tools in the
            correct order, and it will keep the tools and the             correct order, and it will keep the tools and the
            new build products from interfering with the running             new build products from interfering with the running
            system.  This will allow you to ignore most of the             system.  This will allow you to ignore most of the
Line 722  cd $NETBSDSRCDIR && make cleandir
Line 334  cd $NETBSDSRCDIR && make cleandir
   
 Critical utilities:  Critical utilities:
 ^^^^^^^^^^^^^^^^^^^  ^^^^^^^^^^^^^^^^^^^
         gnu/usr.bin/egcs  
         usr.bin/compile_et          usr.bin/compile_et
         usr.bin/make          usr.bin/make
         usr.bin/yacc          usr.bin/yacc
         usr.bin/lex          usr.bin/lex
         usr.bin/xlint          usr.bin/xlint
         usr.sbin/config          usr.bin/config
   
 Other problems and possible solutions:  Other problems and possible solutions:
 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
 Symptom:Unreasonable compiler errors.  
 Fix:    Rebuild gnu/usr.bin/egcs  
   
 Symptom:Complaints involving a Makefile.  Symptom:Complaints involving a Makefile.
 Fix:    Rebuild usr.bin/make:  Fix:    Rebuild usr.bin/make:
         cd usr.bin/make && make && make install          cd usr.bin/make && make && make install
Line 745  Fix: Make sure .mk files are up to date.
Line 353  Fix: Make sure .mk files are up to date.
         cd share/mk && make install          cd share/mk && make install
   
 Symptom:Kernel `config' fails to configure any kernel, including GENERIC.  Symptom:Kernel `config' fails to configure any kernel, including GENERIC.
 Fix:    Rebuild usr.sbin/config  Fix:    Rebuild usr.bin/config
   
 Symptom:  Symptom:
 Fix:    Rebuild usr.bin/yacc  Fix:    Rebuild usr.bin/yacc
Line 771  Fix: Build and install usr.bin/mklocale
Line 379  Fix: Build and install usr.bin/mklocale
 Symptom:undefined reference to `__assert13' or `__unsetenv13'  Symptom:undefined reference to `__assert13' or `__unsetenv13'
 Fix:    Rebuild and install lib/libc  Fix:    Rebuild and install lib/libc
   
 Symptom:usr.sbin/config fails to build.  Symptom:usr.bin/config fails to build.
 Fix:    Try building with -DMAKE_BOOTSTRAP added to CFLAGS in Makefile.  Fix:    Try building with -DMAKE_BOOTSTRAP added to CFLAGS in Makefile.
   
 Symptom:undefined reference to `getprogname' or `setprogname'  Symptom:undefined reference to `getprogname' or `setprogname'

Legend:
Removed from v.1.125  
changed lines
  Added in v.1.187

CVSweb <webmaster@jp.NetBSD.org>