[BACK]Return to UPDATING CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / src

Please note that diffs are not public domain; they are subject to the copyright notices on the relevant files.

Diff for /src/UPDATING between version 1.135.2.1 and 1.205

version 1.135.2.1, 2005/04/20 11:40:16 version 1.205, 2009/11/16 07:39:54
Line 16  See also: BUILDING, build.sh, Makefile.
Line 16  See also: BUILDING, build.sh, Makefile.
 Recent changes:  Recent changes:
 ^^^^^^^^^^^^^^^  ^^^^^^^^^^^^^^^
   
 20050417:  20091101:
         postinstall(8) was moved from /etc to /usr/sbin and made part          After updating, it may be necessary to make the 'cleandir'
         of the "base" set, to make it easier to invoke after an          target in src/tools/yacc/ and in src/usr.bin/yacc/ before a
         upgrade.          'build.sh -u tools' or 'build.sh -u distribution'.  Ditto
           src/tools/lex/ and src/usr.bin/lex/.
 20050211:  
         Fixes to tools/Makefile.gnuhost may cause UPDATE=1 builds in  20091001:
         some of the cross tools to fail if they use configure. Some configure's          An error will create a ./usr/X11R7/lib/X11/xkb/compiled/xkb
         cache the environment passed in and notice the new environment is          symlink, failing the build.  Delete the link, and the subdir
         different and abort. Doing a clean in tools/ should be enough to          it is in, and retry your build.
         make a build continue.  
   20090718:
 20050109:          libc build changed so that strchr() provides the extra entry
         Since su is using pam by default now, make sure that you have          point for index(). Update build of libc.a (and libc_pic.a)
         /etc/pam.d populated (postinstall will do that automatically          may fail because the archive contains the unwanted index.o.
         for you). Otherwise su will fail open (i.e. will not require          (Similarly for strrchr() and rindex().)
         a password).  
   20090709:
 20041229:          Native Xorg was upgraded again.  Builds will probably fail again
         Make had a path resolution bug that manifested itself as not          without a clean objdir, at least for src/external/mit/xorg.
         being able to install openpam.3. This bug has been fixed, but  
         you might need to rebuild make manually first to get through  20090616:
         the build.          Native Xorg was upgraded.  Builds will need a clean objdir for
           src/external/mit/xorg.  Upgrading a system from sets will not
 20041201:          work properly yet as the /usr/X11R7/lib/X11/xkb/symbols/pc
         Userland programs have been changed to use /dev/bpf instead of          subdirectory has been changed into a file, and this needs to
         /dev/bpfX. You need to create that device by installing a new          be manually "rm -r"'ed before installing xbase.tgz.
         MAKEDEV and running it, or mv /dev/bpf0 /dev/bpf && rm /dev/bpf[0-9]*  
   20090501:
 20041006:          Several new functions were added to string.h/libc, and this
           can cause autoconf problems during the tool build for people
         A bug was introduced into /bin/sh (var.c rev 1.35) which causes          who fail to clean out their tools objects properly. If you
         variables to not export correctly to subshells in all cases. This          note messages about stpcpy, stpncpy or strnlen accompanying a
         will cause builds to break if that version of /bin/sh is installed          failure during the tool build, clean out all your tools
         on the system. The proper version of /bin/sh can be verified with:          objects and start again.
   
         ident /bin/sh | grep var  20090325:
           The i386 port was switched to i486 default toolchain.  This requires
         Any /bin/sh w. version 1.35 will not work and needs to be updated          cleaning your src/tools directory and $TOOLDIR and rebuilding them.
         before attempting a build.  
   20090126:
 20041001:          The __posix_fadvise50 system call changed assembly stub type. You need to
         The ipfilter kernel sources moved from sys/netinet to          'rm -f __posix_fadvise50.*' in the libc build directory to avoid using
         dist/sys/ipf/netinet. Due to the move some Makefile          the old assembly stub.
         dependencies are now dangling requiring a make cleandir  
         before they work again (kdump, ktruss, rescue, ipf, and  20090202:
         ftp-proxy are the victims).          pkg_install now depends on the pkgdb cache for automatic conflict
           detection.  It is recommented to rebuild the cache with
 20040715:          ``pkg_admin rebuild''.
         The rc.d/sendmail script now uses a heuristic to determine  
         if sendmail should be started at boot time.  It checks the  20090110:
         contents of /etc/mailer.conf, /etc/mail/submit.cf, and the          time_t and dev_t have been bumped to 64 bit quantities. To upgrade:
         owner and mode of the sendmail binary to see if any changes          1. Make sure your kernel has COMPAT_50 in it. Build and install.
         to the mail infrastructure have been made.  If no changes             This is needed even in the MODULAR kernel because there is
         are detected, it will start an SMTP listener.             conditionally compiled code in rtsock.c.
           2. make sure build.sh completes and the binaries in a chroot work
         Setting sendmail=NO in /etc/rc.conf will override this.             before installing.
           3. If you don't use build.sh and you build directly to root, and
         If you are only using sendmail by default and only for             your build breaks in the middle, don't despair. Make sure headers
         local delivery, it is important that you also update your             are installed properly, and start building libraries first libc
         sendmail.cf so that the SMTP listener only listens on the             and libutil, install them and then continue building all the
         loopback interface.             libraries in src/lib and src/gnu/lib and install them. Once
              the new libraries are installed, you can restart the build.
 20040715:          4. If you compile packages and you notice link time warnings,
         The method by which athhal-elf.o gets pulled into i386             rebuild the required packages to update their shared libraries.
         kernel builds has been changed again.  The latest version             Any package you rebuild will require rebuilding all the packages
         of bsd.files.mk is no longer required.             that depend on it.
           5. Next time you run pwd_mkdb with the new binary, the file
 20040621:             will be upgraded and it will not be backwards compatible.
         Due to the recent rototill of tools/compat it's crucial one starts          6. The utmpx/wtmpx files (/var/run/utmpx and /var/log/wtmpx, see
         from a clean objdir under tools/*.             lastlogx(5)) have been versioned, and there is a heuristic
              for utmp. You are better off removing the old files after
         This is mostly due to generated files (yacc and lex sources) needing             upgrading.  The automated clearing of /var/run during
         to be generated with new rules from bsd.hostprog.mk.             boot, and the automated rotating of files in /var/log by
              newsyslog(8), may mean that you do not have to remove the
         The safest course is to rm -rf all objects under tools before building.             files manually.
           7. The optional accounting file (/var/account/acct, see
 20040516:             accton(8)) has not been versioned, and will need to be
         The end-user modifiable X11 configuration has been moved             removed.  The automatic rotation of the accounting file by
         from /usr/X11R6/lib/X11/<dir> to /etc/X11/<dir>.             /etc/daily limits the bad consequences of failure to remove
         Ensure that src and xsrc is up to date, and run             the file.
         "make cleandir" in src/x11 before your next build.          8. Application software that writes time_t to binary files on
              disk will break or need attention. Most notably: if you are
         postinstall currently doesn't migrate the files from             using PostgreSQL < 8.4, you need to dump your databases,
         /usr/X11R6/lib/X11/* to /etc/X11/* although it does             rebuild PostgreSQL with the new time_t, then restore.
         detect that this needs to occur, so you'll have to  
         manually move these files yourself.  20081219:
           config(1) has been updated, and one of the files it creates -
 20040426:          swapnetbsd.o - has changed format.  You need to rebuild config
         Support for the original dynamic sysctl node structure has          (done automatically by build.sh) and then you need to rerun
         been removed in favor of the newer layout.  This affects          config on all kernel configuration files before rebuilding those
         consumers of the create and delete interface, as well as          kernels.
         the dynamic discovery mechanism.  This is believed only to  
         be the sysctl(8) binary itself, at this point in time, so  20081205:
         the only effect of this should be that a sysctl binary          If you build with MKX11=no, you should remove /etc/rc.d/xdm and
         built from sources dated between 2003/12/04 and 2004/03/24          /etc/rc.d/xfs from DESTDIR because those files were moved to the xetc
         will not work on a kernel built from sources dated after          set and will appear as extra files for MKX11=no update builds.
         2004/04/25.  If you need a new sysctl binary but build.sh  
         does not work, make sure that your revision of  20081122:
         src/sys/sys/sysctl.h is 1.112 (or later), and then the          On i386, various kernel options(4) in GENERIC including
         do the following:          file systems have been disabled and moved into kernel modules.
           Before trying a new GENERIC kernel, you have to prepare the
         cd /usr/src (or wherever your source tree is)          following files as well as a new GENERIC kernel:
         make USETOOLS=no includes  
         cd lib/libc          - build and install kernel modules from src/sys/modules
         make USETOOLS=no dependall install  
         cd ../../sbin/sysctl          - install the latest bootloader, which will load a module
         make USETOOLS=no dependall install            for the file system from which the kernel is loaded automatically
   
         If you are using older sysctl binary, GNU autoconf would fail to          If you have to load your kernel from a file system which is not of
         identify your machine architecture, and tries to build binary for          the same type as the root file system, you have to load the necessary
         "unknown-unknown-netbsd20F" or something like that.  if that happens,          file system module manually on the boot prompt or in the boot.cfg file.
         make sure to follow the above steps.  
   20080827:
 20040425:          If you built and installed a libc from sources between
         The ffs superblock issues listed below under 20040109 and 20030402          2008/08/20 and 2008/08/26 you got a broken strtouq(3)
         are now automatically addressed by the /etc/rc.d/fixsb script or by          which results in false errors reported by lint(1).
         sysinst when it checks a a filesystem. The manual fsck_ffs -b16 -c4          Since this breaks the libc build itself, manual help is
         invocation mentioned below will continue to work and is now          needed -- lint must be disabled temporarily, e.g.:
         automated by those scripts.  Note that under certain circumstances,            $ (cd lib/libc && make MKLINT=no dependall install)
         affected filesystems upgraded to a -current kernel first before  
         upgrading their userland with the fixsb and fsck_ffs fixes may  20080813:
         encounter a 'freeing free inode' panic when writing to the affected          MKDEBUG build was broken because the .depend files did not know
         filesystem, so it is a good idea to repair the filesystem as soon as          about .go files. You need to remove all .depend files and rebuild.
         possible.  For more details on the fixsb script, see pr install/25138.  
   20080802:
 20040418:          A regression in binary compatibility for pthread_mutex_t has
         statfs(2) and friends have been replaced with statvfs(2). Before          been fixed. Unfortunately, the price is breaking compatibility
         installing a newly build userland make sure that you are running          for -current.
         a newly built kernel with COMPAT_20 set. In addition your libc  
         build might not work (undefined SYS_statfs symbol) because make          Threaded programs (using libpthread) and C++ programs (using
         clean does not know how to remove files it does not know about          libstdc++) compiled after 20070907 and before 20080802 need to
         anymore. Manually remove all generated .S sources and objects          be recompiled.
         from the libc build directory.  
           One way to find affected pkgsrc packages:
 20040326:  
         The method by which athhal-elf.o gets pulled into i386 kernel builds            $ grep REQUIRES=/usr/lib/libpthread /var/db/pkg/*/+BUILD_INFO
         has been changed. The file is now stored as a uuencoded file in CVS            $ grep REQUIRES=/usr/lib/libstdc++ /var/db/pkg/*/+BUILD_INFO
         and the generated Makefile will use the new .uue rules from bsd.file.mk  
         to build it.  20080731:
           WAPBL (metadata journaling support) has been added, but at this
         This means you must have the latest bsd.files.mk installed when          time isn't backwards compatible with pre-WAPBL aware kernels
         building a kernel without USETOOLS=yes.          and userland (fsck_ffs in particular).  Please make sure you
           don't use a journaled filesystem with an older kernel/userland,
 20040318:          especially an uncleanly mounted journaled filesystem.  WAPBL
         A bug in the cgd(4) blowfish code was corrected, without          also requires the super block to be in the UFS2 format.  You
         provision of backwards compatibility, after several public          can use fsck_ffs -c 4 to update the superblock format.
         notices over several months. Users of cgd with blowfish cipher  
         ONLY must dump their data before updating their kernels, and  20080721:
         recreate cgd's and restore data using the new kernel. See          Assembler warnings are now fatal if $WARNS>0 and $NOGCCERROR
         (recent message to current-users, URL when mail-index has updated)          isn't defined.
   
 20040313:  20080531:
         On acorn32, the opms and qms drivers have been withdrawn, and          The ioctl number of DRVSUSPENDDEV command on /dev/drvctl changed
         the old wsqms driver is now called qms.  Kernel config files          from 125 (conflicted with DRVCTLCOMMAND) to 129. The drvctl(8)
         will need updating.  See the ones in sys/arch/acorn32/conf          utility needs to be rebuilt and reinstalled as older binaries
         for examples.          won't work correctly. The following sequence of commands:
   
 20040125:            $ (cd sys/sys/ && nbmake-$arch includes)
         On acorn32, the beep and sysbeep devices are no longer            $ (cd sbin/drvctl/ && nbmake-$arch clean)
         needed, and will need to be deleted from kernel configuration            $ (cd sbin/drvctl/ && nbmake-$arch all)
         files.  
           leaves new drvctl utility in sbin/drvctl build directory.
 20040109:  
         Compatibility for old ffs superblock layouts has been  20080503:
         added, and the restrictive fsck checks have been reenabled          The <bsd.lib.mk> variable MKPRIVATELIB was renamed to LIBISPRIVATE.
         when using those layouts.  If you have been using -current  
         since 20030402, you may find that fsck again signals fatal  20080521:
         superblock mismatches.  To repair, make sure you have          For a while, unprivileged UPDATE builds would fail to
         an updated fsck_ffs and then you can use fsck_ffs -b 16 -c 4          succeed at the checkflist stage, complaining that
         to complete the filesystem upgrade.  A message has          ${DESTDIR}/stand/<arch>/ did not exist.  A fix for this
         been added to the kernel which should detect this problem.          problem was committed to share/mk/bsd.kmodule.mk, revision 1.9.
         See the following discussion for more information:          If you already hit this problem, update the .mk file,
         http://mail-index.NetBSD.org/current-users/2004/01/11/0022.html          remove ${DESTDIR}/stand/<arch>, and re-run the build.
   
 20031203:  20080303:
         New binutils builds may fail due to old dependencies.          Linker warnings are now fatal if $WARNS>0.
         It's necessary to "make cleandir" to ensure that  
         the dependencies will be rebuilt correctly.  20080126:
           The posix_fadvise system call has been changed from an assembly
 20031111:          stub, to a c file that calls an assembly stub. You need to
         A newer mkdep is needed.  Error noting that is          'rm -f posix_fadvise.* .depend' in the libc build directory to
                 cc: Ambiguous abbreviation --          avoid using the old assembly stub.
   
 20031008:  20071209:
         /usr/include/sys/disklabel_mbr.h was removed.          The acpiec(4) driver has been split into two attachments. If you
         It's necessary to "make cleandir" to ensure that          get ACPI errors before the attachment, please update your kernel
         the dependencies will be rebuilt correctly.          configuration file appropriately or see GENERIC for more details.
   
 20031007:  20071115:
         A sign exension bug was fixed which set all the high bits          The it(4) driver has been renamed to itesio(4) and the old port
         of our newly expanded ffs fs_flags.  This should only          argument specified in the kernel configuration file is not valid
         affect users who installed or upgraded in September of 2003.          anymore. The itesio(4) driver now uses the Super I/O address port
         A small utility program was posted to tech-kern which          rather than the EC address port. Please update your kernel
         should fix this problem, and a warning message was added          configuration file appropriately or see GENERIC for more details.
         to the kernel which should discover and warn about it.  See  
         http://mail-index.NetBSD.org/tech-kern/2003/10/07/0005.html  20071028:
           The pccons(4) driver has been removed from the NetBSD/shark port.
 20030906:          You need to update any custom kernel configuration file you have
         With the addition of siginfo support the old signal trampoline          to remove any references to pccons (which includes removing the
         code has been deprecated to COMPAT_16. Make sure that your running          now useless XSERVER option) and replace them with the correct
         kernel has COMPAT_16 enabled before building userland.          entries for the wscons driver.  See the GENERIC configuration file
           for more details.
 20030801:  
         With the new openssl, there is some header and library shuffling.  20070913:
         rm -f /usr/include/des.h /usr/include/kerberosIV/* /lib/libdes* \          A latent bug in dhclient/dhcpd that caused it to be unable to
         /usr/lib/libdes* before building.          enumerate interfaces was fixed.  The bug began to cause
           problems after 20070911 when the kernel's SIOCGIFCONF
 20030703:          implementation was repaired.  From 20070529 to 20070911 racoon
         Texinfo was updated to 4.6.  To avoid failures when trying to          could not enumerate interfaces.  (These are noted because
         build the included texinfo files, do:          normal kernel/userspace version matching hygiene is not
           sufficient to avoid this problem.)  Ensure that both kernel
         cd src/gnu/usr.bin/texinfo          and userland are from after 20070913.
         make MKINFO=no dependall install  
   20070703:
 20030630:          nbinstall has been renamed ${MACHINE_GNU_ARCH}-install. It
         Groff was updated to 1.19; it's probably necessary to do          calls the target-specific strip program, and the logic to pass
                 cd share/mk && make install          down STRIP from make has been removed.  This requires a
                 cd src/gnu/usr.bin/groff          re-installation of tools.
                 make MKMAN=no dependall install  
         (untested).  20070422:
           The way OS emulations lookup filenames inside the emulation root
 20030516:          has been changed.  Rather than modify the pathname (and copy back
         Due to bugs in the export handling code, invalid export lines          to userspace) namei() and lookup() directly check the emulation
         were accepted before and caused the kernel to panic when          root. One side effect is that absolute symlinks inside the emulated
         mountd got restarted because it freed memory that had already          root file system will be relative to that file system - unless they
         been freed. This has been fixed and the kernel checks          start /../ this is useful when the emulated root is a real install
         export addresses very strictly. If you upgrade your kernel,          that has such links.
         make sure you also upgrade mountd, because if your export          This might affect symlinks that have been added to reference outside
         file contains lines with an old inet4 address syntax (i.e.          the emulated root.
         a.b.c or a.b or a), they will get rejected by the new kernel.  
   20070412:
 20030402:          The pckbc driver on sgimips IP32 has been removed. Use macekbc
         The superblock layout for FFS was changed.  If you have 1.6          instead. See the GENERIC32_IP3x kernel configuration for an
         fsck binaries, they will signal a fatal superblock mismatch          example.
         with the first alternate, because they compare too many  
         fields (even ones that aren't useful).  If possible, upgrade  20070319:
         your fsck_ffs binary before using a new kernel.          src/lib/libc/Makefile revision 1.129 broke libc and ld.elf_so
         None of this signals actual filesystem damage.          on many platforms due to incorrect flags settings.  If you
           updated and built after about 20070315, do "nbmake-$arch
 20030324:          cleandir" in src/lib/libc and src/libexec/ld.elf_so to force a
         sendmail version 8.12.8 was imported.  Since sendmail is          rebuild of object files that might have been built
         now setgid to the smmsp group, and runs in "collection"          incorrectly, and ensure that you have at least
         mode for most common activities, there is a new config          src/lib/libc/Makefile 1.130.
         file called submit.cf that needs to live in /etc/mail.  
         The generic submit.cf sample in /usr/share/sendmail/cf  20070210:
         is named netbsd-msp.cf.  Upgrading your regular sendmail          src/sys/sys/{sa.h,savar.h} were removed.
         configuration file is also strongly advised.            find ${OBJDIR} \( -name .depend -o -name '*.d' \) -print \
                 | xargs egrep -l '/sa.h|/savar.h' | xargs rm
         See the section named "MESSAGE SUBMISSION PROGRAM" in          will allow dependencies on those files to get get rebuilt
         the updated /usr/share/sendmail/README file for more  
         information.  20070209:
           The threading model was changed when the newlock2 branch
 20030117:          was merged to NetBSD-current.  If you boot with a new
         Texinfo was updated to 4.3.  To avoid failures when trying to          kernel (version 4.99.10), then you also need a new pthread
         build the included texinfo files, do:          library (/usr/lib/libpthread.so.0.7).  If you boot with
           an old kernel, then you need the old pthread library
         cd src/gnu/usr.bin/texinfo          (/usr/lib/libpthread.so.0.6).  Provided you keep the kernel and
         make MKINFO=no dependall install          the pthread library in sync, old threaded applications should
           continue to work with an old or new kernel.  Note that named(8)
 20021223:          is the only threaded application in the base system.
         The METALOG format changed slightly, to remove the leading  
         "${DESTDIR}" from path names.  20061214:
         This only affects people building with UNPRIVED.          Following the move of string_to_flags() and flags_to_string()
         For complete safety, remove the DESTDIR entirely and          from the bin/ls/ sources to libutil, users doing UPDATE builds
         update tools/mtree, before running make build.          will need to do a "make cleandir" in
                   tools/mtree/, tools/makefs/, tools/binstall/, tools/pax/,
 20021219:                  bin/pax/, bin/ls/, usr.sbin/mtree/, usr.sbin/makefs/,
         CVS repository layout was changed.  See the following for details                  usr.bin/xinstall/, libexec/ftpd/, rescue/, as well
         if you are using (anonymous) cvs to update your tree.                  as the installation images in distrib/
           in order to excise stale references to the old stat_flags.h header
         http://mail-index.NetBSD.org/netbsd-announce/2002/12/19/0000.html          file in the ls sources -- stat_flags.h has been removed.
   
 20021219:  20061108:
         install(1) had a '-N dbdir' option added, to specify an          The configure script used in the src/tools/gcc compiler has been
         alternate location to look up users & groups (instead          changed to indicate that our libc has ssp support built-in and
         of the host system passwd(5) and group(5) databases).          does not depend on -lssp and -lssp-nonshared. You'll need to
           make clean in src/tools/gcc first to rebuild the compiler.
         The build system was modified to take advantage of  
         this option (using ${NETBSDSRCDIR}/etc), so if you  20061009:
         use USETOOLS==no, you may have to rebuild and          The sysctl variables net.inet{,6}.tcp{,6}.newreno are no longer
         reinstall usr.bin/xinstall first.          available. Use net.inet{,6}.tcp{,6}.congctl.selected instead.
   
 20021130:  20060814:
         fparseln(3) moved from libutil to libc.          The vt, vidcconsole, kbd, and rpckbd drivers on acorn32 have been
         If building to DESTDIR=/, reinstall the includes          withdrawn.  Use vidcvideo and pckbd instead.  See the GENERIC
         and rebuild libc:          kernel configuration for an example.  X servers from the last
                 make includes          few years should cope.
                 make do-lib-libc  
         If using build.sh, "cd tools/compat && make clean"  20060703:
         before rebuilding the tools.          MPACPI is no more. We always configure PCI interrupts using ACPI
           if we have an ACPI kernel. The option MPACPI_SCANPCI has been renamed
 20021126:          to ACPI_SCANPCI. Thanks to work from fvdl.
         The mk.conf(5) variable SYS_INCLUDE has been deprecated,  
         including the optional "SYS_INCLUDE=symlinks" support.  20060627:
         All header files, including <sys/*.h> are copied into          socket(2) has changed, and its system call has been versioned.
         /usr/include.          For userlands with the old version of socket(2), make sure that
           your kernel has 'options COMPAT_30' set, or else 'bad system call'
 20021121:          errors will result.
         The C run-time support files crtbegin.o and crtend.o  
         (and their companions crtbeginS.o and crtendS.o) were  
         split up, with new crti.o and crtn.o files resulting.  
         This means that libtool needs to be rebuilt once the  
         new libraries are installed.  The process of rebuilding  
         libtool will cause it to automatically notice the new  
         required files, but it *must* be rebuilt in order to  
         do this.  
   
         An out-of-date libtool will result in shared libraries  
         which lack _init() and _fini() routines, which means that  
         their global contructors/destructors will not be invoked.  
   
 20021121:  
         A bug related to how ARM ELF objects were tagged has been  
         corrected.  
   
         NetBSD ARM ELF uses the soft-VFP floating point model by  
         default.  However, the assembler lacked support for marking  
         objects as using the VFP floating point format, and the  
         compiler was not properly passing the flag indicating "soft-VFP"  
         to the assembler.  
   
         Unfortunately, this means that the linker will now consider  
         old (i.e. not marked "softvfp") NetBSD ARM ELF objects to be  
         incompatible with new (properly marked) objects.  
   
         The problem will only manifest itself if you attempt to compile  
         a new program using the fixed toolchain, and link that program  
         against old libraries which do not have the proper "softvfp"  
         markings.  ALL OF YOUR EXISTING BINARIES AND SHARED LIBRARIES  
         WILL CONTINUE TO WORK PROPERLY.  
   
         The only work-around for the problem is to recompile all of  
         the libraries on the system.  The easiest way to do this for  
         system libraries is to install a binary snapshot; they are  
         generally available on releng.NetBSD.org.  Any packages you  
         have installed which supply libraries will have to be recompiled  
         if you wish to link new programs against those libraries.  
   
         If you have questions about this matter, please contact  
         port-arm@NetBSD.org.  
   
 20021011:  
         Systrace has been improved to support privilege elevation.  
         Updating the kernel requires the userland part of systrace  
         to be rebuilt.  
   
 20021010:  
         The config(8) grammar was changed to allow options to register  
         dependencies on attributes, as well as other options.  Users  
         must update and reinstall usr.sbin/config before building a new  
         kernel.  
   
 20021009:  
         A new attribute dependency syntax was introduced to config(8),  
         which is now used by the SCSI configuration description.  Users  
         must update and reinstall usr.sbin/config before building a new  
         kernel.  
   
 20021003:  
         Several changes have been made to the autoconfiguration  
         framework.  Users must update and reinstall usr.sbin/config  
         before building a new kernel.  
   
 20021001:  
         The i386mp branch has been merged.  To compile a kernel, users  
         will need to add the option 'cpu* at mainbus?' to their configuration  
         file.  Multiprocessor kernels will need  
         ioapic*         at mainbus? apid ?  
         options         MULTIPROCESSOR  
         options         COM_MPLOCK  
   
 20020922:  
         MKDYNAMICROOT=yes enabled by default, which means that  
         certain shared libraries are installed into /lib, the shared  
         linker is installed into /libexec, and all programs in /bin  
         and /sbin are dynamically linked.  
         If you do not use "make build", you should ensure that  
         you have the libraries and shared linker in the new locations,  
         with:  
                 make do-lib-csu do-lib-libc do-lib do-gnu-lib do-ld.elf_so  
   
 20020917:  
         USE_NEW_TOOLCHAIN has been replaced with:  
             -   TOOLCHAIN_MISSING -- set to "yes" on platforms for which  
                 there is no working in-tree toolchain (hppa, ns32k, sh5,  
                 x86_64).  
             -   EXTERNAL_TOOLCHAIN -- if defined by the user, points to the  
                 root of an external toolchain (e.g. /usr/local/gnu).  This  
                 enables the cross-build framework even for TOOLCHAIN_MISSING  
                 platforms.  
   
 20020906:  
         gehenna-devsw has been merged into the trunk. Need to update and  
         reinstall usr.sbin/config before building the kernel.  
   
 20020822:  
         Crunched rescue tools (contents of /bin and /sbin, plus others)  
         are now provided in /rescue.  
   
         To ensure that these are built statically linked (no matter  
         what the setting of LDSTATIC is), use a crunchgen(1) built  
         from sources newer than 20020820 (see the next entry).  
   
 20020820:  
         crunchgen(1) changed to ensure that the generated program  
         is statically linked.  
   
         Solution: update and reinstall usr.bin/crunch  
   
 20020605:  
         smmsp user/group has been added for sendmail.  
   
         Add the following into /etc/group:  
   
         smmsp:*:17:  
   
         and the following to /etc/master.passwd (via vipw):  
   
         smmsp:*:17:17::0:0:Sendmail Message Submission Program:/nonexistent:/sbin/nologin  
   
 20020515:  
         sshd user/group has been added.  Need to hand add this in, or sshd  
         will not let you log in (with default, or UsePrivlegeSeparation=yes)  
   
         Add the following into /etc/group:  
   
         sshd:*:16:  
   
         and the following to /etc/master.passwd (via vipw):  
   
         sshd:*:16:16::0:0:& pseudo-user:/var/chroot/sshd:/sbin/nologin  
   
         Also /var/chroot/sshd directory needs to be present (digged as part of  
         the build process).  
   
 20020426:  
         NBUILDJOBS obsoleted in favor of just using -j.  
   
 20020426:  
         etc/postinstall added, which performs various checks for  
         configuration file updates and changes, and can fix most of  
         the problems identified.  
         This should make it much easier to upgrade a system's  
         configuration from earlier systems (as far back as NetBSD 1.5).  
   
 20020320:  
         <bsd.lib.mk> needs a new install(1) for its "-a cmd" support.  
         Build and install at usr.bin/xinstall before the build.  
   
 20020319:  
         Raw IPv6 socket now makes strict checking for sa_family and sa_len  
         on send(2) operation.  Be sure to have sbin/rtsol and usr.sbin/rtsold  
         newer than November 2001 when you upgrade the kernel.  
   
 20020311:  
         ssh configuration files were moved from /etc to /etc/ssh.  Beware  
         if you restart your machine from remote.  Note that sshd.conf needs  
         to be changed (due to the use of "/etc" inside).  
   
 20020223:  
         Users of the VAX port will need to rebuild and install gas  
         so it deal with the now present register prefix used in all  
         the VAX assembly files.  
   
 20020118:  
         ntpd user/group has been added.  Need to hand add this in or builds  
         will break as mtree aborts early.  
   
         Add the following into /etc/group:  
   
         ntpd:*:15:  
   
         and the following to /etc/master.passwd (via vipw):  
   
         ntpd:*:15:15::0:0:Ntpd pseudo-user:/var/chroot/ntpd:/sbin/nologin  
   
 20011207:  
         If you're attempting to build a snapshot on sparc64 and are getting  
         reloc errors from the toolchain groff binary this means your native  
         toolchain has some broken C++ bits.  
   
         To fix:  
   
         Build a new toolchain (i.e. build.sh -t)  
         Use the new toolchain to build and install natively (i.e. /usr/lib)  
   
         gnu/lib/libgcc  
         gnu/lib/libstdc++  
   
         After this a snapshot will be able to be built.  
   
 20011201:  
         In order for a sparc64 build to work you must have a working awk. If  
         you've built and installed a system with the new toolchain up to this  
         point you do not have a working awk as its ability to do floating  
         point is broken.  
   
         To build:  
   
         remake and install gnu/lib/libgcc  
         remake and install gnu/usr.bin/gawk into /usr/bin (make sure it links  
         against the new libgcc.a)  
   
 20011128:  
         Kernel config information was changed to use defflag in  
         the various "files" files.  Bug fixes to config(8) are  
         required in order for this to work properly.  Make sure  
         to build and install in usr.sbin/config before attempting  
         to build a new kernel.  
   
 20011030:  
         libc/locale/wcstod.c now needs new lint(1). Update lint(1)  
         before building libc.  
   
 20011029:  
         The new document BUILDING.mdoc (view with nroff | more, or  
         see pre-generated .txt and .html versions) describes the build  
         procedure in great detail.  BUILDING, and the USE_NEW_TOOLCHAIN  
         build process, are intended in the long run to replace this  
         manual update log.  
   
         Users building a USE_NEW_TOOLCHAIN system should read the  
         BUILDING document for caveats.  Generally, BUILDING supersedes  
         UPDATING for these systems, as tool updating is taken care of  
         by the new build system.  
   
 20011028:  
         src/etc/Makefile now needs install to be able to handle  
         symlinks that point to nowhere. A bug in install that  
         prevented this was corrected.  
   
         Solution: update and reinstall usr.bin/xinstall  
         Better Solution: Use the new toolchain and it will just work  
         for you.  
   
 20011006:  
         /etc/mtree/NetBSD.dist has been updated to take advantage of  
         absolute path support added to mtree(8). Older mtree(8)s don't  
         understand the format.  
   
         Solution: update and reinstall usr.sbin/mtree  
   
 20011004:  
         Crunchgen has been updated to work via reach-over makefiles. Updating  
         is suggested before running a snapshot build  
   
 20010915:  
         The new "ubcperf" code committed by Chuck Silvers removed  
         a header file, uvm/uvm_vnode.h.  There may be stale .depend  
         files that still reference this file.  
   
         Solution: "make cleandir && make dependall" in affected  
         directories.  
   
 20010803:  
         grep.info is now built from grep.texi using makeinfo.  Since it  
         requires makeinfo v4.0, you need to install new texinfo before  
         building gnu/usr.bin/grep.  To install new texinfo, please follow  
         the instruction described in 20010726 entry.  
   
 20010803:  
         (i386 only): i386 kernel now uses new instructions like  
         `fxsave' which old gas doesn't understand.  To build the  
         kernel successfully, you need to build and install a new toolchain,  
         (i.e., build.sh -t) or  (temporarily) comment out "options I686_CPU"  
         from your kernel configuration until you rebuild your userland.  
         See 20011029 above and BUILDING file in this directory for more information.  
         [updated 20020630 since i386 gas moved when USE_NEW_TOOLCHAIN enabled]  
   
 20010731:  
         Bootloader update on ELF platforms.  DDB in kernels from before  
         this will be unable to read symbol tables provided by newer  
         bootloaders.  
   
 20010726:  
         Texinfo was updated to 4.0.  To avoid failures when trying to  
         build the included texinfo files, do:  
   
         cd src/gnu/usr.bin/texinfo  
         make MKINFO=no dependall install  
   
 20010718:  
         Enabled correct .init/.fini processing in crt0.  The way this  
         was done was to change a -I directive to cc(1), which means  
         make(1) will have a stale dependency (it will be checking the  
         timestamp on the wrong "dot_init.h").  
   
         The symptom you will see is that new programs die with SIGSEGV  
         if you have a stale dependency.  
   
         Solution: "make cleandir" in both lib/csu and libexec/ld.elf_so  
         before starting your build.  
   
 20010628:  
         A construct was added to uvm_page.h that uncovered a bug  
         in lint(1).  If you get a warning/error about a non-portable  
         bitfield, update your lint(1) before proceeding.  
   
 20010226:  
         Added named user/group to system. Need to hand add this in or builds  
         will break as mtree aborts early.  
   
         To work around add by hand:  
   
         named:*:14:  
   
         to /etc/group and add:  
   
         named:*:14:14::0:0:Named pseudo-user:/var/named:/sbin/nologin  
   
         to master.passwd (use vipw for instance if doing by hand).  
   
         Now a make build should progress.  
   
 20010219:  
         get/setprogname() added. Any hostprogs that may use this will need  
         to be bootstrapped manually until the host system is current.  
   
         Known problems: sys/arch/macppc/stand/fixcoff  
                         usr.sbin/config (adding -DMAKE_BOOTSTRAP to  
                           CFLAGS and rebuilding should work)  
                         usr.sbin/mdsetimage - Build a static copy if  
                           building a snapshot before fully bootstrapped.  
   
 20010204:  
         prepare the code to compile with stricter gcc flags. in  
         particular start eliminating redundant declarations. Yacc  
         needs to be installed before make build.  
   
 20010114:  
         introduce .if commands(target) in make(1). You need to  
         bring everything up-to-date first, then without installing  
         anything make and install in usr.bin/make, then proceed  
         with make build.  
   
 20010101:  
         bsd.subdir.mk committed 20001230 had a bug which caused  
         afterinstall targets to run too soon; update again.  
   
 20001230:  
         New share/mk files needed to support .WAIT in SUBDIR variables.  
         If you get make errors,  
                 (cd share/mk; make install)  
         Also, PRINTOBJDIR has changed and is now used more heavily.  
   
 20001019:  
         The `ca' device driver has been replaced by `ld'; although the  
         major and minor numbers haven't changed, you should update your /dev  
         directory.  
   
 20000929:  
         The following make directives are obsoleted.  
         MKCRYPTO_RSA NOCRYPTO_RSA NOCRYPTO_RC5 NOCRYPTO_IDEA  
         By default, RSA is built into libcrypto.  IDEA and RC5 will not be  
         built into libcrypto.  By using MKCRYPTO_{RC5,IDEA}, you can build  
         additional library libcrypto_{idea,rc5}.  
   
   
 Hints for a more successful build:  Hints for a more successful build:
 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Line 775  cd $NETBSDSRCDIR && make cleandir
Line 416  cd $NETBSDSRCDIR && make cleandir
   
 Critical utilities:  Critical utilities:
 ^^^^^^^^^^^^^^^^^^^  ^^^^^^^^^^^^^^^^^^^
         gnu/usr.bin/egcs  
         usr.bin/compile_et          usr.bin/compile_et
         usr.bin/make          usr.bin/make
         usr.bin/yacc          usr.bin/yacc
         usr.bin/lex          usr.bin/lex
         usr.bin/xlint          usr.bin/xlint
         usr.sbin/config          usr.bin/config
   
 Other problems and possible solutions:  Other problems and possible solutions:
 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
 Symptom:Unreasonable compiler errors.  
 Fix:    Rebuild gnu/usr.bin/egcs  
   
 Symptom:Complaints involving a Makefile.  Symptom:Complaints involving a Makefile.
 Fix:    Rebuild usr.bin/make:  Fix:    Rebuild usr.bin/make:
         cd usr.bin/make && make && make install          cd usr.bin/make && make && make install
Line 798  Fix: Make sure .mk files are up to date.
Line 435  Fix: Make sure .mk files are up to date.
         cd share/mk && make install          cd share/mk && make install
   
 Symptom:Kernel `config' fails to configure any kernel, including GENERIC.  Symptom:Kernel `config' fails to configure any kernel, including GENERIC.
 Fix:    Rebuild usr.sbin/config  Fix:    Rebuild usr.bin/config
   
 Symptom:  Symptom:
 Fix:    Rebuild usr.bin/yacc  Fix:    Rebuild usr.bin/yacc
Line 824  Fix: Build and install usr.bin/mklocale
Line 461  Fix: Build and install usr.bin/mklocale
 Symptom:undefined reference to `__assert13' or `__unsetenv13'  Symptom:undefined reference to `__assert13' or `__unsetenv13'
 Fix:    Rebuild and install lib/libc  Fix:    Rebuild and install lib/libc
   
 Symptom:usr.sbin/config fails to build.  Symptom:usr.bin/config fails to build.
 Fix:    Try building with -DMAKE_BOOTSTRAP added to CFLAGS in Makefile.  Fix:    Try building with -DMAKE_BOOTSTRAP added to CFLAGS in Makefile.
   
 Symptom:undefined reference to `getprogname' or `setprogname'  Symptom:undefined reference to `getprogname' or `setprogname'

Legend:
Removed from v.1.135.2.1  
changed lines
  Added in v.1.205

CVSweb <webmaster@jp.NetBSD.org>