[BACK]Return to UPDATING CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / src

Please note that diffs are not public domain; they are subject to the copyright notices on the relevant files.

Diff for /src/UPDATING between version 1.121 and 1.203

version 1.121, 2004/05/16 11:33:44 version 1.203, 2009/11/02 01:09:21
Line 1 
Line 1 
 $NetBSD$  $NetBSD$
   
 This file is intended to be a brief introduction to the build  This file (UPDATING) is intended to be a brief reference to recent
 process and a reference on what to do if something doesn't work.  changes that might cause problems in the build process, and a guide for
   what to do if something doesn't work.
   
   For a more detailed description of the recommended way to build NetBSD
   using build.sh, see the BUILDING file.
   
   Note that much of the advice in this UPDATING file was written before
   build.sh existed.  Nevertheless, the advice here may be useful for
   working around specific problems with build.sh.
   
 For a more detailed description see Makefile.  See also: BUILDING, build.sh, Makefile.
   
 Recent changes:  Recent changes:
 ^^^^^^^^^^^^^^^  ^^^^^^^^^^^^^^^
   
 20040516:  20091101:
         The end-user modifiable X11 configuration has been moved          After updating, it may be make the 'cleandir' target in
         from /usr/X11R6/lib/X11/<dir> to /etc/X11/<dir>.          src/tools/yacc/ and in src/usr.bin/yacc/ before a 'build.sh
         Ensure that src and xsrc is up to date, and run          -u tools' or 'build.sh -u distribution'.
         "make cleandir" in src/x11 before your next build.  
   20091001:
 20040426:          An error will create a ./usr/X11R7/lib/X11/xkb/compiled/xkb
         Support for the original dynamic sysctl node structure has          symlink, failing the build.  Delete the link, and the subdir
         been removed in favor of the newer layout.  This affects          it is in, and retry your build.
         consumers of the create and delete interface, as well as  
         the dynamic discovery mechanism.  This is believed only to  20090718:
         be the sysctl(8) binary itself, at this point in time, so          libc build changed so that strchr() provides the extra entry
         the only effect of this should be that a sysctl binary          point for index(). Update build of libc.a (and libc_pic.a)
         built from sources dated between 2003/12/04 and 2004/03/24          may fail because the archive contains the unwanted index.o.
         will not work on a kernel built from sources dated after          (Similarly for strrchr() and rindex().)
         2004/04/25.  If you need a new sysctl binary but build.sh  
         does not work, make sure that your revision of  20090709:
         src/sys/sys/sysctl.h is 1.112 (or later), and then the          Native Xorg was upgraded again.  Builds will probably fail again
         do the following:          without a clean objdir, at least for src/external/mit/xorg.
   
         cd /usr/src (or wherever your source tree is)  20090616:
         make USETOOLS=no includes          Native Xorg was upgraded.  Builds will need a clean objdir for
         cd lib/libc          src/external/mit/xorg.  Upgrading a system from sets will not
         make USETOOLS=no dependall install          work properly yet as the /usr/X11R7/lib/X11/xkb/symbols/pc
         cd ../../sbin/sysctl          subdirectory has been changed into a file, and this needs to
         make USETOOLS=no dependall install          be manually "rm -r"'ed before installing xbase.tgz.
   
 20040425:  20090501:
         The ffs superblock issues listed below under 20040109 and 20030402          Several new functions were added to string.h/libc, and this
         are now automatically addressed by the /etc/rc.d/fixsb script or by          can cause autoconf problems during the tool build for people
         sysinst when it checks a a filesystem. The manual fsck_ffs -b16 -c4          who fail to clean out their tools objects properly. If you
         invocation mentioned below will continue to work and is now          note messages about stpcpy, stpncpy or strnlen accompanying a
         automated by those scripts.  Note that under certain circumstances,          failure during the tool build, clean out all your tools
         affected filesystems upgraded to a -current kernel first before          objects and start again.
         upgrading their userland with the fixsb and fsck_ffs fixes may  
         encounter a 'freeing free inode' panic when writing to the affected  20090325:
         filesystem, so it is a good idea to repair the filesystem as soon as          The i386 port was switched to i486 default toolchain.  This requires
         possible.  For more details on the fixsb script, see pr install/25138.          cleaning your src/tools directory and $TOOLDIR and rebuilding them.
   
 20040418:  20090126:
         statfs(2) and friends have been replaced with statvfs(2). Before          The __posix_fadvise50 system call changed assembly stub type. You need to
         installing a newly build userland make sure that you are running          'rm -f __posix_fadvise50.*' in the libc build directory to avoid using
         a newly built kernel with COMPAT_20 set. In addition your libc          the old assembly stub.
         build might not work (undefined SYS_statfs symbol) because make  
         clean does not know how to remove files it does not know about  20090202:
         anymore. Manually remove all generated .S sources and objects          pkg_install now depends on the pkgdb cache for automatic conflict
         from the libc build directory.          detection.  It is recommented to rebuild the cache with
           ``pkg_admin rebuild''.
 20040326:  
         The method by which athhal-elf.o gets pulled into i386 kernel builds  20090110:
         has been changed. The file is now stored as a uuencoded file in CVS          time_t and dev_t have been bumped to 64 bit quantities. To upgrade:
         and the generated Makefile will use the new .uue rules from bsd.file.mk          1. Make sure your kernel has COMPAT_50 in it. Build and install.
         to build it.             This is needed even in the MODULAR kernel because there is
              conditionally compiled code in rtsock.c.
         This means you must have the latest bsd.files.mk installed when          2. make sure build.sh completes and the binaries in a chroot work
         building a kernel without USETOOLS=yes.             before installing.
           3. If you don't use build.sh and you build directly to root, and
 20040318:             your build breaks in the middle, don't despair. Make sure headers
         A bug in the cgd(4) blowfish code was corrected, without             are installed properly, and start building libraries first libc
         provision of backwards compatibility, after several public             and libutil, install them and then continue building all the
         notices over several months. Users of cgd with blowfish cipher             libraries in src/lib and src/gnu/lib and install them. Once
         ONLY must dump their data before updating their kernels, and             the new libraries are installed, you can restart the build.
         recreate cgd's and restore data using the new kernel. See          4. If you compile packages and you notice link time warnings,
         (recent message to current-users, URL when mail-index has updated)             rebuild the required packages to update their shared libraries.
              Any package you rebuild will require rebuilding all the packages
 20040313:             that depend on it.
         On acorn32, the opms and qms drivers have been withdrawn, and          5. Next time you run pwd_mkdb with the new binary, the file
         the old wsqms driver is now called qms.  Kernel config files             will be upgraded and it will not be backwards compatible.
         will need updating.  See the ones in sys/arch/acorn32/conf          6. The utmpx/wtmpx files (/var/run/utmpx and /var/log/wtmpx, see
         for examples.             lastlogx(5)) have been versioned, and there is a heuristic
              for utmp. You are better off removing the old files after
 20040125:             upgrading.  The automated clearing of /var/run during
         On acorn32, the beep and sysbeep devices are no longer             boot, and the automated rotating of files in /var/log by
         needed, and will need to be deleted from kernel configuration             newsyslog(8), may mean that you do not have to remove the
         files.             files manually.
           7. The optional accounting file (/var/account/acct, see
 20040109:             accton(8)) has not been versioned, and will need to be
         Compatibility for old ffs superblock layouts has been             removed.  The automatic rotation of the accounting file by
         added, and the restrictive fsck checks have been reenabled             /etc/daily limits the bad consequences of failure to remove
         when using those layouts.  If you have been using -current             the file.
         since 20030402, you may find that fsck again signals fatal          8. Application software that writes time_t to binary files on
         superblock mismatches.  To repair, make sure you have             disk will break or need attention. Most notably: if you are
         an updated fsck_ffs and then you can use fsck_ffs -b 16 -c 4             using PostgreSQL < 8.4, you need to dump your databases,
         to complete the filesystem upgrade.  A message has             rebuild PostgreSQL with the new time_t, then restore.
         been added to the kernel which should detect this problem.  
         See the following discussion for more information:  20081219:
         http://mail-index.NetBSD.org/current-users/2004/01/11/0022.html          config(1) has been updated, and one of the files it creates -
           swapnetbsd.o - has changed format.  You need to rebuild config
 20031203:          (done automatically by build.sh) and then you need to rerun
         New binutils builds may fail due to old dependencies.          config on all kernel configuration files before rebuilding those
         It's necessary to "make cleandir" to ensure that          kernels.
         the dependencies will be rebuilt correctly.  
   20081205:
 20031111:          If you build with MKX11=no, you should remove /etc/rc.d/xdm and
         A newer mkdep is needed.  Error noting that is          /etc/rc.d/xfs from DESTDIR because those files were moved to the xetc
                 cc: Ambiguous abbreviation --          set and will appear as extra files for MKX11=no update builds.
   
 20031008:  20081122:
         /usr/include/sys/disklabel_mbr.h was removed.          On i386, various kernel options(4) in GENERIC including
         It's necessary to "make cleandir" to ensure that          file systems have been disabled and moved into kernel modules.
         the dependencies will be rebuilt correctly.          Before trying a new GENERIC kernel, you have to prepare the
           following files as well as a new GENERIC kernel:
 20031007:  
         A sign exension bug was fixed which set all the high bits          - build and install kernel modules from src/sys/modules
         of our newly expanded ffs fs_flags.  This should only  
         affect users who installed or upgraded in September of 2003.          - install the latest bootloader, which will load a module
         A small utility program was posted to tech-kern which            for the file system from which the kernel is loaded automatically
         should fix this problem, and a warning message was added  
         to the kernel which should discover and warn about it.  See          If you have to load your kernel from a file system which is not of
         http://mail-index.NetBSD.org/tech-kern/2003/10/07/0005.html          the same type as the root file system, you have to load the necessary
           file system module manually on the boot prompt or in the boot.cfg file.
 20030906:  
         With the addition of siginfo support the old signal trampoline  20080827:
         code has been deprecated to COMPAT_16. Make sure that your running          If you built and installed a libc from sources between
         kernel has COMPAT_16 enabled before building userland.          2008/08/20 and 2008/08/26 you got a broken strtouq(3)
           which results in false errors reported by lint(1).
 20030801:          Since this breaks the libc build itself, manual help is
         With the new openssl, there is some header and library shuffling.          needed -- lint must be disabled temporarily, e.g.:
         rm -f /usr/include/des.h /usr/include/kerberosIV/* /lib/libdes* \            $ (cd lib/libc && make MKLINT=no dependall install)
         /usr/lib/libdes* before building.  
   20080813:
 20030703:          MKDEBUG build was broken because the .depend files did not know
         Texinfo was updated to 4.6.  To avoid failures when trying to          about .go files. You need to remove all .depend files and rebuild.
         build the included texinfo files, do:  
   20080802:
         cd src/gnu/usr.bin/texinfo          A regression in binary compatibility for pthread_mutex_t has
         make MKINFO=no dependall install          been fixed. Unfortunately, the price is breaking compatibility
           for -current.
 20030630:  
         Groff was updated to 1.19; it's probably necessary to do          Threaded programs (using libpthread) and C++ programs (using
                 cd share/mk && make install          libstdc++) compiled after 20070907 and before 20080802 need to
                 cd src/gnu/usr.bin/groff          be recompiled.
                 make MKMAN=no dependall install  
         (untested).          One way to find affected pkgsrc packages:
   
 20030516:            $ grep REQUIRES=/usr/lib/libpthread /var/db/pkg/*/+BUILD_INFO
         Due to bugs in the export handling code, invalid export lines            $ grep REQUIRES=/usr/lib/libstdc++ /var/db/pkg/*/+BUILD_INFO
         were accepted before and caused the kernel to panic when  
         mountd got restarted because it freed memory that had already  20080731:
         been freed. This has been fixed and the kernel checks          WAPBL (metadata journaling support) has been added, but at this
         export addresses very strictly. If you upgrade your kernel,          time isn't backwards compatible with pre-WAPBL aware kernels
         make sure you also upgrade mountd, because if your export          and userland (fsck_ffs in particular).  Please make sure you
         file contains lines with an old inet4 address syntax (i.e.          don't use a journaled filesystem with an older kernel/userland,
         a.b.c or a.b or a), they will get rejected by the new kernel.          especially an uncleanly mounted journaled filesystem.  WAPBL
           also requires the super block to be in the UFS2 format.  You
 20030402:          can use fsck_ffs -c 4 to update the superblock format.
         The superblock layout for FFS was changed.  If you have 1.6  
         fsck binaries, they will signal a fatal superblock mismatch  20080721:
         with the first alternate, because they compare too many          Assembler warnings are now fatal if $WARNS>0 and $NOGCCERROR
         fields (even ones that aren't useful).  If possible, upgrade          isn't defined.
         your fsck_ffs binary before using a new kernel.  
         None of this signals actual filesystem damage.  20080531:
           The ioctl number of DRVSUSPENDDEV command on /dev/drvctl changed
 20030324:          from 125 (conflicted with DRVCTLCOMMAND) to 129. The drvctl(8)
         sendmail version 8.12.8 was imported.  Since sendmail is          utility needs to be rebuilt and reinstalled as older binaries
         now setgid to the smmsp group, and runs in "collection"          won't work correctly. The following sequence of commands:
         mode for most common activities, there is a new config  
         file called submit.cf that needs to live in /etc/mail.            $ (cd sys/sys/ && nbmake-$arch includes)
         The generic submit.cf sample in /usr/share/sendmail/cf            $ (cd sbin/drvctl/ && nbmake-$arch clean)
         is named netbsd-msp.cf.  Upgrading your regular sendmail            $ (cd sbin/drvctl/ && nbmake-$arch all)
         configuration file is also strongly advised.  
           leaves new drvctl utility in sbin/drvctl build directory.
         See the section named "MESSAGE SUBMISSION PROGRAM" in  
         the updated /usr/share/sendmail/README file for more  20080503:
         information.          The <bsd.lib.mk> variable MKPRIVATELIB was renamed to LIBISPRIVATE.
   
 20030117:  20080521:
         Texinfo was updated to 4.3.  To avoid failures when trying to          For a while, unprivileged UPDATE builds would fail to
         build the included texinfo files, do:          succeed at the checkflist stage, complaining that
           ${DESTDIR}/stand/<arch>/ did not exist.  A fix for this
         cd src/gnu/usr.bin/texinfo          problem was committed to share/mk/bsd.kmodule.mk, revision 1.9.
         make MKINFO=no dependall install          If you already hit this problem, update the .mk file,
           remove ${DESTDIR}/stand/<arch>, and re-run the build.
 20021223:  
         The METALOG format changed slightly, to remove the leading  20080303:
         "${DESTDIR}" from path names.          Linker warnings are now fatal if $WARNS>0.
         This only affects people building with UNPRIVED.  
         For complete safety, remove the DESTDIR entirely and  20080126:
         update tools/mtree, before running make build.          The posix_fadvise system call has been changed from an assembly
           stub, to a c file that calls an assembly stub. You need to
 20021219:          'rm -f posix_fadvise.* .depend' in the libc build directory to
         CVS repository layout was changed.  See the following for details          avoid using the old assembly stub.
         if you are using (anonymous) cvs to update your tree.  
   20071209:
         http://mail-index.NetBSD.org/netbsd-announce/2002/12/19/0000.html          The acpiec(4) driver has been split into two attachments. If you
           get ACPI errors before the attachment, please update your kernel
 20021219:          configuration file appropriately or see GENERIC for more details.
         install(1) had a '-N dbdir' option added, to specify an  
         alternate location to look up users & groups (instead  20071115:
         of the host system passwd(5) and group(5) databases).          The it(4) driver has been renamed to itesio(4) and the old port
           argument specified in the kernel configuration file is not valid
         The build system was modified to take advantage of          anymore. The itesio(4) driver now uses the Super I/O address port
         this option (using ${NETBSDSRCDIR}/etc), so if you          rather than the EC address port. Please update your kernel
         use USETOOLS==no, you may have to rebuild and          configuration file appropriately or see GENERIC for more details.
         reinstall usr.bin/xinstall first.  
   20071028:
 20021130:          The pccons(4) driver has been removed from the NetBSD/shark port.
         fparseln(3) moved from libutil to libc.          You need to update any custom kernel configuration file you have
         If building to DESTDIR=/, reinstall the includes          to remove any references to pccons (which includes removing the
         and rebuild libc:          now useless XSERVER option) and replace them with the correct
                 make includes          entries for the wscons driver.  See the GENERIC configuration file
                 make do-lib-libc          for more details.
         If using build.sh, "cd tools/compat && make clean"  
         before rebuilding the tools.  20070913:
           A latent bug in dhclient/dhcpd that caused it to be unable to
 20021126:          enumerate interfaces was fixed.  The bug began to cause
         The mk.conf(5) variable SYS_INCLUDE has been deprecated,          problems after 20070911 when the kernel's SIOCGIFCONF
         including the optional "SYS_INCLUDE=symlinks" support.          implementation was repaired.  From 20070529 to 20070911 racoon
         All header files, including <sys/*.h> are copied into          could not enumerate interfaces.  (These are noted because
         /usr/include.          normal kernel/userspace version matching hygiene is not
           sufficient to avoid this problem.)  Ensure that both kernel
 20021121:          and userland are from after 20070913.
         The C run-time support files crtbegin.o and crtend.o  
         (and their companions crtbeginS.o and crtendS.o) were  20070703:
         split up, with new crti.o and crtn.o files resulting.          nbinstall has been renamed ${MACHINE_GNU_ARCH}-install. It
         This means that libtool needs to be rebuilt once the          calls the target-specific strip program, and the logic to pass
         new libraries are installed.  The process of rebuilding          down STRIP from make has been removed.  This requires a
         libtool will cause it to automatically notice the new          re-installation of tools.
         required files, but it *must* be rebuilt in order to  
         do this.  20070422:
           The way OS emulations lookup filenames inside the emulation root
         An out-of-date libtool will result in shared libraries          has been changed.  Rather than modify the pathname (and copy back
         which lack _init() and _fini() routines, which means that          to userspace) namei() and lookup() directly check the emulation
         their global contructors/destructors will not be invoked.          root. One side effect is that absolute symlinks inside the emulated
           root file system will be relative to that file system - unless they
 20021121:          start /../ this is useful when the emulated root is a real install
         A bug related to how ARM ELF objects were tagged has been          that has such links.
         corrected.          This might affect symlinks that have been added to reference outside
           the emulated root.
         NetBSD ARM ELF uses the soft-VFP floating point model by  
         default.  However, the assembler lacked support for marking  20070412:
         objects as using the VFP floating point format, and the          The pckbc driver on sgimips IP32 has been removed. Use macekbc
         compiler was not properly passing the flag indicating "soft-VFP"          instead. See the GENERIC32_IP3x kernel configuration for an
         to the assembler.          example.
   
         Unfortunately, this means that the linker will now consider  20070319:
         old (i.e. not marked "softvfp") NetBSD ARM ELF objects to be          src/lib/libc/Makefile revision 1.129 broke libc and ld.elf_so
         incompatible with new (properly marked) objects.          on many platforms due to incorrect flags settings.  If you
           updated and built after about 20070315, do "nbmake-$arch
         The problem will only manifest itself if you attempt to compile          cleandir" in src/lib/libc and src/libexec/ld.elf_so to force a
         a new program using the fixed toolchain, and link that program          rebuild of object files that might have been built
         against old libraries which do not have the proper "softvfp"          incorrectly, and ensure that you have at least
         markings.  ALL OF YOUR EXISTING BINARIES AND SHARED LIBRARIES          src/lib/libc/Makefile 1.130.
         WILL CONTINUE TO WORK PROPERLY.  
   20070210:
         The only work-around for the problem is to recompile all of          src/sys/sys/{sa.h,savar.h} were removed.
         the libraries on the system.  The easiest way to do this for            find ${OBJDIR} \( -name .depend -o -name '*.d' \) -print \
         system libraries is to install a binary snapshot; they are                | xargs egrep -l '/sa.h|/savar.h' | xargs rm
         generally available on releng.NetBSD.org.  Any packages you          will allow dependencies on those files to get get rebuilt
         have installed which supply libraries will have to be recompiled  
         if you wish to link new programs against those libraries.  20070209:
           The threading model was changed when the newlock2 branch
         If you have questions about this matter, please contact          was merged to NetBSD-current.  If you boot with a new
         port-arm@NetBSD.org.          kernel (version 4.99.10), then you also need a new pthread
           library (/usr/lib/libpthread.so.0.7).  If you boot with
 20021011:          an old kernel, then you need the old pthread library
         Systrace has been improved to support privilege elevation.          (/usr/lib/libpthread.so.0.6).  Provided you keep the kernel and
         Updating the kernel requires the userland part of systrace          the pthread library in sync, old threaded applications should
         to be rebuilt.          continue to work with an old or new kernel.  Note that named(8)
           is the only threaded application in the base system.
 20021010:  
         The config(8) grammar was changed to allow options to register  20061214:
         dependencies on attributes, as well as other options.  Users          Following the move of string_to_flags() and flags_to_string()
         must update and reinstall usr.sbin/config before building a new          from the bin/ls/ sources to libutil, users doing UPDATE builds
         kernel.          will need to do a "make cleandir" in
                   tools/mtree/, tools/makefs/, tools/binstall/, tools/pax/,
 20021009:                  bin/pax/, bin/ls/, usr.sbin/mtree/, usr.sbin/makefs/,
         A new attribute dependency syntax was introduced to config(8),                  usr.bin/xinstall/, libexec/ftpd/, rescue/, as well
         which is now used by the SCSI configuration description.  Users                  as the installation images in distrib/
         must update and reinstall usr.sbin/config before building a new          in order to excise stale references to the old stat_flags.h header
         kernel.          file in the ls sources -- stat_flags.h has been removed.
   
 20021003:  20061108:
         Several changes have been made to the autoconfiguration          The configure script used in the src/tools/gcc compiler has been
         framework.  Users must update and reinstall usr.sbin/config          changed to indicate that our libc has ssp support built-in and
         before building a new kernel.          does not depend on -lssp and -lssp-nonshared. You'll need to
           make clean in src/tools/gcc first to rebuild the compiler.
 20021001:  
         The i386mp branch has been merged.  To compile a kernel, users  20061009:
         will need to add the option 'cpu* at mainbus?' to their configuration          The sysctl variables net.inet{,6}.tcp{,6}.newreno are no longer
         file.  Multiprocessor kernels will need          available. Use net.inet{,6}.tcp{,6}.congctl.selected instead.
         ioapic*         at mainbus? apid ?  
         options         MULTIPROCESSOR  20060814:
         options         COM_MPLOCK          The vt, vidcconsole, kbd, and rpckbd drivers on acorn32 have been
           withdrawn.  Use vidcvideo and pckbd instead.  See the GENERIC
 20020922:          kernel configuration for an example.  X servers from the last
         MKDYNAMICROOT=yes enabled by default, which means that          few years should cope.
         certain shared libraries are installed into /lib, the shared  
         linker is installed into /libexec, and all programs in /bin  20060703:
         and /sbin are dynamically linked.          MPACPI is no more. We always configure PCI interrupts using ACPI
         If you do not use "make build", you should ensure that          if we have an ACPI kernel. The option MPACPI_SCANPCI has been renamed
         you have the libraries and shared linker in the new locations,          to ACPI_SCANPCI. Thanks to work from fvdl.
         with:  
                 make do-lib-csu do-lib-libc do-lib do-gnu-lib do-ld.elf_so  20060627:
           socket(2) has changed, and its system call has been versioned.
 20020917:          For userlands with the old version of socket(2), make sure that
         USE_NEW_TOOLCHAIN has been replaced with:          your kernel has 'options COMPAT_30' set, or else 'bad system call'
             -   TOOLCHAIN_MISSING -- set to "yes" on platforms for which          errors will result.
                 there is no working in-tree toolchain (hppa, ns32k, sh5,  
                 x86_64).  
             -   EXTERNAL_TOOLCHAIN -- if defined by the user, points to the  
                 root of an external toolchain (e.g. /usr/local/gnu).  This  
                 enables the cross-build framework even for TOOLCHAIN_MISSING  
                 platforms.  
   
 20020906:  
         gehenna-devsw has been merged into the trunk. Need to update and  
         reinstall usr.sbin/config before building the kernel.  
   
 20020822:  
         Crunched rescue tools (contents of /bin and /sbin, plus others)  
         are now provided in /rescue.  
   
         To ensure that these are built statically linked (no matter  
         what the setting of LDSTATIC is), use a crunchgen(1) built  
         from sources newer than 20020820 (see the next entry).  
   
 20020820:  
         crunchgen(1) changed to ensure that the generated program  
         is statically linked.  
   
         Solution: update and reinstall usr.bin/crunch  
   
 20020605:  
         smmsp user/group has been added for sendmail.  
   
         Add the following into /etc/group:  
   
         smmsp:*:17:  
   
         and the following to /etc/master.passwd (via vipw):  
   
         smmsp:*:17:17::0:0:Sendmail Message Submission Program:/nonexistent:/sbin/nologin  
   
 20020515:  
         sshd user/group has been added.  Need to hand add this in, or sshd  
         will not let you log in (with default, or UsePrivlegeSeparation=yes)  
   
         Add the following into /etc/group:  
   
         sshd:*:16:  
   
         and the following to /etc/master.passwd (via vipw):  
   
         sshd:*:16:16::0:0:& pseudo-user:/var/chroot/sshd:/sbin/nologin  
   
         Also /var/chroot/sshd directory needs to be present (digged as part of  
         the build process).  
   
 20020426:  
         NBUILDJOBS obsoleted in favor of just using -j.  
   
 20020426:  
         etc/postinstall added, which performs various checks for  
         configuration file updates and changes, and can fix most of  
         the problems identified.  
         This should make it much easier to upgrade a system's  
         configuration from earlier systems (as far back as NetBSD 1.5).  
   
 20020320:  
         <bsd.lib.mk> needs a new install(1) for its "-a cmd" support.  
         Build and install at usr.bin/xinstall before the build.  
   
 20020319:  
         Raw IPv6 socket now makes strict checking for sa_family and sa_len  
         on send(2) operation.  Be sure to have sbin/rtsol and usr.sbin/rtsold  
         newer than November 2001 when you upgrade the kernel.  
   
 20020311:  
         ssh configuration files were moved from /etc to /etc/ssh.  Beware  
         if you restart your machine from remote.  Note that sshd.conf needs  
         to be changed (due to the use of "/etc" inside).  
   
 20020223:  
         Users of the VAX port will need to rebuild and install gas  
         so it deal with the now present register prefix used in all  
         the VAX assembly files.  
   
 20020118:  
         ntpd user/group has been added.  Need to hand add this in or builds  
         will break as mtree aborts early.  
   
         Add the following into /etc/group:  
   
         ntpd:*:15:  
   
         and the following to /etc/master.passwd (via vipw):  
   
         ntpd:*:15:15::0:0:Ntpd pseudo-user:/var/chroot/ntpd:/sbin/nologin  
   
 20011207:  
         If you're attempting to build a snapshot on sparc64 and are getting  
         reloc errors from the toolchain groff binary this means your native  
         toolchain has some broken C++ bits.  
   
         To fix:  
   
         Build a new toolchain (i.e. build.sh -t)  
         Use the new toolchain to build and install natively (i.e. /usr/lib)  
   
         gnu/lib/libgcc  
         gnu/lib/libstdc++  
   
         After this a snapshot will be able to be built.  
   
 20011201:  
         In order for a sparc64 build to work you must have a working awk. If  
         you've built and installed a system with the new toolchain up to this  
         point you do not have a working awk as its ability to do floating  
         point is broken.  
   
         To build:  
   
         remake and install gnu/lib/libgcc  
         remake and install gnu/usr.bin/gawk into /usr/bin (make sure it links  
         against the new libgcc.a)  
   
 20011128:  
         Kernel config information was changed to use defflag in  
         the various "files" files.  Bug fixes to config(8) are  
         required in order for this to work properly.  Make sure  
         to build and install in usr.sbin/config before attempting  
         to build a new kernel.  
   
 20011030:  
         libc/locale/wcstod.c now needs new lint(1). Update lint(1)  
         before building libc.  
   
 20011029:  
         The new document BUILDING.mdoc (view with nroff | more, or  
         see pre-generated .txt and .html versions) describes the build  
         procedure in great detail.  BUILDING, and the USE_NEW_TOOLCHAIN  
         build process, are intended in the long run to replace this  
         manual update log.  
   
         Users building a USE_NEW_TOOLCHAIN system should read the  
         BUILDING document for caveats.  Generally, BUILDING supersedes  
         UPDATING for these systems, as tool updating is taken care of  
         by the new build system.  
   
 20011028:  
         src/etc/Makefile now needs install to be able to handle  
         symlinks that point to nowhere. A bug in install that  
         prevented this was corrected.  
   
         Solution: update and reinstall usr.bin/xinstall  
         Better Solution: Use the new toolchain and it will just work  
         for you.  
   
 20011006:  
         /etc/mtree/NetBSD.dist has been updated to take advantage of  
         absolute path support added to mtree(8). Older mtree(8)s don't  
         understand the format.  
   
         Solution: update and reinstall usr.sbin/mtree  
   
 20011004:  
         Crunchgen has been updated to work via reach-over makefiles. Updating  
         is suggested before running a snapshot build  
   
 20010915:  
         The new "ubcperf" code committed by Chuck Silvers removed  
         a header file, uvm/uvm_vnode.h.  There may be stale .depend  
         files that still reference this file.  
   
         Solution: "make cleandir && make dependall" in affected  
         directories.  
   
 20010803:  
         grep.info is now built from grep.texi using makeinfo.  Since it  
         requires makeinfo v4.0, you need to install new texinfo before  
         building gnu/usr.bin/grep.  To install new texinfo, please follow  
         the instruction described in 20010726 entry.  
   
 20010803:  
         (i386 only): i386 kernel now uses new instructions like  
         `fxsave' which old gas doesn't understand.  To build the  
         kernel successfully, you need to build and install a new toolchain,  
         (i.e., build.sh -t) or  (temporarily) comment out "options I686_CPU"  
         from your kernel configuration until you rebuild your userland.  
         See 20011029 above and BUILDING file in this directory for more information.  
         [updated 20020630 since i386 gas moved when USE_NEW_TOOLCHAIN enabled]  
   
 20010731:  
         Bootloader update on ELF platforms.  DDB in kernels from before  
         this will be unable to read symbol tables provided by newer  
         bootloaders.  
   
 20010726:  
         Texinfo was updated to 4.0.  To avoid failures when trying to  
         build the included texinfo files, do:  
   
         cd src/gnu/usr.bin/texinfo  
         make MKINFO=no dependall install  
   
 20010718:  
         Enabled correct .init/.fini processing in crt0.  The way this  
         was done was to change a -I directive to cc(1), which means  
         make(1) will have a stale dependency (it will be checking the  
         timestamp on the wrong "dot_init.h").  
   
         The symptom you will see is that new programs die with SIGSEGV  
         if you have a stale dependency.  
   
         Solution: "make cleandir" in both lib/csu and libexec/ld.elf_so  
         before starting your build.  
   
 20010628:  
         A construct was added to uvm_page.h that uncovered a bug  
         in lint(1).  If you get a warning/error about a non-portable  
         bitfield, update your lint(1) before proceeding.  
   
 20010226:  
         Added named user/group to system. Need to hand add this in or builds  
         will break as mtree aborts early.  
   
         To work around add by hand:  
   
         named:*:14:  
   
         to /etc/group and add:  
   
         named:*:14:14::0:0:Named pseudo-user:/var/named:/sbin/nologin  
   
         to master.passwd (use vipw for instance if doing by hand).  
   
         Now a make build should progress.  
   
 20010219:  
         get/setprogname() added. Any hostprogs that may use this will need  
         to be bootstrapped manually until the host system is current.  
   
         Known problems: sys/arch/macppc/stand/fixcoff  
                         usr.sbin/config (adding -DMAKE_BOOTSTRAP to  
                           CFLAGS and rebuilding should work)  
                         usr.sbin/mdsetimage - Build a static copy if  
                           building a snapshot before fully bootstrapped.  
   
 20010204:  
         prepare the code to compile with stricter gcc flags. in  
         particular start eliminating redundant declarations. Yacc  
         needs to be installed before make build.  
   
 20010114:  
         introduce .if commands(target) in make(1). You need to  
         bring everything up-to-date first, then without installing  
         anything make and install in usr.bin/make, then proceed  
         with make build.  
   
 20010101:  
         bsd.subdir.mk committed 20001230 had a bug which caused  
         afterinstall targets to run too soon; update again.  
   
 20001230:  
         New share/mk files needed to support .WAIT in SUBDIR variables.  
         If you get make errors,  
                 (cd share/mk; make install)  
         Also, PRINTOBJDIR has changed and is now used more heavily.  
   
 20001019:  
         The `ca' device driver has been replaced by `ld'; although the  
         major and minor numbers haven't changed, you should update your /dev  
         directory.  
   
 20000929:  
         The following make directives are obsoleted.  
         MKCRYPTO_RSA NOCRYPTO_RSA NOCRYPTO_RC5 NOCRYPTO_IDEA  
         By default, RSA is built into libcrypto.  IDEA and RC5 will not be  
         built into libcrypto.  By using MKCRYPTO_{RC5,IDEA}, you can build  
         additional library libcrypto_{idea,rc5}.  
   
   
 Hints for a more successful build:  Hints for a more successful build:
 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
       Use build.sh, but do not use its "expert mode":
           This will automatically build the tools in the
              correct order, and it will keep the tools and the
              new build products from interfering with the running
              system.  This will allow you to ignore most of the
              other advice in this file.
     Build a new kernel first:      Build a new kernel first:
         This makes sure that any new system calls or features          This makes sure that any new system calls or features
            expected by the new userland will be present.  This             expected by the new userland will be present.  This
Line 592  Hints for a more successful build:
Line 333  Hints for a more successful build:
            about one.  It also makes it easier to clean up after             about one.  It also makes it easier to clean up after
            a build.  It's also necessary if you want to use the             a build.  It's also necessary if you want to use the
            same source tree for multiple machines.             same source tree for multiple machines.
            To use object directories:             To use object directories with build.sh:
               a) invoke build.sh with the "-M" or "-O" options.
              To use object directories without using build.sh:
             a) cd /usr/src ; make cleandir              a) cd /usr/src ; make cleandir
             b) Add "OBJMACHINE=yes" to /etc/mk.conf              b) Add "OBJMACHINE=yes" to /etc/mk.conf
             c) Add "MKOBJDIRS=yes" to /etc/mk.conf              c) Add "MKOBJDIRS=yes" to /etc/mk.conf
Line 600  Hints for a more successful build:
Line 343  Hints for a more successful build:
            Note that running "make obj" in a directory will create             Note that running "make obj" in a directory will create
            in obj.$MACHINE directory.             in obj.$MACHINE directory.
     Build to a DESTDIR:      Build to a DESTDIR:
         This helps to keep old          This helps to keep old installed files (especially libraries)
            installed files (especially libraries) from interfering             from interfering with the new build.
            with the new build.             To build to a DESTDIR with build.sh, use the "-D" option.
            To build to a DESTDIR, set the DESTDIR environment             To build to a DESTDIR without using build.sh, set the DESTDIR
            variable before running make build.  It should be set to             environment variable before running make build.  It should be
            the pathname of an initially empty directory.             set to the pathname of an initially empty directory.
            Problems: you might need to update critical utilities             Problems: if you do not use build.sh, you might need to
                 without using DESTDIR since nothing is executed                  update critical utilities without using DESTDIR since
                 from what is installed in DESTDIR.                  nothing is executed from what is installed in DESTDIR.
                 (See critical utils, below)                  (See critical utils, below.)
     Build often:      Build often:
         This keeps critical utilities current enough to not choke          This keeps critical utilities current enough to not choke
         on any other part of the source tree that depends on up to          on any other part of the source tree that depends on up to
         date functionality.          date functionality.  If you use build.sh, you should not have
           this problem.
   
 What to do if things don't work:  What to do if things don't work:
 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
Line 671  cd $NETBSDSRCDIR && make cleandir
Line 415  cd $NETBSDSRCDIR && make cleandir
   
 Critical utilities:  Critical utilities:
 ^^^^^^^^^^^^^^^^^^^  ^^^^^^^^^^^^^^^^^^^
         gnu/usr.bin/egcs  
         usr.bin/compile_et          usr.bin/compile_et
         usr.bin/make          usr.bin/make
         usr.bin/yacc          usr.bin/yacc
         usr.bin/lex          usr.bin/lex
         usr.bin/xlint          usr.bin/xlint
         usr.sbin/config          usr.bin/config
   
 Other problems and possible solutions:  Other problems and possible solutions:
 ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^  ^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^^
 Symptom:Unreasonable compiler errors.  
 Fix:    Rebuild gnu/usr.bin/egcs  
   
 Symptom:Complaints involving a Makefile.  Symptom:Complaints involving a Makefile.
 Fix:    Rebuild usr.bin/make:  Fix:    Rebuild usr.bin/make:
         cd usr.bin/make && make && make install          cd usr.bin/make && make && make install
Line 694  Fix: Make sure .mk files are up to date.
Line 434  Fix: Make sure .mk files are up to date.
         cd share/mk && make install          cd share/mk && make install
   
 Symptom:Kernel `config' fails to configure any kernel, including GENERIC.  Symptom:Kernel `config' fails to configure any kernel, including GENERIC.
 Fix:    Rebuild usr.sbin/config  Fix:    Rebuild usr.bin/config
   
 Symptom:  Symptom:
 Fix:    Rebuild usr.bin/yacc  Fix:    Rebuild usr.bin/yacc
Line 720  Fix: Build and install usr.bin/mklocale
Line 460  Fix: Build and install usr.bin/mklocale
 Symptom:undefined reference to `__assert13' or `__unsetenv13'  Symptom:undefined reference to `__assert13' or `__unsetenv13'
 Fix:    Rebuild and install lib/libc  Fix:    Rebuild and install lib/libc
   
 Symptom:usr.sbin/config fails to build.  Symptom:usr.bin/config fails to build.
 Fix:    Try building with -DMAKE_BOOTSTRAP added to CFLAGS in Makefile.  Fix:    Try building with -DMAKE_BOOTSTRAP added to CFLAGS in Makefile.
   
 Symptom:undefined reference to `getprogname' or `setprogname'  Symptom:undefined reference to `getprogname' or `setprogname'

Legend:
Removed from v.1.121  
changed lines
  Added in v.1.203

CVSweb <webmaster@jp.NetBSD.org>