[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / xview-clients

File: [cvs.NetBSD.org] / pkgsrc / x11 / xview-clients / Makefile (download)

Revision 1.29, Sat Mar 4 21:31:14 2006 UTC (18 years, 1 month ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.28: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.29 2006/03/04 21:31:14 jlam Exp $

DISTNAME=		xview3.2p1-X11R6
PKGNAME=		xview-clients-3.2.1
PKGREVISION=		2
CATEGORIES=		x11
MASTER_SITES=		${MASTER_SITE_LOCAL}

MAINTAINER=		pkgsrc-users@NetBSD.org
COMMENT=		OpenLook applications and man pages

NOT_FOR_PLATFORM=       *-*-alpha       # it builds but everything segfaults...

NO_SRC_ON_FTP=		Already in MASTER_SITE_LOCAL

EXTRACT_ELEMENTS=	${DISTNAME}/clients ${DISTNAME}/images

WRKSRC=			${WRKDIR}/${DISTNAME}/clients
USE_IMAKE=		yes

post-patch:
	@cd ${WRKSRC};					\
	for file in olwm/openwin-menu-programs; do	\
		${MV} -f $${file} $${file}.tmp;		\
		${SED}	-e "s,@PREFIX@,${PREFIX},g"	\
			-e "s,@X11BASE@,${X11BASE},g"	\
			< $${file}.tmp > $${file};	\
		${RM} -f $${file}.tmp;			\
	done

.include "../../x11/xview-lib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"