[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / xterm

File: [cvs.NetBSD.org] / pkgsrc / x11 / xterm / Makefile (download)

Revision 1.15, Mon Feb 14 22:46:50 2005 UTC (19 years, 2 months ago) by minskim
Branch: MAIN
Changes since 1.14: +2 -2 lines

Update xterm to 200.

Changes:

    * increase color pairs value for xterm-256color and xterm-88color
      to match ncurses, which has an experimental option to support this.

    * modify ifdef's to make AIX use termios rather than termio; the
      struct sizes for the two were not the same.

    * improve CF_WITH_IMAKE_CFLAGS configure macro script for
      OSMAJORVERSION and OSMINORVERSION values, e.g., for Tru64 and AIX.

    * modify ifdef to define USE_POSIX_TERMIOS for Darwin (patch by
      Min Sik Kim).

    * modify find_utmp() to initialize the whole utmpx struct (except
      ut_id), since that is needed for OSF1 4.0D to prevent an infinite loop
      on exit.

    * add configure check before adding -D_POSIX_SOURCE since some
      platforms predefine it, e.g., cygwin.

    * add simplified sed expressions in CF_IMAKE_CFLAGS configure
      script macro to ensure value for PROJECTROOT is quoted on Solaris,
      i.e., when nested \( and \) are not interpreted correctly.

    * correct DEC rectangle operations to reset state after completing
      the operations.

    * modify CASE_ST handling in charproc.c to ensure that the parse
      state is reset even if xterm is not currently processing an OSC or
      other string (patch by Johnny Billquist forwarded by Matthias Scheler,
      NetBSD xsrc/29003).

    * fix OS/2 build for innotek_libc (patch by David Yeo).

    * fix a regression from patch #197 fix for Debian #277832 which
      disowned the selection if it was scrolled, e.g., by the user pressing
      return at the bottom of the screen (Debian #291787).

    * move the warning/exit for missing $DISPLAY into the error
      handler in case -display is given, and the connect fails for some
      other reason.

# $NetBSD: Makefile,v 1.15 2005/02/14 22:46:50 minskim Exp $

DISTNAME=	xterm-200
CATEGORIES=	x11
MASTER_SITES=	ftp://invisible-island.net/xterm/
EXTRACT_SUFX=	.tgz

MAINTAINER=	tech-pkg@NetBSD.org
HOMEPAGE=	http://dickey.his.com/xterm/xterm.html
COMMENT=	Latest terminal emulator for the X Window System

GNU_CONFIGURE=	yes
USE_BUILDLINK3=	yes
USE_X11=	yes
WRKSRC=		${WRKDIR}/${PKGNAME}

.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} == "SunOS"
INSTALL_FILE=	${WRKDIR}/INSTALL
DEINSTALL_FILE=	${INSTALL_FILE}

pre-build:
	@${SED} -e 's#@MV@#${MV}#g' \
	  -e 's#@LOCALBASE@#${LOCALBASE}#g' \
	  -e 's#@PREFIX@#${PREFIX}#g' \
	  ${PKGDIR}/INSTALL >${INSTALL_FILE}

pre-install:
	${SH} ${INSTALL_FILE} ${PKGNAME} PRE-INSTALL

post-install:
	${SH} ${INSTALL_FILE} ${PKGNAME} POST-INSTALL
.endif

.include "../../mk/bsd.pkg.mk"