File:  [cvs.NetBSD.org] / pkgsrc / x11 / xterm / Makefile
Revision 1.143: download - view: text, annotated - select for diffs
Mon Mar 6 07:27:09 2023 UTC (21 months ago) by pin
Branches: MAIN
CVS tags: HEAD
x11/xterm: update to 379

Patch #379 - 2023/02/15
 - improve text-cursor (patch by Jan Engelhardt):
     - allow selecting CURSOR_BAR mode from command-line/Xresources.
     - draw cursor using filled rectangle instead of rectangle outline to
       permit thicker underlines/bars.
     - scale up cursor relative to font size.
 - improve readline modes (Fedora #2166860):
     - document readline modes
     - change the feature to configure by default
     - replace hard-coded SS3 for cursor movement with current mode
     - replace hard-coded erase/lnext characters with current values
 - improve status-line (report by Thomas Wolff):
     - RIS turns off status-line
     - Right-margin (DECLRMM and DECSLRM) limits the length of text
       written/updated in the status-line.
     - Most controls which affect the whole screen are ignored while updating
       the status-line.
 - modify configure check for tgetent to allow for some special cases of
   ncurses configuration (report by Satadru Pramani).
 - reduce timeout, improve warning message if resize is run on a terminal which
   is not VT100-compatible.
 - reduce compiler warnings in configure script.

Thanks to @wiz for help with initial build failure.

# $NetBSD: Makefile,v 1.143 2023/03/06 07:27:09 pin Exp $

DISTNAME=	xterm-379
CATEGORIES=	x11
MASTER_SITES=	ftp://ftp.invisible-island.net/xterm/
EXTRACT_SUFX=	.tgz

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://invisible-island.net/xterm/xterm.html
COMMENT=	Latest terminal emulator for the X Window System
LICENSE=	x11

GNU_CONFIGURE=		yes
USE_TOOLS+=		tbl pkg-config

WRKSRC=			${WRKDIR}/${PKGNAME_NOREV}

CONFIGURE_ARGS+=	--enable-88-color
CONFIGURE_ARGS+=	--enable-256-color
CONFIGURE_ARGS+=	--enable-paste64
CONFIGURE_ARGS+=	--enable-readline-mouse

CONFIGURE_ARGS.standard=	# empty
CONFIGURE_ARGS.3d=		--with-Xaw3d
CONFIGURE_ARGS.xpm=		--with-Xaw3d
CONFIGURE_ARGS.neXtaw=		--with-neXtaw
CONFIGURE_ARGS+=		${${CONFIGURE_ARGS.${XAW_TYPE}}:L}

LDFLAGS+=		-lfreetype

INSTALLATION_DIRS=	share/applications

.include "../../mk/bsd.prefs.mk"

.if ${X11_TYPE} == "modular"
CONFIGURE_ARGS+=	--disable-imake
CONFIGURE_ARGS+=	--enable-narrowproto
.endif

.if exists(/usr/include/wchar.h)
CONFIGURE_ARGS+=	--enable-wide-chars
.endif

.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXt/buildlink3.mk"
###
### For detection of XKB bell extension.
###
BUILDLINK_DEPMETHOD.libxkbfile?=	build
.include "../../x11/libxkbfile/buildlink3.mk"

post-install:
	${INSTALL_DATA} ${WRKSRC}/xterm.desktop \
		${DESTDIR}${PREFIX}/share/applications && \
	${INSTALL_DATA} ${WRKSRC}/uxterm.desktop \
		${DESTDIR}${PREFIX}/share/applications
	cd ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1 && tbl xterm.1 \
		> xterm.1.tbl && mv xterm.1.tbl xterm.1

.include "options.mk"

.include "../../mk/curses.buildlink3.mk"
.include "../../mk/termcap.buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../mk/xaw.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>