[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / xterm

File: [cvs.NetBSD.org] / pkgsrc / x11 / xterm / Makefile (download)

Revision 1.110, Sun Jun 12 14:40:27 2016 UTC (7 years, 10 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.109: +2 -3 lines

Updated xterm to 325.

Patch #325 - 2016/06/05

    improve manual page discussion of function keys (discussion with Ross Combs).
    further improve fix for Debian #545220 in patch #248, to avoid conflict with combining characters (Debian #738794).
    improve -hold option to avoid 100% CPU usage with NetBSD after closing the shell, which makes subsequent checks for X input events fail (prompted by patch by Pierre Pronchery).
    review #ifdef statements, listed those which do not have a configure option in xtermcfg.hin.
    fixed one case where the menu sensistivity for Print-All Immediately and Print-All on Error was not properly ifdef'd.
    modify terminfo entries for 16-, 88- and 256-color to reset palette with rs1 capability.
    accept legacy value of -kt as synonym for the oldXtermFKeys resource, and extend the full-reset logic to use the keyboard type set via -kt.
    modify ioctl calls for I_PUSH to first check if the module has been added, using I_FIND. This is needed for newer Solaris libraries with c11 support (adapted from patch by Alan Coopersmith).
    add check in getXtermCombining to ensure that combining characters were allocated (report by Tor Andersson).
    add configure option --without-xinerama to allow suppressing the extension (Gentoo #580936).
    update keysym2ucs.c based on Unicode 9.0
    fixed most cppcheck --enable=all warnings, including for style (prompted by report by David Binderman). There was one bug-fix:
        RGB least-squares computation in allocateClosestRGB used only one ordinate
    add cppcheck to lint-like programs in configure script and makefile.
    updates for SIXEL and ReGIS (Ross Combs):
        Fixes some const correctness issues and points out an array lifetime issue
        Sixel drawing should still happen after an error if some commands have been processed
        Tiny steps toward reporting ReGIS input

# $NetBSD: Makefile,v 1.110 2016/06/12 14:40:27 wiz Exp $

DISTNAME=	xterm-325
CATEGORIES=	x11
MASTER_SITES=	ftp://invisible-island.net/xterm/
EXTRACT_SUFX=	.tgz

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://dickey.his.com/xterm/xterm.html
COMMENT=	Latest terminal emulator for the X Window System
LICENSE=	x11

GNU_CONFIGURE=		yes
USE_TOOLS+=		tbl pkg-config

WRKSRC=			${WRKDIR}/${PKGNAME_NOREV}

CONFIGURE_ARGS+=	--enable-88-color
CONFIGURE_ARGS+=	--enable-256-color
CONFIGURE_ARGS+=	--enable-paste64
CONFIGURE_ARGS+=	--enable-readline-mouse

CONFIGURE_ARGS.standard=# empty
CONFIGURE_ARGS.3d=	--with-Xaw3d
CONFIGURE_ARGS.xpm=	--with-Xaw3d
CONFIGURE_ARGS.neXtaw=	--with-neXtaw
CONFIGURE_ARGS+=	${${CONFIGURE_ARGS.${XAW_TYPE}}:L}

INSTALLATION_DIRS=	share/applications

.include "../../mk/bsd.prefs.mk"

.if ${X11_TYPE} == "modular"
CONFIGURE_ARGS+=	--disable-imake
CONFIGURE_ARGS+=	--enable-narrowproto
.endif

.if exists(/usr/include/wchar.h)
CONFIGURE_ARGS+=	--enable-wide-chars
.endif

.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXt/buildlink3.mk"
###
### For detection of XKB bell extension.
###
BUILDLINK_DEPMETHOD.libxkbfile?=	build
.include "../../x11/libxkbfile/buildlink3.mk"

post-install:
	${INSTALL_DATA} ${WRKSRC}/xterm.desktop \
		${DESTDIR}${PREFIX}/share/applications && \
	${INSTALL_DATA} ${WRKSRC}/uxterm.desktop \
		${DESTDIR}${PREFIX}/share/applications
	cd ${DESTDIR}${PREFIX}/${PKGMANDIR}/man1 && tbl xterm.1 \
		> xterm.1.tbl && mv xterm.1.tbl xterm.1

.include "options.mk"

.include "../../mk/curses.buildlink3.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../mk/xaw.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"