[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / xrdb

File: [cvs.NetBSD.org] / pkgsrc / x11 / xrdb / Makefile (download)

Revision 1.9, Mon Sep 9 09:42:22 2013 UTC (10 years, 6 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1, pkgsrc-2015Q4-base, pkgsrc-2015Q4, pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1, pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4, pkgsrc-2013Q3-base, pkgsrc-2013Q3
Changes since 1.8: +2 -3 lines

Update to 1.1.0:

This release contains a number of changes around the way xrdb calls the
selected macro processing program, normally cpp, to handle the provided
resource file, including adding a -undef option to pass through to cpp,
allowing builders to provide default cpp flags at build time, and only
passing -P by default to a processor named cpp.

It also adds a -version flag to aid in debugging which version is in use
and fixes a number of compiler warnings.

Alan Coopersmith (11):
      Tokenize #define names in the PATHETICCPP case too
      Clarify .Xresources vs. .Xdefaults in man page
      Ensure we don't read out of ClassName array bounds for unknown visual type
      Fix many const pointer warnings
      Remove unnecessary casts from malloc & realloc calls
      Strip trailing whitespace
      Mark fatal() & Syntax() with printf & noreturn attributes
      Rename args to several functions to not shadow global variables
      Only add -P flag if using cpp as our preprocessor
      Add -version flag to print package version string from autoconf
      xrdb 1.1.0

Egbert Eich (2):
      Usage: In usage message print preprocessor that's actually chosen.
      Allow the CPP macro to contain preprocessors with command line options (v2)

Jon TURNEY (1):
      Fix build with WIN32 defined, but PATHETICCPP not defined

Matthieu Herrb (1):
      predefined cpp macros can produce unexpected results (bug 3413)

# $NetBSD: Makefile,v 1.9 2013/09/09 09:42:22 wiz Exp $

DISTNAME=		xrdb-1.1.0
CATEGORIES=		x11
MASTER_SITES=		${MASTER_SITE_XORG:=app/}
EXTRACT_SUFX=		.tar.bz2

MAINTAINER=		joerg@NetBSD.org
HOMEPAGE=		http://xorg.freedesktop.org/
COMMENT=		X server resource database utility

GNU_CONFIGURE=		yes
USE_TOOLS+=		pkg-config

CONFIGURE_ARGS+=	--with-cpp=${CPPPATH}

.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXmu/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"