[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / xplanet

File: [cvs.NetBSD.org] / pkgsrc / x11 / xplanet / Makefile (download)

Revision 1.32, Wed Sep 20 18:20:39 2006 UTC (17 years, 6 months ago) by xtraeme
Branch: MAIN
Changes since 1.31: +14 -1 lines

Make X11 dependency an option... and enabled by default as before.

Requested by gdamore@.

# $NetBSD: Makefile,v 1.32 2006/09/20 18:20:39 xtraeme Exp $

DISTNAME=	xplanet-1.2.0
PKGREVISION=	3
CATEGORIES=	x11
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=xplanet/}

MAINTAINER=	atatat@NetBSD.org
HOMEPAGE=	http://xplanet.sourceforge.net/
COMMENT=	Rotating rendered map of the Earth in X11 root window

USE_LANGUAGES=		c c++
USE_TOOLS+=		gmake
GNU_CONFIGURE=		yes

# directory creation should be fixed in the future release of xplanet
pre-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/xplanet
.for dir in arcs config fonts images markers origin satellites \
		scripts spice stars
	${INSTALL_DATA_DIR} ${PREFIX}/share/xplanet/${dir}
.endfor

PKG_OPTIONS_VAR=        PKG_OPTIONS.planet
PKG_SUPPORTED_OPTIONS=  x11
PKG_SUGGESTED_OPTIONS=  x11

.include "../../mk/bsd.options.mk"

.if !empty(PKG_OPTIONS:Mx11)
.include "../../devel/pango/buildlink3.mk"
.else
CONFIGURE_ARGS+=	--disable-pango
CONFIGURE_ARGS+=	--without-x
CONFIGURE_ARGS+=	--without-xscreensaver
.endif

.include "../../graphics/jpeg/buildlink3.mk"
.include "../../graphics/freetype2/buildlink3.mk"
.include "../../graphics/libungif/buildlink3.mk"
.include "../../graphics/netpbm/buildlink3.mk"
.include "../../graphics/png/buildlink3.mk"
.include "../../graphics/tiff/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"