[BACK]Return to Makefile.common CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / xosd

File: [cvs.NetBSD.org] / pkgsrc / x11 / xosd / Makefile.common (download)

Revision 1.22, Sat Mar 4 21:31:13 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2006Q4-base, pkgsrc-2006Q4, pkgsrc-2006Q3-base, pkgsrc-2006Q3, pkgsrc-2006Q2-base, pkgsrc-2006Q2, pkgsrc-2006Q1-base, pkgsrc-2006Q1
Changes since 1.21: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile.common,v 1.22 2006/03/04 21:31:13 jlam Exp $

DISTNAME=	xosd-2.2.12
CATEGORIES=	x11
MASTER_SITES=	http://www.ignavus.net/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.ignavus.net/software.html

DISTINFO_FILE=		${.CURDIR}/../../x11/xosd/distinfo
PATCHDIR=		${.CURDIR}/../../x11/xosd/patches

GNU_CONFIGURE=		yes
USE_LIBTOOL=		yes

SHLIBTOOL_OVERRIDE=	libtool-disable-static

CONFIGURE_ARGS+=	--disable-xinerama

# Avoid an ICE on sparc64 with gcc2
CONFIGURE_ENV+=		F77=${FALSE:Q}

SUBST_CLASSES+=		fixme
SUBST_STAGE.fixme=	post-patch
SUBST_FILES.fixme=	configure
SUBST_SED.fixme=	-e "s|-lpthread|${PTHREAD_LIBS}|g"

PTHREAD_AUTO_VARS=	yes

.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/x11.buildlink3.mk"