[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / xorgproto

File: [cvs.NetBSD.org] / pkgsrc / x11 / xorgproto / Makefile (download)

Revision 1.10, Sat Nov 23 11:41:20 2019 UTC (4 years, 4 months ago) by nia
Branch: MAIN
Changes since 1.9: +4 -1 lines

xorgproto: Force consistent man page installation for SunOS/etc

It appears to attempt to detect whether the system uses "Sys-V"-style
man categories by checking for a specific file in /usr/share/man.

This doesn't seem to be particularly accurate and causes problems with
varying PLISTs on pkgsrc depending on the system's filesystem layout.

So just force a consistent category number for "misc" pages for every OS,
for now...

# $NetBSD: Makefile,v 1.10 2019/11/23 11:41:20 nia Exp $

DISTNAME=		xorgproto-2019.2
PKGREVISION=		2
CATEGORIES=		x11 devel
MASTER_SITES=		${MASTER_SITE_XORG:=proto/}
EXTRACT_SUFX=		.tar.bz2

MAINTAINER=		joerg@NetBSD.org
HOMEPAGE=		http://xorg.freedesktop.org/
COMMENT=		Various X headers from Xorg X11
LICENSE=		mit

GNU_CONFIGURE=		yes
USE_LANGUAGES=		c

# some packages need the old headers
CONFIGURE_ARGS+=	--enable-legacy

# Force a consistent PLIST.
CONFIGURE_ENV+=		MISC_MAN_SUFFIX="7"

PKGCONFIG_OVERRIDE+=	applewmproto.pc.in
PKGCONFIG_OVERRIDE+=	bigreqsproto.pc.in
PKGCONFIG_OVERRIDE+=	compositeproto.pc.in
PKGCONFIG_OVERRIDE+=	damageproto.pc.in
PKGCONFIG_OVERRIDE+=	dmxproto.pc.in
PKGCONFIG_OVERRIDE+=	dri2proto.pc.in
PKGCONFIG_OVERRIDE+=	dri3proto.pc.in
PKGCONFIG_OVERRIDE+=	fixesproto.pc.in
PKGCONFIG_OVERRIDE+=	fontsproto.pc.in
PKGCONFIG_OVERRIDE+=	glproto.pc.in
PKGCONFIG_OVERRIDE+=	inputproto.pc.in
PKGCONFIG_OVERRIDE+=	kbproto.pc.in
PKGCONFIG_OVERRIDE+=	presentproto.pc.in
PKGCONFIG_OVERRIDE+=	randrproto.pc.in
PKGCONFIG_OVERRIDE+=	recordproto.pc.in
PKGCONFIG_OVERRIDE+=	renderproto.pc.in
PKGCONFIG_OVERRIDE+=	resourceproto.pc.in
PKGCONFIG_OVERRIDE+=	scrnsaverproto.pc.in
PKGCONFIG_OVERRIDE+=	trapproto.pc.in
PKGCONFIG_OVERRIDE+=	videoproto.pc.in
PKGCONFIG_OVERRIDE+=	windowswmproto.pc.in
PKGCONFIG_OVERRIDE+=	xcmiscproto.pc.in
PKGCONFIG_OVERRIDE+=	xextproto.pc.in
PKGCONFIG_OVERRIDE+=	xf86bigfontproto.pc.in
PKGCONFIG_OVERRIDE+=	xf86dgaproto.pc.in
PKGCONFIG_OVERRIDE+=	xf86driproto.pc.in
PKGCONFIG_OVERRIDE+=	xf86miscproto.pc.in
PKGCONFIG_OVERRIDE+=	xf86vidmodeproto.pc.in
PKGCONFIG_OVERRIDE+=	xineramaproto.pc.in
PKGCONFIG_OVERRIDE+=	xproto.pc.in
PKGCONFIG_OVERRIDE+=	xproxymngproto.pc.in

.include "../../mk/bsd.pkg.mk"