[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / xkeyboard-config

File: [cvs.NetBSD.org] / pkgsrc / x11 / xkeyboard-config / Makefile (download)

Revision 1.32, Thu Feb 2 18:47:30 2017 UTC (7 years, 2 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1
Changes since 1.31: +2 -2 lines

Updated xkeyboard-config to 2.20.

Emil Velikov (1):
      autogen.sh: use quoted string variables

Michal Suchanek (1):
      ctrl: add missing modifier_map

Mihail Konev (1):
      autogen: add default patch prefix

Peter Hutterer (3):
      Drop AM_MAINTAINER_MODE
      autogen.sh: honor NOCONFIGURE=1
      autogen.sh: use exec instead of waiting for configure to finish

Sergey Udaltsov (13):
      Add missing Arabic diacritics to Arabic layouts
      Restored original RALT behavior for German
      Rulemak layout (Colemak based Russian phonetic layout)
      fixed credits
      Add Elfdalian layout
      Fixed al(plisi)
      Added ruble to rulemak
      Changed AltGr+t to Turkish Lira (instead of trademark)
      prerelease 2.19.99 for translations
      Added Lira to Turkish F layout as well
      Updated translations, prerelease
      Erroneous patch applied for modifiers
      Release 2.20

Stefan Tauner (2):
      symbols/de: use rightsinglequotemark on BKSL in all variants
      symbols/de: Fix whitespace after adding rightsinglequotemark

# $NetBSD: Makefile,v 1.32 2017/02/02 18:47:30 wiz Exp $

DISTNAME=		xkeyboard-config-2.20
CATEGORIES=		x11
MASTER_SITES=		${MASTER_SITE_XORG:=data/${PKGBASE}/}
EXTRACT_SUFX=		.tar.bz2

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://www.freedesktop.org/wiki/Software/XKeyboardConfig
COMMENT=		X Keyboard Configuration Database

BUILD_DEPENDS+=		xkbcomp-[0-9]*:../../x11/xkbcomp

CONFLICTS+=		xkbdata-[0-9]*

MAKE_JOBS_SAFE=		no

GNU_CONFIGURE=		yes
USE_LIBTOOL=		yes
USE_TOOLS+=		gmake intltool msgfmt pkg-config
PKGCONFIG_OVERRIDE+=	xkeyboard-config.pc.in

BUILD_DEFS+=		VARBASE
BUILD_DEFS+=		XKBCOMPDIR

CONFIGURE_ARGS+=	--with-xkb-rules-symlink=xfree86,xorg
CONFIGURE_ARGS+=	--with-xkb-base=${XKBBASE:Q}
CONFIGURE_ARGS+=	--datadir=${PREFIX}/share
CONFIGURE_ARGS+=	--without-xsltproc
###
REPLACE_SH=		rules/merge.sh
###
### Keymaps, rules, etc. are installed here.
###
XKBBASE=		${PREFIX}/share/X11/xkb
###
### The server puts compiled keymaps in the directory below.
###
XKBCOMPDIR?=		${VARBASE}/db/xkb
###
### The package must symlink ${XKBCOMPDIR} into ${XKBBASE}. ${XKBCOMP} is
### is the path to the xkbcomp binary we wish to use.
###
XKBCOMPDIR_SYMLINK=	${XKBBASE}/compiled
XKBCOMP=		${PREFIX}/bin/xkbcomp

FILES_SUBST+=		XKBBASE=${XKBBASE:Q}
FILES_SUBST+=		XKBCOMP=${XKBCOMP:Q}
FILES_SUBST+=		XKBCOMP_SYMLINK=${${XKBBASE}/xkbcomp:L:Q}
FILES_SUBST+=		XKBCOMPDIR=${XKBCOMPDIR:Q}
FILES_SUBST+=		XKBCOMPDIR_SYMLINK=${XKBCOMPDIR_SYMLINK:Q}

OWN_DIRS+=		${XKBCOMPDIR}

BUILDLINK_DEPMETHOD.gettext=	build	# for the configure only
.include "../../devel/gettext-lib/buildlink3.mk"

BUILDLINK_API_DEPENDS.libX11+=	libX11>=1.4.3
.include "../../x11/libX11/buildlink3.mk"
BUILDLINK_API_DEPENDS.xproto+=	xproto>=7.0.20
.include "../../x11/xproto/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"