[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / xfstt

File: [cvs.NetBSD.org] / pkgsrc / x11 / xfstt / Makefile (download)

Revision 1.33, Wed Jun 13 08:23:26 2012 UTC (11 years, 10 months ago) by mef
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3, pkgsrc-2012Q2-base, pkgsrc-2012Q2
Changes since 1.32: +2 -2 lines

Makefile
	CHANGES file no longer exists, remove from install file list.
PLIST
	Because of missing CHANGES, two files were not installed.
	Pick them up again.

# $NetBSD: Makefile,v 1.33 2012/06/13 08:23:26 mef Exp $
#

DISTNAME=		xfstt-1.9
CATEGORIES=		x11 net fonts
MASTER_SITES=		http://download.berlios.de/xfstt/

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://developer.berlios.de/projects/xfstt/
COMMENT=		TrueType font server for X11
LICENSE=		gnu-gpl-v2

PKG_DESTDIR_SUPPORT=	user-destdir

USE_LANGUAGES=		c c++
USE_X11BASE=		YES
USE_TOOLS+=		gmake pkg-config
GNU_CONFIGURE=		YES

# There isn't really any l10n yet, only some preliminary i18n support.
CONFIGURE_ARGS+=	--disable-nls

CXXFLAGS+=		-fomit-frame-pointer -ffast-math

RCD_SCRIPTS=		xfstt
INSTALLATION_DIRS=	bin			\
			${PKGMANDIR}/man1	\
			lib/X11/fonts/TTF	\
			share/doc/xfstt		\
			share/examples/xfstt

SUBST_CLASSES+=		paths
SUBST_FILES.paths=	doc/FAQ doc/xfstt.1x
SUBST_SED.paths=	-e 's,@PREFIX@,${PREFIX},g'
SUBST_STAGE.paths=	post-patch

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/src/xfstt ${DESTDIR}${PREFIX}/bin
	${INSTALL_MAN} ${WRKSRC}/doc/xfstt.1x \
		${DESTDIR}${PREFIX}/${PKGMANDIR}/man1/xfstt.1
	cd ${WRKSRC} && (					\
	    ${INSTALL_DATA} doc/FAQ TODO THANKS		\
		${DESTDIR}${PREFIX}/share/doc/xfstt/ ;		\
	    ${INSTALL_DATA} doc/examples/font.properties	\
		 ${DESTDIR}${PREFIX}/share/examples/xfstt/	\
	)

.include "../../x11/fontsproto/buildlink3.mk"
.include "../../x11/xproto/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"