[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / xfstt

File: [cvs.NetBSD.org] / pkgsrc / x11 / xfstt / Makefile (download)

Revision 1.13, Sat Feb 22 13:33:31 2003 UTC (21 years, 1 month ago) by salo
Branch: MAIN
Changes since 1.12: +22 -20 lines

Updated to version 1.4.

Changes:

- added MESSAGE file with post-install instructions
- minor cleanups

1.4:
====
- Auto* tools
- Initial i18n support (not used yet)
- Fixed slow down with some programs using FS_ListFontsWithXInfo
- Fixed childs unlinking unix socket when father uid == childs uid
- Added an option to specify pidfile location
- Added endpwent() to prevent leaking one fd
- Changed usage output

1.3.1:
======
- Added --cache description to man page

# $NetBSD: Makefile,v 1.13 2003/02/22 13:33:31 salo Exp $
#

DISTNAME=		xfstt-1.4
CATEGORIES=		x11 net fonts
MASTER_SITES=		http://download.berlios.de/xfstt/

MAINTAINER=		packages@netbsd.org
HOMEPAGE=		http://developer.berlios.de/projects/xfstt
COMMENT=		TrueType font server for X11

USE_PKGINSTALL=		YES
USE_X11BASE=		YES
USE_GMAKE=		YES
GNU_CONFIGURE=		YES

# There isn't really any l10n yet, only some preliminary i18n support.
CONFIGURE_ARGS+=	--disable-nls

CXXFLAGS+=		-fomit-frame-pointer -ffast-math

RCD_SCRIPTS=		xfstt

post-patch:
	@( \
	cd ${WRKSRC} ; \
	for f in src/perftest.cc src/xfstt.cc doc/xfstt.1x; \
	do \
	    ${MV} $$f $$f.orig ; \
	    ${SED} ${FILES_SUBST_SED} $$f.orig > $$f ; \
	done ; \
	)

do-install:
	${INSTALL_PROGRAM} ${WRKSRC}/src/xfstt ${PREFIX}/bin
	${INSTALL_MAN} ${WRKSRC}/doc/xfstt.1x ${PREFIX}/man/man1/xfstt.1
	${INSTALL_DATA_DIR} ${PREFIX}/lib/X11/fonts/TrueType
	${INSTALL_DATA_DIR} ${PREFIX}/share/doc/xfstt
	${INSTALL_DATA_DIR} ${PREFIX}/share/examples/xfstt
	cd ${WRKSRC} && (				\
	${INSTALL_DATA} doc/FAQ CHANGES TODO THANKS	\
		${PREFIX}/share/doc/xfstt/ ;		\
	${INSTALL_DATA} doc/examples/font.properties	\
		 ${PREFIX}/share/examples/xfstt/	\
	)

.include "../../mk/bsd.pkg.mk"