[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / xfd

File: [cvs.NetBSD.org] / pkgsrc / x11 / xfd / Makefile (download)

Revision 1.9, Wed Jan 23 18:59:12 2013 UTC (11 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.8: +4 -5 lines

Update to 1.1.1 based on PR 47475 by Richard Palo.

1.1.1:
This minor maintenance release fixes some build configuration issues
and some (but not all) compiler warnings.

Alan Coopersmith (4):
      Strip trailing whitespace
      Add const attribute to domaindir fix gcc -Wwrite-strings warnings
      Remove freetype2 from PKG_CHECK_MODULES list
      xfd 1.1.1

Gaetan Nadon (6):
      config: replace deprecated AC_HELP_STRING with AS_HELP_STRING
      config: replace deprecated AM_CONFIG_HEADER with AC_CONFIG_HEADERS
      man: remove trailing spaces and tabs
      man: replace hard coded man page section with substitution strings
      config: move man pages into their own directory
      Use the Automake recommended alternative to AX_DEFINE_DIR


1.1.0:

This release adds internationalization support (though with no translations
contributed yet), drops Xaw8 support, and accumulates a number of years worth
of build configuration improvements and janitorial cleanups.

Alan Coopersmith (10):
      Update man page to better reflect Xft support
      Add README with pointers to mailing lists, bugzilla, & git
      Bump xorg-macros requirement to 1.4 for XORG_INSTALL changes
      Fill in COPYING with notices from source code & man page
      Integrate gettext support with autotools build system
      Clean up CFLAGS/LIB settings in configure.ac & Makefile.am
      Use AM_V_GEN to silence manpage generation too
      config: upgrade to util-macros 1.8 for additional man page support
      config: Remove unnecessary calls from configure.ac
      xfd 1.1.0

Gaetan Nadon (9):
      .gitignore: use common defaults with custom section # 24239
      Makefile.am: ChangeLog not required: EXTRA_DIST or *CLEANFILES #24432
      Deploy the new XORG_DEFAULT_OPTIONS #24242
      INSTALL, NEWS, README or AUTHORS files are missing/incorrect #24206
      Makefile.am: add ChangeLog and INSTALL on MAINTAINERCLEANFILES
      configure.ac: use backticks rather than $() for cmd subs
      config: update and relocate AX_DEFINE_DIR macro
      config: ignore xfd.po file when gettext is used
      config: update AC_PREREQ statement to 2.60

James Cloos (4):
      Rename .cvsignore to .gitignore
      Add *~ to .gitignore to skip patch/emacs droppings
      Replace static ChangeLog with dist-hook to generate from git log
      xaw8 is gone, use xaw7

Jay Hobson (1):
      Internationalize xfd: Call gettext on strings printed to stderr

Jeremy Huddleston (2):
      Build fix for file systems that are not case sensitive
      Added missing AM_PROG_CC_C_O

Matthieu Herrb (1):
      Let xfd build on systems without gettext.

Paulo Cesar Pereira de Andrade (1):
      Correct make distcheck and sparse warnings.

Peter Breitenlohner (1):
      enable VPATH build, reorganize app default files

# $NetBSD: Makefile,v 1.9 2013/01/23 18:59:12 wiz Exp $
#

DISTNAME=	xfd-1.1.1
CATEGORIES=	x11
MASTER_SITES=	${MASTER_SITE_XORG:=app/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://xorg.freedesktop.org/
COMMENT=	Display all the characters in an X font

GNU_CONFIGURE=	yes
USE_TOOLS+=	pkg-config

CONFIGURE_ENV+=		APP_MAN_SUFFIX=1
MAKE_FLAGS+=		appdefaultdir=${PREFIX}/lib/X11/app-defaults

.include "../../x11/libXft/buildlink3.mk"
.include "../../x11/libXaw/buildlink3.mk"
.include "../../x11/libXmu/buildlink3.mk"
.include "../../x11/libXrender/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"