[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / xf86-video-amdgpu

File: [cvs.NetBSD.org] / pkgsrc / x11 / xf86-video-amdgpu / Makefile (download)

Revision 1.16, Wed Mar 6 14:00:30 2019 UTC (5 years ago) by wiz
Branch: MAIN
Changes since 1.15: +2 -2 lines

xf86-video-amdgpu: update to 19.0.0.

I'm pleased to announce the 19.0.0 release of xf86-video-amdgpu, the
Xorg driver for AMD Radeon GPUs supported by the amdgpu kernel driver.
This release supports xserver versions 1.13-1.20.

Highlights:

* Support for FreeSync variable refresh rate (this also requires the
  amdgpu driver from kernel 5.0 or newer, and radeonsi from Mesa 19.0 or
  newer).
* Various TearFree related fixes and robustness improvements.
* Support for scanout buffers using DCC colour compression.
* Up to six independent instances per GPU are now supported in "Zaphod"
  style multi-head configurations.

Plus other improvements and fixes. Thanks to everybody who contributed
to this release in any way!


Mario Kleiner (1):
      Fix crash when page flipping in multi-X-Screen/Zaphod mode

Michel Dänzer (53):
      Post-release version bump
      Convert README to markdown
      Handle pending scanout update in drmmode_crtc_scanout_free
      Make wait_pending_flip / handle_deferred symmetric in set_mode_major
      Cast return value of amdgpu_get_marketing_name to char*
      Fix --disable-glamor build
      Add GitLab CI configuration
      Fix condition for calling set_pixmap_bo in drmmode_xf86crtc_resize
      Allow up to six instances in Zaphod mode
      Detect and fix up non-premultiplied cursor data
      glamor: Can work at depth >= 15 with current xserver Git master
      man: This driver supports colour depths 8, 15 and 16
      Add README.md to EXTRA_DIST
      Relax detection of non-premultiplied alpha cursor data
      Use drm_abort_one in drm_queue_handler
      Explicitly keep track of whether a DRM event is for a flip or not
      Move deferred vblank events to separate drm_vblank_deferred list
      Skip gamma correction of cursor data if premultiplied R/G/B > alpha
      Generate docker image as part of CI pipeline
      Perform scanout buffer update immediately if drmmode_wait_vblank fails
      Cancel pending scanout update in drmmode_crtc_scanout_update
      Automatically try re-enabling TearFree after a flip failed
      Don't use GBM for allocating HW cursor BOs
      Drop AMDGPUInfoRec::cursor_buffer array
      Use drmIoctl in drmmode_show_cursor
      Update cursor position in drmmode_show_cursor if hotspot changed
      Use two HW cursor buffers per CRTC
      Don't clear info->flip_window in present_unflip
      Remove superfluous vrr_flipping field and clean up related code
      gitlab-ci: Use kaniko instead of docker-in-docker for image generation
      Only call drmmode_uevent_init if RandR is enabled
      Only call drmmode_validate_leases if RandR is enabled
      dri3: Flush if necessary in dri3_fd_from_pixmap
      dri2: Flush in dri2_create_buffer2 after calling glamor_set_pixmap_bo
      glamor: Avoid glamor_create_pixmap for pixmaps backing windows
      Don't allow TearFree scanout flips to complete in the same vblank period
      Only update drmmode_crtc->flip_pending after actually submitting a flip
      Call drmHandleEvent again if it was interrupted by a signal
      Keep waiting for a pending flip if drm_handle_event returns 0
      gitlab-ci: Only run docker-image stage if relevant source files change
      gitlab-ci: Don't rely on $CI_PROJECT_NAME
      Don't register a window private if VRR is disabled
      Don't enable the VRR support code for GPU screens
      Wrap change/delete window property request handlers
      Make use of property request wrappers for VRR property
      Call amdgpu_present_set_screen_vrr from amdgpu_vrr_property_update
      present: Check that flip and screen pixmap pitches match
      dri2: Call drm_queue_handle_deferred in dri2_deferred_event
      Revert "gitlab-ci: Only run docker-image stage if relevant source files change"
      Revert "Remove set but unused amdgpu_dri2::pKernelDRMVersion"
      Make drmmode_cm_enabled an inline function
      present: Don't check tiling parameters with DC & DRM minor version >= 31
      Bump version for the 19.0.0 release

Nicholas Kazlauskas (2):
      Check last flip window instead of screen root before flipping
      Support CRTC variable refresh for windows using Present flips

# $NetBSD: Makefile,v 1.16 2019/03/06 14:00:30 wiz Exp $

DISTNAME=	xf86-video-amdgpu-19.0.0
CATEGORIES=	x11
MASTER_SITES=	${MASTER_SITE_XORG:=driver/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	joerg@NetBSD.org
HOMEPAGE=	http://xorg.freedesktop.org/
COMMENT=	Modular Xorg ATI (Tonga, Carrizo, Iceland, Fiji, Stoney) driver
LICENSE=	mit AND x11

USE_LIBTOOL=	yes
GNU_CONFIGURE=	yes
USE_TOOLS+=	gmake pkg-config

CONFIGURE_ENV.SunOS+=	DRIVER_MAN_SUFFIX=4

.include "../../x11/libdrm/buildlink3.mk"
.include "../../x11/modular-xorg-server/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"