[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / xf86-input-keyboard

File: [cvs.NetBSD.org] / pkgsrc / x11 / xf86-input-keyboard / Makefile (download)

Revision 1.12, Sun May 6 20:00:23 2012 UTC (11 years, 11 months ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2012Q2-base, pkgsrc-2012Q2
Changes since 1.11: +3 -3 lines

Update to 1.6.1, provided by Francois Tigeot in PR 46416.

1.6.1:

Remove calls to xf86IsPc98
Return proper default for unknown values in pInfo->device_control
Man page fixes

1.6.0:

Various manual page fixes

1.5.99.901:

Adjust to input ABI 12
Require server 1.4 or later
Remove paranoia about event processing during suspend
Remove unused code and variables
bsd: Include fix
linux: warning fixes
Remove unused OpenBSD PCCONS code
Make key codes for Sun Japanese keyboard match xkb-config mappings
Fix default options for PC98
bsd: Fix print wscons type keyboard for Sun5
Do not print values of variables XkbRules etc. twice
Remove random History comment and OS_KBD_VERSION_CURRENT
Replace deprecated xfree/xcalloc with free & calloc
Remove unused PROT_XQUEUE and PROT_USB
Remove unused bell_pitch and bell_duration
lnx: Fix detect CustomKeycodes for __powerpc__
Do not print values of Protocol twice
Cleanup set the value of CustomKeycodes
Removed unnecessary code, since ABI_XINPUT_VERSION >= 2

1.5.0:

Various documentation and configuration fixes
Silence sed substitutions in make output
Various configure and pkg-config fixes
Missing #ifdef for PCCONS
Remove unused SCO driver files
upgrade to util-macros 1.8 for additional man page support
sun_kbd: Add mappings for Hangul and Hanja keys on Korean keyboard
Remove unused keyboardOptions
Various code cleanups
Sun's copyrights now belong to Oracle

1.4.0:

Require macros 1.3 for XORG_DEFAULT_OPTIONS
Don't use XKB_DFLT_RULES from the server
Remove now un-used autorepeat field

1.3.99.1:

Fix return type issues, remove unused variables, clear compiler warnings
Add note on hal-based configuration to man page
Add README with pointers to mailing list, bugzilla & git repos
Switch to new XKB API, remove all "noXkb" handling
Use XKB_DFLT_RULES from xorg-server.h for default xkb rules filename
Remove SpecialKey handling
Remove leftover ifdef XINPUT
Remove special support for Panix106 (SVR4 derivative)
Remove ModuleInfoRec
Remove autorepeat
nec/jp layout is just "jp" these days.
No more special sun keyboards anymore.
Fix xf86-input-keyboard build on Linux/sparc
Return BadValue if the server failed to init the keyboard. (#21278)
Assume Solaris is at least Solaris 8
Solaris keyboard fixes for HAL hotplugging support
Override HKTG & BSlash2 keycodes on Solaris
Sun bug 6852921: Recycling Xorg runs out of file descriptors in kbd driver
sun_kbd: re-open keyboard if needed in KbdOn
sun_kbd: Use HID ioctl variants to get/set direct mode on usbhid devices
sun_kbd: Check if streams module is already on the stack before pushing it

# $NetBSD: Makefile,v 1.12 2012/05/06 20:00:23 wiz Exp $

DISTNAME=	xf86-input-keyboard-1.6.1
CATEGORIES=	x11
MASTER_SITES=	${MASTER_SITE_XORG:=driver/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	joerg@NetBSD.org
HOMEPAGE=	http://xorg.freedesktop.org/
COMMENT=	Modular Xorg keyboard driver

PKG_DESTDIR_SUPPORT=	user-destdir

USE_LIBTOOL=	YES
GNU_CONFIGURE=	YES
USE_TOOLS+=	gmake pkg-config

.include "../../x11/inputproto/buildlink3.mk"
.include "../../x11/libxkbfile/buildlink3.mk"
.include "../../x11/randrproto/buildlink3.mk"
.include "../../x11/modular-xorg-server/buildlink3.mk"
.include "../../x11/kbproto/buildlink3.mk"
.include "../../x11/xproto/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"