[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / xcb-util

File: [cvs.NetBSD.org] / pkgsrc / x11 / xcb-util / Makefile (download)

Revision 1.9, Tue Oct 2 12:09:41 2012 UTC (7 years ago) by tron
Branch: MAIN
Changes since 1.8: +2 -1 lines

Increase the minium required version of the "x11/libxcb" package to 1.6.
There are at least two packages ("graphics/cairo" and "x11/xlsclients")
which require this. And we definitely want to avoid the situation where
both the based and "pkgsrc" version get used at the same time.

Bump all the packages which use the "x11/libxcb" package except the two
which already require version 1.6. For those package remove the manually
set minimum required version.

Change discussed with Thomas Klausner in private e-mail.

# $NetBSD: Makefile,v 1.9 2012/10/02 12:09:41 tron Exp $
#

DISTNAME=	xcb-util-0.3.9
PKGREVISION=	1
CATEGORIES=	x11
MASTER_SITES=	http://xcb.freedesktop.org/dist/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://xcb.freedesktop.org/
COMMENT=	XCB Utilities

PKG_DESTDIR_SUPPORT=	user-destdir

GNU_CONFIGURE=	yes
USE_TOOLS+=	pkg-config gmake gm4
USE_LIBTOOL=	yes

PKGCONFIG_OVERRIDE+=	xcb-util.pc.in
PKGCONFIG_OVERRIDE+=	xcb-atom.pc.in
PKGCONFIG_OVERRIDE+=	xcb-event.pc.in
PKGCONFIG_OVERRIDE+=	xcb-aux.pc.in

.include "../../devel/gperf/buildlink3.mk"
.include "../../x11/libxcb/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"