[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / wxGTK28-contrib

File: [cvs.NetBSD.org] / pkgsrc / x11 / wxGTK28-contrib / Makefile (download)

Revision 1.44, Wed May 20 06:09:09 2020 UTC (3 years ago) by rillig
Branch: MAIN
Changes since 1.43: +8 -1 lines

mark packages that fail with -Werror=char-subscripts

These packages are susceptible to bugs when confronted with non-ASCII
characters.

See https://gcc.gnu.org/bugzilla/show_bug.cgi?id=94182.

It takes some time to analyze and fix these individually, therefore they
are only marked as "needs work".

# $NetBSD: Makefile,v 1.44 2020/05/20 06:09:09 rillig Exp $

.include "../../x11/wxGTK28/Makefile.common"

PKGNAME=	${DISTNAME:S/wxGTK/wxGTK28-contrib/}
PKGREVISION=	15
COMMENT=	Contrib libraries for wxWidgets GTK

USE_TOOLS+=		gmake

BUILD_DIRS=		build-non-unicode/contrib/src \
			build-unicode/contrib/src

# We patch configure
CHECK_PORTABILITY_SKIP+=	configure.in

INSTALL_TARGET=		install

BUILDLINK_DEPMETHOD.libXt?=	build

# ../../../../contrib/src/stc/scintilla/src/Editor.cxx: In member function 'void Editor::LayoutLine(int, Surface*, ViewStyle&, LineLayout*, int)':
# ../../../../contrib/src/stc/scintilla/src/Editor.cxx:2048:47: error: array subscript has type 'char' [-Werror=char-subscripts]
#         if (ctrlCharWidth[ll->chars[charInLine]] == 0) {
#                                                ^
# Maybe fix this later.
BUILDLINK_TRANSFORM+=	rm:-Werror=char-subscripts

.include "../../x11/wxGTK28/buildlink3.mk"
.include "../../x11/libXt/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"