[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / startup-notification010

File: [cvs.NetBSD.org] / pkgsrc / x11 / startup-notification010 / Attic / Makefile (download)

Revision 1.3, Tue Oct 2 12:09:41 2012 UTC (11 years, 6 months ago) by tron
Branch: MAIN
Changes since 1.2: +2 -2 lines

Increase the minium required version of the "x11/libxcb" package to 1.6.
There are at least two packages ("graphics/cairo" and "x11/xlsclients")
which require this. And we definitely want to avoid the situation where
both the based and "pkgsrc" version get used at the same time.

Bump all the packages which use the "x11/libxcb" package except the two
which already require version 1.6. For those package remove the manually
set minimum required version.

Change discussed with Thomas Klausner in private e-mail.

# $NetBSD: Makefile,v 1.3 2012/10/02 12:09:41 tron Exp $

DISTNAME=		startup-notification-0.10
PKGREVISION=		3
CATEGORIES=		x11
MASTER_SITES=		http://www.freedesktop.org/software/startup-notification/releases/

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://www.freedesktop.org/wiki/Software/startup-notification
COMMENT=		X11 application startup notification library
LICENSE=		mit AND gnu-lgpl-v2.1

PKG_INSTALLATION_TYPES=	overwrite pkgviews
PKG_DESTDIR_SUPPORT=	user-destdir

USE_TOOLS+=		pkg-config
GNU_CONFIGURE=		yes
USE_LIBTOOL=		yes

PKGCONFIG_OVERRIDE=	libstartup-notification-1.0.pc.in

DOCDIR=			${PREFIX}/share/doc/startup-notification
INSTALLATION_DIRS+=	${DOCDIR}

post-install:
	cd ${WRKSRC} && ${INSTALL_DATA} AUTHORS COPYING ChangeLog NEWS \
		doc/startup-notification.txt ${DESTDIR}${DOCDIR}

BUILDLINK_DEPMETHOD.libXt?=	build

.include "../../x11/libSM/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXt/buildlink3.mk"
.include "../../x11/libxcb/buildlink3.mk"
.include "../../x11/xcb-util036/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"