[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / rxvt-unicode

File: [cvs.NetBSD.org] / pkgsrc / x11 / rxvt-unicode / Makefile (download)

Revision 1.49, Sat Nov 30 23:24:10 2013 UTC (10 years, 4 months ago) by morr
Branch: MAIN
CVS Tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1, pkgsrc-2013Q4-base, pkgsrc-2013Q4
Changes since 1.48: +2 -5 lines

Update to verion 9.19.

Changes:

- work around perl 5.18.0 breakage in tabbed extension
  (reported by Karol Blazewicz) and in pod (Dominic Hargreaves).
- fix regression that caused the double-click word selection to
  erroneously include a tab on the left of the selected word.
- implement FOCUS variable and focus_fade function in background
  expression, to allow focus-sensitive background images.
- add support for the set cursor style (DECSCUSR) control
  function.
- honour cursorColor also when the cursor style is underline.
- export some Color_xxx constants to Perl.

pkgsrc changes:
- remove patches/patch-src_perl_tabbed, it is upstream now

# $NetBSD: Makefile,v 1.49 2013/11/30 23:24:10 morr Exp $

DISTNAME=	rxvt-unicode-9.19
CATEGORIES=	x11
MASTER_SITES=	http://dist.schmorp.de/rxvt-unicode/ \
		http://dist.schmorp.de/rxvt-unicode/Attic/
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://software.schmorp.de/pkg/rxvt-unicode.html
COMMENT=	Clone of rxvt supporting Xft fonts and Unicode
LICENSE=	gnu-gpl-v2

GNU_CONFIGURE=	yes
USE_LANGUAGES=	c c++
USE_TOOLS+=	pkg-config
USE_FEATURES+=	snprintf

CONFIGURE_ENV+=		ac_cv_path_TIC=no

CONFIGURE_ARGS+=	--enable-256-color

INSTALLATION_DIRS+=	share/doc/rxvt-unicode share/examples/rxvt-unicode

post-install:
	${INSTALL_DATA} ${WRKSRC}/README.FAQ \
		${DESTDIR}${PREFIX}/share/doc/rxvt-unicode
.for t in rxvt-unicode.termcap rxvt-unicode.terminfo
	${INSTALL_DATA} ${WRKSRC}/doc/etc/${t} \
		${DESTDIR}${PREFIX}/share/examples/rxvt-unicode
.endfor

.include "options.mk"

.include "../../x11/libXpm/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"