The NetBSD Project

CVS log for pkgsrc/x11/ruby-tk/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / x11 / ruby-tk

Request diff between arbitrary revisions


Default branch: MAIN


Revision 1.60 / (download) - annotate - [select for diffs], Mon Apr 15 14:35:12 2019 UTC (5 weeks, 5 days ago) by wiz
Branch: MAIN
CVS Tags: HEAD
Changes since 1.59: +2 -2 lines
Diff to previous 1.59 (colored)

ruby-tk: remove reference to ruby 2.3

Revision 1.59 / (download) - annotate - [select for diffs], Mon Apr 15 14:27:07 2019 UTC (5 weeks, 5 days ago) by taca
Branch: MAIN
Changes since 1.58: +0 -0 lines
Diff to previous 1.58 (colored)

x11/ruby-tk: revert package remove

Revert ruby-tk package remove.  It is stiil required by lang/ruby22.

Revision 1.58, Sun Apr 14 15:34:44 2019 UTC (5 weeks, 6 days ago) by taca
Branch: MAIN
Changes since 1.57: +1 -1 lines
FILE REMOVED

x11/ruby-tk: remove ruby-tk

Remove ruby-tk, really it was ruby23-tk.
Someday, ruby-tk-gem would be renamed to ruby-tk.

Revision 1.57 / (download) - annotate - [select for diffs], Fri Dec 28 12:34:36 2018 UTC (4 months, 3 weeks ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2019Q1-base, pkgsrc-2019Q1, pkgsrc-2018Q4-base, pkgsrc-2018Q4
Changes since 1.56: +1 -6 lines
Diff to previous 1.56 (colored)

x11/ruby-tk: clean up Makefile

Remove code fragments for ruby18.

Revision 1.56 / (download) - annotate - [select for diffs], Thu Mar 29 03:16:11 2018 UTC (13 months, 3 weeks ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Changes since 1.55: +1 -2 lines
Diff to previous 1.55 (colored)

x11/ruby-tk: reset PKGREVISION

Reset PKGREVISION by updates of all ruby*-base packages.

Revision 1.55 / (download) - annotate - [select for diffs], Mon Mar 12 11:17:57 2018 UTC (14 months, 2 weeks ago) by wiz
Branch: MAIN
Changes since 1.54: +2 -1 lines
Diff to previous 1.54 (colored)

Recursive bumps for fontconfig and libzip dependency changes.

Revision 1.54 / (download) - annotate - [select for diffs], Fri Sep 15 00:37:14 2017 UTC (20 months, 1 week ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4, pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-
Changes since 1.53: +1 -2 lines
Diff to previous 1.53 (colored)

Reset PKGREVISION.

Revision 1.53 / (download) - annotate - [select for diffs], Tue Jun 20 22:38:16 2017 UTC (23 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2017Q2-base, pkgsrc-2017Q2
Changes since 1.52: +2 -2 lines
Diff to previous 1.52 (colored)

No more Ruby 2.1.

Revision 1.52 / (download) - annotate - [select for diffs], Tue May 30 15:49:12 2017 UTC (23 months, 3 weeks ago) by taca
Branch: MAIN
Changes since 1.51: +4 -2 lines
Diff to previous 1.51 (colored)

* Replace RUBY_VERSION_FULL with RUBY_VERSION since there is no
  RUBY_VERSION_FULL contains Ruby's patchlevel.
* Add comment to RUBY_VERSIONS_ACCEPTED that ruby-tk is not bundled by
  Ruby 2.4 and later.

Revision 1.51 / (download) - annotate - [select for diffs], Sat Apr 22 18:27:05 2017 UTC (2 years, 1 month ago) by taca
Branch: MAIN
Changes since 1.50: +2 -2 lines
Diff to previous 1.50 (colored)

Remove 18 from RUBY_VERSIONS_ACCEPTED.

Revision 1.50 / (download) - annotate - [select for diffs], Thu Sep 8 15:19:19 2016 UTC (2 years, 8 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3
Changes since 1.49: +2 -2 lines
Diff to previous 1.49 (colored)

Rename RUBY_VERSION_SUPPORTED into _RUBY_VERSIONS_ACCEPTED to follow the
naming scheme of the other multi-version packages. Add support for the
coorresponding RUBY_VERSIONS_INCOMPATIBLE list.

Revision 1.49 / (download) - annotate - [select for diffs], Mon Mar 14 00:59:07 2016 UTC (3 years, 2 months ago) by tnn
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Changes since 1.48: +2 -2 lines
Diff to previous 1.48 (colored)

remove references to ruby200

Revision 1.48 / (download) - annotate - [select for diffs], Wed Dec 30 15:03:49 2015 UTC (3 years, 4 months ago) by taca
Branch: MAIN
Changes since 1.47: +2 -3 lines
Diff to previous 1.47 (colored)

Add support for ruby23.

Revision 1.47 / (download) - annotate - [select for diffs], Mon Nov 23 15:46:59 2015 UTC (3 years, 6 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Changes since 1.46: +2 -2 lines
Diff to previous 1.46 (colored)

Remove 193 from RUBY_VERSION_SUPPORTED.

Revision 1.46 / (download) - annotate - [select for diffs], Sun Mar 8 16:30:37 2015 UTC (4 years, 2 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.45: +2 -1 lines
Diff to previous 1.45 (colored)

Explictly allow build with ruby21-base.

Revision 1.45 / (download) - annotate - [select for diffs], Sun Dec 14 14:01:23 2014 UTC (4 years, 5 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4
Changes since 1.44: +7 -2 lines
Diff to previous 1.44 (colored)

Now build with tcl/tk 8.6 except ruby18.

Bump REVISION.

Revision 1.43.6.1 / (download) - annotate - [select for diffs], Sat Nov 1 19:35:00 2014 UTC (4 years, 6 months ago) by tron
Branch: pkgsrc-2014Q3
Changes since 1.43: +3 -2 lines
Diff to previous 1.43 (colored) next main 1.44 (colored)

Pullup ticket #4532 - requested by taca
x11/ruby-tk: bug fix patch

Revisions pulled up:
- x11/ruby-tk/Makefile                                          1.44

---
   Module Name:	pkgsrc
   Committed By:	taca
   Date:		Mon Oct 27 13:22:51 UTC 2014

   Modified Files:
   	pkgsrc/x11/ruby-tk: Makefile

   Log Message:
   Add a simple work around to link correctly xlib on X11_TYPE is "native"
   case.

Revision 1.44 / (download) - annotate - [select for diffs], Mon Oct 27 13:22:51 2014 UTC (4 years, 6 months ago) by taca
Branch: MAIN
Changes since 1.43: +3 -2 lines
Diff to previous 1.43 (colored)

Add a simple work around to link correctly xlib on X11_TYPE is "native"
case.

Revision 1.43 / (download) - annotate - [select for diffs], Mon Mar 10 14:23:51 2014 UTC (5 years, 2 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2014Q3-base, pkgsrc-2014Q2-base, pkgsrc-2014Q2, pkgsrc-2014Q1-base, pkgsrc-2014Q1
Branch point for: pkgsrc-2014Q3
Changes since 1.42: +4 -4 lines
Diff to previous 1.42 (colored)

Switch to use lang/tcl85 and x11/tk85 instead of lang/tcl and x11/tk.

Bump PKGREVISION.

Revision 1.42 / (download) - annotate - [select for diffs], Sat Jan 11 14:42:06 2014 UTC (5 years, 4 months ago) by adam
Branch: MAIN
Changes since 1.41: +2 -2 lines
Diff to previous 1.41 (colored)

Revbump after updating tcl/tk.

Revision 1.41 / (download) - annotate - [select for diffs], Sun Nov 24 15:26:30 2013 UTC (5 years, 6 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4
Changes since 1.40: +2 -1 lines
Diff to previous 1.40 (colored)

Fix wrong parameter from [ruby-list:49643] in ruby-tk package.

Bump PKGREVISION.

Revision 1.40 / (download) - annotate - [select for diffs], Thu Jun 27 16:37:16 2013 UTC (5 years, 10 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2013Q3-base, pkgsrc-2013Q3, pkgsrc-2013Q2-base, pkgsrc-2013Q2
Changes since 1.39: +1 -2 lines
Diff to previous 1.39 (colored)

Reset PKGREVISION by update of both ruby18 and ruby193.

Revision 1.39 / (download) - annotate - [select for diffs], Thu Jun 6 12:55:22 2013 UTC (5 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.38: +2 -2 lines
Diff to previous 1.38 (colored)

Bump PKGREVISION for libXft changes for NetBSD native X support on
NetBSD 6, requested by tron.

Revision 1.38 / (download) - annotate - [select for diffs], Tue Jun 4 22:17:32 2013 UTC (5 years, 11 months ago) by tron
Branch: MAIN
Changes since 1.37: +2 -2 lines
Diff to previous 1.37 (colored)

Try to fix the fallout caused by the fix for PR pkg/47882. Part 3:

Recursively bump package revisions again after the "freetype2" and
"fontconfig" handling was fixed.

Revision 1.37 / (download) - annotate - [select for diffs], Mon Jun 3 10:06:25 2013 UTC (5 years, 11 months ago) by wiz
Branch: MAIN
Changes since 1.36: +2 -2 lines
Diff to previous 1.36 (colored)

Bump freetype2 and fontconfig dependencies to current pkgsrc versions,
to address issues with NetBSD-6(and earlier)'s fontconfig not being
new enough for pango.

While doing that, also bump freetype2 dependency to current pkgsrc
version.

Suggested by tron in PR 47882

Revision 1.36 / (download) - annotate - [select for diffs], Mon Oct 29 05:06:51 2012 UTC (6 years, 6 months ago) by asau
Branch: MAIN
CVS Tags: pkgsrc-2013Q1-base, pkgsrc-2013Q1, pkgsrc-2012Q4-base, pkgsrc-2012Q4
Changes since 1.35: +1 -3 lines
Diff to previous 1.35 (colored)

Drop superfluous PKG_DESTDIR_SUPPORT, "user-destdir" is default these days.

Revision 1.35 / (download) - annotate - [select for diffs], Tue Aug 21 23:49:27 2012 UTC (6 years, 9 months ago) by marino
Branch: MAIN
CVS Tags: pkgsrc-2012Q3-base, pkgsrc-2012Q3
Changes since 1.34: +2 -1 lines
Diff to previous 1.34 (colored)

Recursive PKGREVISION bump for tcl and tk upgrade to 8.5.12

Revision 1.34 / (download) - annotate - [select for diffs], Tue Nov 8 15:24:59 2011 UTC (7 years, 6 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2012Q2-base, pkgsrc-2012Q2, pkgsrc-2012Q1-base, pkgsrc-2012Q1, pkgsrc-2011Q4-base, pkgsrc-2011Q4
Changes since 1.33: +2 -2 lines
Diff to previous 1.33 (colored)

* Change RUBY_VERSION_SUFFIX to RUBY_VERSION_FULL.
* Add support for Ruby 1.9.3.

Revision 1.33 / (download) - annotate - [select for diffs], Fri Aug 12 15:37:54 2011 UTC (7 years, 9 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2011Q3-base, pkgsrc-2011Q3
Changes since 1.32: +2 -1 lines
Diff to previous 1.32 (colored)

Fix shbang of one script.

Revision 1.32 / (download) - annotate - [select for diffs], Fri Sep 10 03:35:58 2010 UTC (8 years, 8 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2011Q2-base, pkgsrc-2011Q2, pkgsrc-2011Q1-base, pkgsrc-2011Q1, pkgsrc-2010Q4-base, pkgsrc-2010Q4, pkgsrc-2010Q3-base, pkgsrc-2010Q3
Changes since 1.31: +3 -3 lines
Diff to previous 1.31 (colored)

* Remove RUBY_HAS_ARCHLIB.
* Use patches and distinfo from lang/ruby18-base.
* Add support for both ruby18 and ruby19.

Revision 1.31 / (download) - annotate - [select for diffs], Thu Jun 19 14:37:41 2008 UTC (10 years, 11 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2010Q2-base, pkgsrc-2010Q2, pkgsrc-2010Q1-base, pkgsrc-2010Q1, pkgsrc-2009Q4-base, pkgsrc-2009Q4, pkgsrc-2009Q3-base, pkgsrc-2009Q3, pkgsrc-2009Q2-base, pkgsrc-2009Q2, pkgsrc-2009Q1-base, pkgsrc-2009Q1, pkgsrc-2008Q4-base, pkgsrc-2008Q4, pkgsrc-2008Q3-base, pkgsrc-2008Q3, pkgsrc-2008Q2-base, pkgsrc-2008Q2, cwrapper, cube-native-xorg-base, cube-native-xorg
Changes since 1.30: +5 -3 lines
Diff to previous 1.30 (colored)

Update ruby18-tk package to 1.8.7.

Since chanes are too much to write here, please refer

	http://svn.ruby-lang.org/repos/ruby/tags/v1_8_7/NEWS
	http://svn.ruby-lang.org/repos/ruby/tags/v1_8_7/ChangeLog

	http://svn.ruby-lang.org/repos/ruby/tags/v1_8_7_17/NEWS
	http://svn.ruby-lang.org/repos/ruby/tags/v1_8_7_17/ChangeLog

Revision 1.30 / (download) - annotate - [select for diffs], Fri Apr 4 15:31:39 2008 UTC (11 years, 1 month ago) by jlam
Branch: MAIN
Changes since 1.29: +2 -2 lines
Diff to previous 1.29 (colored)

RUBY_REPLACE_DIRS is relative to ${WRKSRC} so no need to give the absolute
path to these directories.

Revision 1.29 / (download) - annotate - [select for diffs], Thu Mar 13 22:07:05 2008 UTC (11 years, 2 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2008Q1-base, pkgsrc-2008Q1
Changes since 1.28: +5 -3 lines
Diff to previous 1.28 (colored)

Support user-destdir installation

Revision 1.28 / (download) - annotate - [select for diffs], Thu Mar 15 16:43:26 2007 UTC (12 years, 2 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2007Q4-base, pkgsrc-2007Q4, pkgsrc-2007Q3-base, pkgsrc-2007Q3, pkgsrc-2007Q2-base, pkgsrc-2007Q2, pkgsrc-2007Q1-base, pkgsrc-2007Q1
Changes since 1.27: +1 -6 lines
Diff to previous 1.27 (colored)

Updating Ruby to 1.8.6; ruby18-tk

- discontinue use of RUBY_PATCH_DATE.
- Introduce RUBY_PATCH_LEVEL.

pkgsrc's ruby tracks Ruby's patch release and avoid to maintain
its own patch files (with RUBY_PATCH_DATE).

Changes are too much, please see ChangeLog file.

Revision 1.26.2.1 / (download) - annotate - [select for diffs], Sat Feb 3 20:22:29 2007 UTC (12 years, 3 months ago) by salo
Branch: pkgsrc-2006Q4
Changes since 1.26: +3 -2 lines
Diff to previous 1.26 (colored) next main 1.27 (colored)

Pullup ticket 2006 - requested by taca
bugfix for ruby-tk

Revisions pulled up:
- pkgsrc/x11/ruby-tk/Makefile				1.27
- pkgsrc/x11/ruby-tk/PLIST				1.8

   Module Name:		pkgsrc
   Committed By:	taca
   Date:		Sun Jan 28 05:17:34 UTC 2007

   Modified Files:
   	pkgsrc/x11/ruby-tk: Makefile PLIST

   Log Message:
   Make sure to build and install tkutil extention library.
   PR pkg/35470 should be fixed.

   Bump PKGREVISION.

Revision 1.27 / (download) - annotate - [select for diffs], Sun Jan 28 05:17:34 2007 UTC (12 years, 3 months ago) by taca
Branch: MAIN
Changes since 1.26: +3 -2 lines
Diff to previous 1.26 (colored)

Make sure to build and install tkutil extention library.
PR pkg/35470 should be fixed.

Bump PKGREVISION.

Revision 1.24.2.1 / (download) - annotate - [select for diffs], Sat Dec 9 10:17:48 2006 UTC (12 years, 5 months ago) by salo
Branch: pkgsrc-2006Q3
Changes since 1.24: +19 -15 lines
Diff to previous 1.24 (colored) next main 1.25 (colored)

Pullup ticket 1943 - requested by taca
security update for ruby18

Revisions pulled up:
- pkgsrc/lang/ruby/Makefile				1.41
- pkgsrc/lang/ruby/rubyversion.mk			1.29, 1.30
- pkgsrc/lang/ruby18-base/Makefile			1.29
- pkgsrc/lang/ruby18-base/PLIST				1.9
- pkgsrc/lang/ruby18-base/PLIST.common_end		1.2
- pkgsrc/lang/ruby18-base/distinfo			1.17
- pkgsrc/lang/ruby18-base/options.mk			1.1
- pkgsrc/lang/ruby18-base/patches/patch-af		1.1
- pkgsrc/lang/ruby18-base/patches/patch-bl		removed
- pkgsrc/lang/ruby18/Makefile				1.15
- pkgsrc/databases/ruby-gdbm/Makefile			1.15
- pkgsrc/databases/ruby-gdbm/distinfo			1.1
- pkgsrc/devel/ruby-curses/Makefile			1.10
- pkgsrc/devel/ruby-curses/distinfo			1.7
- pkgsrc/devel/ruby-mode/Makefile			1.15
- pkgsrc/devel/ruby-mode/distinfo			1.6
- pkgsrc/devel/ruby-readline/Makefile			1.20
- pkgsrc/devel/ruby-readline/distinfo			1.13
- pkgsrc/devel/ruby-readline/patches/patch-aa		1.5
- pkgsrc/x11/ruby-tk/Makefile				1.25, 1.26
- pkgsrc/x11/ruby-tk/PLIST				1.7
- pkgsrc/x11/ruby-tk/distinfo				1.11
- pkgsrc/mk/defaults/options.description		1.130

   Module Name:		pkgsrc
   Committed By:	taca
   Date:		Wed Dec  6 16:25:26 UTC 2006

   Modified Files:
   	pkgsrc/databases/ruby-gdbm: Makefile
   Added Files:
   	pkgsrc/databases/ruby-gdbm: distinfo

   Log Message:
   Update ruby-gdbm package to 1.8.5.20061205:

   - rdoc addition and trivial change.
---
   Module Name:		pkgsrc
   Committed By:	taca
   Date:		Wed Dec  6 16:28:18 UTC 2006

   Modified Files:
   	pkgsrc/devel/ruby-curses: Makefile distinfo

   Log Message:
   Update ruby-curses package to 1.8.5.20061205:

   - Fixed colose_set method always returns false.
---
   Module Name:		pkgsrc
   Committed By:	taca
   Date:		Wed Dec  6 16:36:41 UTC 2006

   Modified Files:
   	pkgsrc/devel/ruby-mode: Makefile
   Added Files:
   	pkgsrc/devel/ruby-mode: distinfo

   Log Message:
   Update ruby-mode package to 1.8.5.20061205.

   Tue Dec  5 00:59:05 2006  Yukihiro Matsumoto  <matz@ruby-lang.org>

   	* misc/ruby-mode.el (ruby-parse-partial): need to parse "/=" as
   	  self assignment operator, not regex.  [ruby-talk:227324]

   Wed Sep 13 18:25:18 2006  Yukihiro Matsumoto  <matz@ruby-lang.org>

   	* misc/ruby-mode.el (ruby-parse-partial): better here-doc support.
   	  a patch from Marshall T. Vandegrift <llasram at gmail.com>.
   	  [ruby-core:08804]
---
   Module Name:		pkgsrc
   Committed By:	taca
   Date:		Wed Dec  6 16:31:34 UTC 2006

   Modified Files:
   	pkgsrc/devel/ruby-readline: Makefile distinfo
   	pkgsrc/devel/ruby-readline/patches: patch-aa

   Log Message:
   Update ruby-readline package to 1.8.5.20061205:

   - No change with 20061205 patch.
   - Disable checking rl_filename_completion_function() to prevent compile
     error.
---
   Module Name:		pkgsrc
   Committed By:	taca
   Date:		Wed Dec  6 16:34:42 UTC 2006

   Modified Files:
   	pkgsrc/lang/ruby: Makefile

   Log Message:
   Update ruby package to 1.8.5.20061205.  No change for this wrapper package.
---
   Module Name:		pkgsrc
   Committed By:	taca
   Date:		Wed Dec  6 16:17:17 UTC 2006

   Modified Files:
   	pkgsrc/lang/ruby: rubyversion.mk

   Log Message:
   - Handle patchlevel which has introduced to Ruby.
   - Introduce RUBY_PATCH_DATE and RUBY_VERSION_SUFFIX.
   - Change _RUBY_VERS_TEENY to _RUBY_VER_TEENY as other version variable
     like RUBY_VER_MAJOR.
---
   Module Name:		pkgsrc
   Committed By:	taca
   Date:		Wed Dec  6 16:19:50 UTC 2006

   Modified Files:
   	pkgsrc/lang/ruby: rubyversion.mk

   Log Message:
   Update RUBY18_PATCH_DATE to 20061205, starting update of Ruby.
---
   Module Name:		pkgsrc
   Committed By:	taca
   Date:		Wed Dec  6 16:34:09 UTC 2006

   Modified Files:
   	pkgsrc/lang/ruby18: Makefile

   Log Message:
   Update ruby18 package to 1.8.5.20061205.  No change for this meta pacakge
   itself.
---
   Module Name:		pkgsrc
   Committed By:	taca
   Date:		Wed Dec  6 16:24:27 UTC 2006

   Modified Files:
   	pkgsrc/lang/ruby18-base: Makefile PLIST PLIST.common_end distinfo
   Added Files:
   	pkgsrc/lang/ruby18-base: options.mk
   	pkgsrc/lang/ruby18-base/patches: patch-af
   Removed Files:
   	pkgsrc/lang/ruby18-base/patches: patch-bl

   Log Message:
   o Update ruby18-base pacakge to Ruby 1.8 branch 2006/12/05.

   	- Many changes from 2006/9/6; see Changes file, please.
   	- Fixes another cgi.rb vulnerability:
   		http://jvn.jp/jp/JVN%2384798830/index.html

   o Introduce ruby-build-ri-db PKG_OPTION which enable installing database
     for Ruby's ri utility.  Default is disabled and should be fix
     PR pkg/34587.
---
   Module Name:		pkgsrc
   Committed By:	taca
   Date:		Wed Dec  6 17:00:54 UTC 2006

   Modified Files:
   	pkgsrc/mk/defaults: options.description

   Log Message:
   Add description of ruby-build-ri-db.
---
   Module Name:		pkgsrc
   Committed By:	tv
   Date:		Fri Nov 10 16:54:54 UTC 2006

   Modified Files:
   	pkgsrc/x11/ruby-tk: Makefile

   Log Message:
   Use find -print | xargs rather than find -exec.
---
   Module Name:		pkgsrc
   Committed By:	taca
   Date:		Wed Dec  6 16:33:16 UTC 2006

   Modified Files:
   	pkgsrc/x11/ruby-tk: Makefile PLIST distinfo

   Log Message:
   Update ruby-tk package to 1.8.5.20061205:

   Changes are huge, please see Changes.

   - pkgsrc change; fix permission of a image file.

Revision 1.26 / (download) - annotate - [select for diffs], Wed Dec 6 16:33:16 2006 UTC (12 years, 5 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2006Q4-base
Branch point for: pkgsrc-2006Q4
Changes since 1.25: +19 -14 lines
Diff to previous 1.25 (colored)

Update ruby-tk package to 1.8.5.20061205:

Changes are huge, please see Changes.

- pkgsrc change; fix permission of a image file.

Revision 1.25 / (download) - annotate - [select for diffs], Fri Nov 10 16:54:54 2006 UTC (12 years, 6 months ago) by tv
Branch: MAIN
Changes since 1.24: +2 -3 lines
Diff to previous 1.24 (colored)

Use find -print | xargs rather than find -exec.

Revision 1.24 / (download) - annotate - [select for diffs], Thu Sep 7 15:43:20 2006 UTC (12 years, 8 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2006Q3-base
Branch point for: pkgsrc-2006Q3
Changes since 1.23: +6 -2 lines
Diff to previous 1.23 (colored)

Update Ruby to 1.8.5 (+ ruby-1-8 branch on 2006-09-07).

pkgsrc changes:

* Add RUBY_DYNAMIC_DIRS which cause generating dynamic PLIST entries.
* Move using buildlinks to rubyversion.mk.
* Merge converters/ruby-iconv to ruby18-base.

Ruby changes:

* too may, see ChangeLog file or
  http://eigenclass.org/hiki.rb?ruby+1.8.5+changelog

This is ruby-tk part.

Revision 1.22.2.1 / (download) - annotate - [select for diffs], Wed Jun 7 22:44:08 2006 UTC (12 years, 11 months ago) by salo
Branch: pkgsrc-2006Q1
Changes since 1.22: +3 -2 lines
Diff to previous 1.22 (colored) next main 1.23 (colored)

Pullup ticket 1679 - requested by taca
runtime fix for ruby-tk

Revisions pulled up:
- pkgsrc/x11/ruby-tk/Makefile		1.23

   Module Name:		pkgsrc
   Committed By:	taca
   Date:		Wed May 31 04:08:27 UTC 2006

   Modified Files:
   	pkgsrc/x11/ruby-tk: Makefile

   Log Message:
   Specify X11BASE as configuration parameter.  This change should fix
   the problem which cause LoadError of libX11.so.6.  This problem was
   noted by rudolf <netbsd at eq.cz> on pkgsrc-users.

   Bump PKGREVISION.

Revision 1.23 / (download) - annotate - [select for diffs], Wed May 31 04:08:27 2006 UTC (12 years, 11 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2006Q2-base, pkgsrc-2006Q2
Changes since 1.22: +3 -2 lines
Diff to previous 1.22 (colored)

Specify X11BASE as configuration parameter.  This change should fix
the problem which cause LoadError of libX11.so.6.  This problem was
noted by rudolf <netbsd at eq.cz> on pkgsrc-users.

Bump PKGREVISION.

Revision 1.22 / (download) - annotate - [select for diffs], Sun Feb 5 23:11:43 2006 UTC (13 years, 3 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2006Q1-base
Branch point for: pkgsrc-2006Q1
Changes since 1.21: +2 -1 lines
Diff to previous 1.21 (colored)

Recursive revision bump / recommended bump for gettext ABI change.

Revision 1.21 / (download) - annotate - [select for diffs], Tue Jan 3 14:41:21 2006 UTC (13 years, 4 months ago) by taca
Branch: MAIN
Changes since 1.20: +2 -4 lines
Diff to previous 1.20 (colored)

Update ruby-tk pacakge to 1.8.4.

x11/ruby-tcltk package was merged to this pacakge now.

Revision 1.20 / (download) - annotate - [select for diffs], Thu Nov 3 07:22:58 2005 UTC (13 years, 6 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2005Q4-base, pkgsrc-2005Q4
Changes since 1.19: +1 -2 lines
Diff to previous 1.19 (colored)

Remove specifying RUBY_VERSION_SUPPORTED.

Revision 1.19 / (download) - annotate - [select for diffs], Wed Nov 2 08:59:42 2005 UTC (13 years, 6 months ago) by taca
Branch: MAIN
Changes since 1.18: +1 -2 lines
Diff to previous 1.18 (colored)

- Reset PKGREVISION by updating Ruby 1.8.3.
- Add one fix from ruby_1_8 branch.

Revision 1.18 / (download) - annotate - [select for diffs], Wed Jun 1 18:03:31 2005 UTC (13 years, 11 months ago) by jlam
Branch: MAIN
CVS Tags: pkgsrc-2005Q3-base, pkgsrc-2005Q3, pkgsrc-2005Q2-base, pkgsrc-2005Q2
Changes since 1.17: +1 -2 lines
Diff to previous 1.17 (colored)

Massive cleanup of buildlink3.mk and builtin.mk files in pkgsrc.
Several changes are involved since they are all interrelated.  These
changes affect about 1000 files.

The first major change is rewriting bsd.builtin.mk as well as all of
the builtin.mk files to follow the new example in bsd.builtin.mk.
The loop to include all of the builtin.mk files needed by the package
is moved from bsd.builtin.mk and into bsd.buildlink3.mk.  bsd.builtin.mk
is now included by each of the individual builtin.mk files and provides
some common logic for all of the builtin.mk files.  Currently, this
includes the computation for whether the native or pkgsrc version of
the package is preferred.  This causes USE_BUILTIN.* to be correctly
set when one builtin.mk file includes another.

The second major change is teach the builtin.mk files to consider
files under ${LOCALBASE} to be from pkgsrc-controlled packages.  Most
of the builtin.mk files test for the presence of built-in software by
checking for the existence of certain files, e.g. <pthread.h>, and we
now assume that if that file is under ${LOCALBASE}, then it must be
from pkgsrc.  This modification is a nod toward LOCALBASE=/usr.  The
exceptions to this new check are the X11 distribution packages, which
are handled specially as noted below.

The third major change is providing builtin.mk and version.mk files
for each of the X11 distribution packages in pkgsrc.  The builtin.mk
file can detect whether the native X11 distribution is the same as
the one provided by pkgsrc, and the version.mk file computes the
version of the X11 distribution package, whether it's built-in or not.

The fourth major change is that the buildlink3.mk files for X11 packages
that install parts which are part of X11 distribution packages, e.g.
Xpm, Xcursor, etc., now use imake to query the X11 distribution for
whether the software is already provided by the X11 distribution.
This is more accurate than grepping for a symbol name in the imake
config files.  Using imake required sprinkling various builtin-imake.mk
helper files into pkgsrc directories.  These files are used as input
to imake since imake can't use stdin for that purpose.

The fifth major change is in how packages note that they use X11.
Instead of setting USE_X11, package Makefiles should now include
x11.buildlink3.mk instead.  This causes the X11 package buildlink3
and builtin logic to be executed at the correct place for buildlink3.mk
and builtin.mk files that previously set USE_X11, and fixes packages
that relied on buildlink3.mk files to implicitly note that X11 is
needed.  Package buildlink3.mk should also include x11.buildlink3.mk
when linking against the package libraries requires also linking
against the X11 libraries.  Where it was obvious, redundant inclusions
of x11.buildlink3.mk have been removed.

Revision 1.17 / (download) - annotate - [select for diffs], Mon Apr 11 21:48:13 2005 UTC (14 years, 1 month ago) by tv
Branch: MAIN
Changes since 1.16: +1 -2 lines
Diff to previous 1.16 (colored)

Remove USE_BUILDLINK3 and NO_BUILDLINK; these are no longer used.

Revision 1.16 / (download) - annotate - [select for diffs], Thu Mar 24 21:13:03 2005 UTC (14 years, 2 months ago) by wiz
Branch: MAIN
Changes since 1.15: +1 -2 lines
Diff to previous 1.15 (colored)

Remove FreeBSD RCS Ids. pkgsrc has diverged too much for syncing to be
useful.

Revision 1.15 / (download) - annotate - [select for diffs], Sun Mar 6 17:19:08 2005 UTC (14 years, 2 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2005Q1-base, pkgsrc-2005Q1
Changes since 1.14: +2 -1 lines
Diff to previous 1.14 (colored)

Bump PKGREVISION with introduce of ruby16-base/ruby18-base pacakge.

Revision 1.14 / (download) - annotate - [select for diffs], Sun Mar 6 13:13:21 2005 UTC (14 years, 2 months ago) by taca
Branch: MAIN
Changes since 1.13: +2 -2 lines
Diff to previous 1.13 (colored)

Cosmetic change with pkglint(1).

Revision 1.13 / (download) - annotate - [select for diffs], Wed Jan 26 16:03:49 2005 UTC (14 years, 4 months ago) by taca
Branch: MAIN
Changes since 1.12: +3 -3 lines
Diff to previous 1.12 (colored)

Make sure to change current directory to ${WRKSRC} before removing
extra files by find(1).

Revision 1.12 / (download) - annotate - [select for diffs], Sun Jan 23 17:37:48 2005 UTC (14 years, 4 months ago) by taca
Branch: MAIN
Changes since 1.11: +3 -2 lines
Diff to previous 1.11 (colored)

Update to Ruby 1.8.2 base and thses changes:

	* ext/tk/lib/multi-tk.rb: ditto

	* some fixes to run examples (not yet complete).

Revision 1.11 / (download) - annotate - [select for diffs], Sun Nov 28 06:32:53 2004 UTC (14 years, 5 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2004Q4-base, pkgsrc-2004Q4
Changes since 1.10: +2 -2 lines
Diff to previous 1.10 (colored)

Fix a mistake of REPLACE_RUBY_DIRS usage.

Revision 1.10 / (download) - annotate - [select for diffs], Sat Nov 27 14:50:45 2004 UTC (14 years, 6 months ago) by taca
Branch: MAIN
Changes since 1.9: +18 -12 lines
Diff to previous 1.9 (colored)

Update ruby-tk pacakge to 1.8.1 with new framework for Ruby packages.

Revision 1.9 / (download) - annotate - [select for diffs], Wed Mar 17 04:13:46 2004 UTC (15 years, 2 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2004Q3-base, pkgsrc-2004Q3, pkgsrc-2004Q2-base, pkgsrc-2004Q2, pkgsrc-2004Q1-base, pkgsrc-2004Q1
Changes since 1.8: +1 -8 lines
Diff to previous 1.8 (colored)

Remove CONFIGURE_ARGS here since it had no effect and specified
incorrect parameter.

Revision 1.8 / (download) - annotate - [select for diffs], Tue Mar 16 02:01:12 2004 UTC (15 years, 2 months ago) by taca
Branch: MAIN
Changes since 1.7: +2 -2 lines
Diff to previous 1.7 (colored)

Add ruby to CATEGORIES.

Revision 1.7 / (download) - annotate - [select for diffs], Fri Mar 12 05:02:55 2004 UTC (15 years, 2 months ago) by taca
Branch: MAIN
Changes since 1.6: +2 -2 lines
Diff to previous 1.6 (colored)

Bump pacakge revision with ruby-base package's update.

Revision 1.6 / (download) - annotate - [select for diffs], Tue Jan 20 12:28:27 2004 UTC (15 years, 4 months ago) by agc
Branch: MAIN
Changes since 1.5: +2 -2 lines
Diff to previous 1.5 (colored)

Move WRKSRC definition away from the first paragraph in a Makefile.

Revision 1.5 / (download) - annotate - [select for diffs], Fri Dec 19 12:04:20 2003 UTC (15 years, 5 months ago) by sketch
Branch: MAIN
Changes since 1.4: +2 -1 lines
Diff to previous 1.4 (colored)

Bump PKGREVISION for packages which install files into RUBY_ARCHLIBDIR,
which has changed for Solaris installs.

Revision 1.4 / (download) - annotate - [select for diffs], Thu Jul 17 22:56:45 2003 UTC (15 years, 10 months ago) by grant
Branch: MAIN
CVS Tags: pkgsrc-2003Q4-base, pkgsrc-2003Q4
Changes since 1.3: +2 -2 lines
Diff to previous 1.3 (colored)

s/netbsd.org/NetBSD.org/

Revision 1.3 / (download) - annotate - [select for diffs], Sat Mar 29 12:43:09 2003 UTC (16 years, 2 months ago) by jmmv
Branch: MAIN
Changes since 1.2: +2 -2 lines
Diff to previous 1.2 (colored)

Place WRKSRC where it belongs, to make pkglint happy; ok'ed by wiz.

Revision 1.2 / (download) - annotate - [select for diffs], Sun Dec 30 16:25:34 2001 UTC (17 years, 4 months ago) by taca
Branch: MAIN
CVS Tags: pkgviews-base, pkgviews, netbsd-1-6-RELEASE-base, netbsd-1-6-1-base, netbsd-1-6-1, netbsd-1-6, netbsd-1-5-PATCH003, buildlink2-base, buildlink2
Changes since 1.1: +7 -2 lines
Diff to previous 1.1 (colored)

update ruby-tk pakcage to ruby 1.6.6 based.

Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Sat Jun 30 08:20:26 2001 UTC (17 years, 10 months ago) by taca
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0 lines
Diff to previous 1.1 (colored)

Importing Ruby interface to the Tk widget set.

	This will be part of ruby meta-package.

Moved ruby-Tk to ruby-Tk-mixedcase in the repository [schmonz 2007-06-07]

Revision 1.1 / (download) - annotate - [select for diffs], Sat Jun 30 08:20:26 2001 UTC (17 years, 10 months ago) by taca
Branch: MAIN

Initial revision

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>