[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / ruby-gnome2-gtksourceview2

File: [cvs.NetBSD.org] / pkgsrc / x11 / ruby-gnome2-gtksourceview2 / Attic / Makefile (download)

Revision 1.7, Sat Oct 23 12:45:14 2010 UTC (13 years, 5 months ago) by obache
Branch: MAIN
Changes since 1.6: +3 -1 lines

Update ruby-gnome2 to 0.90.3.

= NEWS

== Ruby-GNOME2 0.90.3: 2010-10-23

NOTE: 0.90.x releases are for 1.0.0 major release.

  * Support String encoding in Ruby 1.9.
  * RVAL2CSTR2 and CSTR2RVAL2 are deprecated.
  * Ruby/GIO2 is imported as an experimental library.

=== Changes

==== All

  * Support String encoding.
    [Guillaume Cottenceau, Neil Roberts, Kouhei Sutou]
  * Don't install *.pc by default. Set pkgconfigdir make
    varialbe like 'make pkgconfigdir=/usr/lib/pkgconfig'.

==== Ruby/GLib2

  * Improvements:
    * declare argument types.
      [Nobuyoshi Nakada, Kouhei Sutou]

==== Ruby/GIO2

  * Imported as an experimental library.
    [Nikolai Weibull]

==== Ruby/GTK2

  * Improvements:
    * keep backward compatibility around GDK key
      symbols introduced at GTK+ 2.20.
      "[ruby-gnome2-devel-en] Constants names change in Gdk::KeyVal"
      [Vincent Carmona]
    * move gdk-pixbuf and cairo related methods from Ruby/GdkPixbuf2.
      "[ruby-gnome2-devel-en] gtk2 dependency to gdkpixbuf2"
      [Andrea Dallera, Kouhei Sutou]
  * Bug fixes:
    * fix GType conversion in Gtk::ItemFactory.new on 64bit
      platform.
      [Grant McLean, Steve Wills, Kouhei Sutou]

==== Ruby/GdkPixbuf2

  * Improvements:
    * move gdk-pixbuf and cairo related methods to Ruby/GTK2.
      "[ruby-gnome2-devel-en] gtk2 dependency to gdkpixbuf2"
      [Andrea Dallera, Kouhei Sutou]
    * change .pc filename from ruby-gdkpixbuf2 to
      ruby-gdk-pixbuf2.

==== Ruby/RSVG2

  * Bug fixes:
    * add missing libcroco dependency on Windows.
      [U.Nakamura, Kouhei Sutou]

==== Ruby/Poppler

  * Improvements:
    * support Popper 0.15.0. [#3079667]
      [Mamoru Tasaka, Kouhei Sutou]

  * Bug fixes:
    * add missing libjpeg dependency on Windows.
      [U.Nakamura, Kouhei Sutou]
    * fix installed Ruby/GLib2 gem can't be detected.
      [kdmsnr, Kouhei Sutou]

=== Thanks

  * U.Nakamura
  * kdmsnr
  * Mamoru Tasaka
  * Guillaume Cottenceau
  * Vincent Carmona
  * Grant McLean
  * Steve Wills
  * Andrea Dallera
  * Nobuyoshi Nakada
  * Neil Roberts

== Ruby-GNOME2 0.90.2: 2010-09-26

NOTE: 0.90.x releases are for 1.0.0 major release.

A RubyGems package fix release.

=== Changes

==== All

  * fix path.
    [kimura wataru, Kouhei Sutou]

==== Ruby/GTK2

  * Bug fixes:
    * fix gtk2/base.rb is missing in gem.
      [S.Kitagawa, Kouhei Sutou]

==== Ruby/GIO2

  * Bug fixes:
    * fix a typo in .pc name. [#3075619]
      [O01eg, Kouhei Sutou]

==== Ruby/RSVG2

  * Bug fixes:
    * also check rb_cairo.h availability. [#3075617]
      [O01eg, Kouhei Sutou]

=== Thanks

  * S.Kitagawa
  * O01eg
  * kimura wataru

# $NetBSD: Makefile,v 1.7 2010/10/23 12:45:14 obache Exp $
#

PKGNAME=		${RUBY_PKGPREFIX}-gnome2-gtksourceview2-${VERSION}
COMMENT=		Ruby binding of gtksourceview2
CATEGORIES=		x11

CONFLICTS+=		ruby[0-9][0-9]-gnome2-gtksourceview2-[0-9]*

PKG_DESTDIR_SUPPORT=	user-destdir

RUBY_EXTCONF_SUBDIRS=	gtksourceview2

DEPENDS+=		${RUBY_PKGPREFIX}-gnome2-gtk>=${VERSION}:../../x11/ruby-gnome2-gtk

do-test:
	${RUN} cd ${WRKSRC}/gtk/test; ${SETENV} ${TEST_ENV} ${RUBY} run-test.rb

.include "../../x11/gtksourceview2/buildlink3.mk"
.include "../../devel/ruby-pkg-config/tool.mk"
.include "../../meta-pkgs/ruby-gnome2/Makefile.common"