[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / ruby-gnome2-gtk

File: [cvs.NetBSD.org] / pkgsrc / x11 / ruby-gnome2-gtk / Attic / Makefile (download)

Revision 1.57, Sat Apr 16 17:41:05 2016 UTC (8 years ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2016Q2-base, pkgsrc-2016Q2
Changes since 1.56: +1 -2 lines

Update ruby-gnome2 packages to 3.0.8.

Upstream changes:
(from https://github.com/ruby-gnome2/ruby-gnome2/blob/3.0.8/NEWS)

= Ruby-GNOME2 3.0.8: 2016-04-03

It's a release that improves GTK+ 3 support.

=== Changes

==== All

  * Droped Ruby 2.0.0 support.
  * Travis: use Trusty beta image.
    [Patch by Hiroshi Hatake]
  * Added AltLinux to supported OSes.
    [Patch by Malo Skrylevo]

==== Ruby/GLib2

  * Improvements
    * Added (({RVAL2CSTR_PTR_ACCEPT_NIL})).
    * Added (({RVAL2CSTR_RAW})).
    * Added (({RVAL2CSTR_RAW_ACCEPT_NIL})).
    * Supported (({GLib::Variant.new(value, type)})).
    * Added (({GLib::Regex})) class.
      [Patch by cedlemo]
    * Supported more variant types in (({rbg_variant_to_ruby})).
     [Patch by Aurelien Jacobs]
    * Supported array in (({rg_ruby_to_variant})).
      [Patch by Aurelien Jacobs]
    * Added (({GLib::Regex#split})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#match})).
      [Patch by cedlemo]
    * Added (({GLib::MatchInfo})) class.
      [Patch by cedlemo]
    * Added (({GLib::Regex#max_backref})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#capture_count})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#has_cr_or_lf?})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#max_lookbehind})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#string_number})).
      [Patch by cedlemo]
    * Added (({GLib::Regex.escape_string})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#match?})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#match_all})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#split})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#replace})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#check_replacement})).
      [Patch by cedlemo]
    * Added (({GLib::Regex#replace_eval})).
      [Patch by cedlemo]
    * Added (({GLib::MatchInfo#partial_match})).
      [Patch by cedlemo]
    * Added (({GLib::MatchInfo#fetch})).
      [Patch by cedlemo]
    * Added (({GLib::MatchInfo#[]})).
    * Added (({GLib::MatchInfo#fetch_pos})).
      [Patch by cedlemo]
    * Added (({GLib::MatchInfo#fetch_position})).
    * Added (({GLib::MatchInfo#fetch_all})).
      [Patch by cedlemo]
    * Added (({GLib::MatchInfo#next})).
      [Patch by cedlemo]

  * Fixes
    * Fixed a bug that raw string is converted to UTF-8.
    * Fixed handling of 64 bits (({FIXNUM})) variant initialization.

==== Ruby/GObjectIntrospection

  * Improvements
    * Supported allocated output parameter.
    * Supported dynamic callback.
    * Supported enum as output value.
    * Added function type name in error message.
    * Added (({RB_ZALLOC})).
    * Supported freeing GType-ed union.
      [GitHub#700][Reported by cedlemo]
    * Added (({GI::Repository#get_version})).
  * Fixes
    * Fixed a bug that block is always ignored in singleton method.
      [ruby-gnome2-devel-ja][Reported by Yuuki Harano]

==== Ruby/GIO2

  * Improvements
    * Supported (({Gio::Application.new(:arguments => [...]})).
      [GitHub#519][Reported by Mamoru TASAKA]
    * Started to use dynamic callback.

==== Ruby/GTK3

  * Improvements
    * Supported (({Gtk::Clipboard#request_text})).
      [ruby-gnome2-devel-en][Reported by Detlef Reichl]
    * Supported (({Gtk::Clipboard#request_contents})).
    * Supported (({Gtk::Clipboard#request_image})).
    * Supported (({Gtk::Clipboard#request_targets})).
    * Supported (({Gtk::Clipboard#request_rich_text})).
    * Supported (({Gtk::Clipboard#request_uris})).
    * Updated main demo application.
      [Patch by cedlemo]
    * Updated and finished sample tutorial.
      [Patch by cedlemo]
    * Supported (({Gtk::TreeModel#set_sort_func})).
      [GitHub#596][Reported by Christopher L. Ramsey]
    * Supported (({Gtk::Box#set_child_packing})).
      [GitHub#602][Reported by Ibrahim Tencer]
    * Updated stack demo.
      [Patch by cedlemo]
    * Added scale demo.
      [Patch by cedlemo]
    * Updated theming style classes demo.
      [Patch by cedlemo]
    * Created entry buffer demo.
      [Patch by cedlemo]
    * Made (({Gtk::EntryBuffer#new more rubyish})).
      [Patch by cedlemo]
    * Added markup demo.
      [Patch by cedlemo]
    * Added headerbar demo.
      [Patch by cedlemo]
    * Updated css accordion demo.
      [Patch by cedlemo]
    * Added pickers demo.
      [Patch by cedlemo]
    * Updated links demo.
      [Patch by cedlemo]
    * Added overlay demo.
      [Patch by cedlemo]
    * Added textmask demo.
      [Patch by cedlemo]
    * Added sidebar demo.
      [Patch by cedlemo]
    * Updated spinner demo.
      [Patch by cedlemo]
    * Updated entry completion demo.
      [Patch by cedlemo]
    * Added revealer demo.
      [Patch by cedlemo]
    * Updated expander demo.
      [Patch by cedlemo]
    * Added overlay2 demo.
      [Patch by cedlemo]
    * Updated colorsel demo.
      [Patch by cedlemo]
    * (({rbgobj_gc_mark_instance})) has to be called
      for the (({Gtk::TreeSelection})).
      [Patch by Hiroyuki Ito]
    * Updated css basics demo.
      [Patch by cedlemo]
    * Made (({Gtk::TreeModel#iter_nth_child})) and
      (({Gtk::TreeModel#iter_children})) work like
      (({#get_value})).
    * Added methods to Gtk::TreeIter:
        * (({Gtk::TreeIter#previous!}))
        * (({Gtk::TreeIter#has_child?}))
        * (({Gtk::TreeIter#n_children}))
        * (({Gtk::TreeIter#nth_child}))
        * (({Gtk::TreeIter#children})).
      [Patch by Hiroyuki Ito]
    * Added support for (({Gtk::TreeSelection})).
      [Patch by dutchhome]
    * Updated builder demo.
      [Patch by cedlemo]
    * Updated css pixbufs demo.
      [Patch by cedlemo]
    * Updated button box demo.
      [Patch by cedlemo]
    * Created css shadows demo.
      [Patch by cedlemo]
    * Updated infobar demo.
      [Patch by cedlemo]
    * Added support for MenuPositionFunc in
      (({Gtk::Menu#popup})).
      [GitHub#61][Reported by Abby Archer]
    * Made (({Gtk::Widget#translate_coordinates})) more
      rubyish.
      [Patch by cedlemo]
    * Added support for (({EntryCompletionMatchFunc})).
      [Patch by Hiroyuki Ito]
    * Updated iconview edit demo.
      [Patch by cedlemo]
    * Updated sizegroup demo.
      [Patch by cedlemo]
    * Updated cursors demo.
      [Patch by cedlemo]
    * Made (({Gtk::MenuItem#new})) like
      (({Gtk::CheckMenuItem#new})).
      [Patch by Hiroyuki Ito]
    * Move the (({#set_values})) implementation to
      (({Gtk::TreeModel})) instead of (({Gtk::ListStore})).
      [GitHub#659][Reported by detlef]
    * Updated search entry2 demo.
      [Patch by cedlemo]
    * Updated menus demo.
      [Patch by cedlemo]
    * Updated css multiplebgs demo.
      [Patch by cedlemo]
    * Added auto generated callback for AssistantPageFunc.
    * Added auto generated callback for BuilderConnectFunc.
    * Updated model button demo.
      [Patch by cedlemo]
    * Updated dialog demo.
      [Patch by cedlemo]
    * Added another example sample for (({Gtk::TreeStore})).
      [Patch by cedlemo]
    * Added the methods:
        * (({Gtk::TreePath#next!}))
        * (({Gtk::TreePath#prev!}))
        * (({Gtk::TreePath#up!}))
        * (({Gtk::TreePath#down!})).
      [Patch by cedlemo]
    * Added (({Gtk::TreeIter#first_child})).
      [Patch by cedlemo]
    * Updated filtermodel demo.
      [Patch by cedlemo]
    * Updated popover demo.
      [Patch by cedlemo]
    * Supported (({Gtk::Builder#connect_signals})).
    * Added new sample icons-theme-viewer.rb.
      [Patch by cedlemo]
    * Added new sample menus_from_resources.rb.
      [Patch by cedlemo]
    * Updated printing demo.
      [Patch by cedlemo]
    * Updated assistant demo.
      [Patch by cedlemo]
    * Updated panes demo.
      [Patch by cedlemo]
    * Updated font features demo.
      [Patch by cedlemo]

  * Fixes:
    * Fixed a bug that (({Gtk::Widget.set_connect_func})) doesn't work.
      [GitHub#703][Reported by cedlemo]

==== Ruby/Poppler

  * Improvements:
    * Removed needless (({POPPLER_TYPE_ORIENTATION})) binding.
      [GiHub#653][Reported by Rob Brackett]

==== Ruby/WebKit2GTK

  * Improvements:
    * Supported old WebKit2GTK+.

=== Thanks

  * Detlef Reichl
  * Mamoru TASAKA
  * cedlemo
  * Christopher L. Ramsey
  * Hiroyuki Ito
  * dutchhome Jon Raiford
  * Rob Brackett
  * Abby Archer
  * Yuuki Harano
  * detlef
  * Aurelien Jacobs
  * Hiroshi Hatake
  * Malo Skrylevo

# $NetBSD: Makefile,v 1.57 2016/04/16 17:41:05 tsutsui Exp $
#

DISTNAME=		gtk2-${VERSION}
PKGNAME=		${RUBY_PKGPREFIX}-gnome2-gtk-${VERSION}
COMMENT=		Ruby binding of GTK+-2.x
CATEGORIES=		x11

CONFLICTS+=		ruby-gnome2-gtk-[0-9]*
CONFLICTS+=		ruby[0-9][0-9]-gnome2-gtk-[0-9]*

DEPENDS+=		${RUBY_PKGPREFIX}-gnome2-atk>=${VERSION}:../../devel/ruby-gnome2-atk
DEPENDS+=		${RUBY_PKGPREFIX}-gnome2-pango>=${VERSION}:../../devel/ruby-gnome2-pango
DEPENDS+=		${RUBY_PKGPREFIX}-gnome2-gdkpixbuf>=${VERSION}:../../graphics/ruby-gnome2-gdkpixbuf

.include "../../devel/ruby-gnome2-pango/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../meta-pkgs/ruby-gnome2/Makefile.common"
.include "../../lang/ruby/gem.mk"
.include "../../mk/bsd.pkg.mk"