Up to [cvs.NetBSD.org] / pkgsrc / x11 / ruby-gnome2-gtk
Request diff between arbitrary revisions
Default branch: MAIN
Revision 1.14, Sat Sep 14 18:11:36 2019 UTC (4 years, 2 months ago) by tsutsui
Branch: MAIN
CVS Tags: HEAD
Changes since 1.13: +1 -1
lines
FILE REMOVED
ruby-gnome: Update to 3.3.8, and rename package names to match gems. Also reorganize several dependencies in Makefile and buildlink3.mk. See the following post for details: https://mail-index.netbsd.org/pkgsrc-users/2019/09/07/msg029327.html https://mail-index.netbsd.org/pkgsrc-users/2019/09/13/msg029356.html Upstream changes (from NEWS): == Ruby-GNOME 3.3.8: 2019-09-10 This is a partially GLib 2.62.0 support release. === Changes ==== All * Improvements * Changed our project name to Ruby-GNOME from Ruby-GNOME2. [GitHub#1277][Suggested by kojix2] [GitHub#1291][Patch by kojix2] * Stopped to release (({.tar.gz})) because they are no longer used. ==== Ruby/GLib2 * Improvements * (({GLib.convert})): Changed to set correct encoding. * (({GLib::FILENAME_ENCODING})): Added. * Changed to use the same enum object for the same enum value. * (({GLib::Enum.find})): Added. * (({GLib::Bytes#initialize})): Changed to reuse (({String})) data even if the given (({String})) isn't frozen. * (({GLib::Bytes.try_convert})): Added. * (({GLib::Enum.try_convert})): Added. * (({GLib::Flags.try_convert})): Added. * (({GLib::Type.try_convert})): Added. * (({GLib::MkEnums.create})): Added support for flags to enum definition. [GitHub#1295][Patch by Mamoru TASAKA] ==== Ruby/GIO2 * Fixes * Renamed to (({Gio::Icon#hash})) from (({Gio::Icon.hash})). [GitHub#1293][Reported by Erik Czumadewski] ==== Ruby/GObjectIntrospection * Improvements * Introduced (({try_convert})) protocol. ==== Ruby/CairoGObject * Improvements * (({Cairo::Context.try_convert})): Added. * (({Cairo::Device.try_convert})): Added. * (({Cairo::Pattern.try_convert})): Added. * (({Cairo::Surface.try_convert})): Added. * (({Cairo::ScaledFont.try_convert})): Added. * (({Cairo::FontFace.try_convert})): Added. * (({Cairo::FontOptions.try_convert})): Added. * (({Cairo::Region.try_convert})): Added. === Thanks * kojix2 * Erik Czumadewski * Mamoru TASAKA
Revision 1.13 / (download) - annotate - [select for diffs], Sat Jun 9 03:36:09 2018 UTC (5 years, 5 months ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2019Q2-base,
pkgsrc-2019Q2,
pkgsrc-2019Q1-base,
pkgsrc-2019Q1,
pkgsrc-2018Q4-base,
pkgsrc-2018Q4,
pkgsrc-2018Q3-base,
pkgsrc-2018Q3,
pkgsrc-2018Q2-base,
pkgsrc-2018Q2
Changes since 1.12: +4 -2
lines
Diff to previous 1.12 (colored)
ruby-gnome2: update to 3.2.7. pkgsrc changes: * remove a fix for glib2 pulled from upstream * remove a gobject-introspection patch for netbsd-6 (seems fixed in upstream) Upstream changes (from NEWS): == Ruby-GNOME2 3.2.7: 2018-06-07 This is a packaging bug fix release of 3.2.6. === Changes ==== All * Improvements * Added support for using unreleased version with Bundler. [Patch by cedlemo] * Fixes * Fixed a packaging bug that dependencies are missing. == Ruby-GNOME2 3.2.6: 2018-06-06 This is a bug fix release of 3.2.5. === Changes ==== Document * Improvements * Updated project URL. [GitHub#1174][Patch by okkez] ==== All * Improvements * Added support for using unreleased version with Bundler. [Patch by cedlemo] * Windows: Upgraded bundled library versions. ==== Ruby/GLib2 * Improvements * (({GLib::Object.define_signal})): Added. (({GLib::Object.signal_new})) is deprecated. * (({GLib::Object.signal_new})): Changed to accept (({Symbol})) as flags. * (({GLib::Signal})): Migrated to (({TypedData})). * (({GLib::Enum})): Migrated to (({TypedData})). * (({GLib::Flags})): Migrated to (({TypedData})). * (({GLib::Boxed})): Migrated to (({TypedData})). * (({GLib::Param})): Migrated to (({TypedData})). * (({rbgobj_signal_new()})): Added. (({rbgobj_signal_wrap()})) is deprecated. * Dropped GLib < 2.28 support. * (({GLib::Variant.new})): Changed to accept (({String})) as variant type. * (({rbg_variant_type_from_ruby()})): Added. * (({rbg_gc_guard()})): Added. * (({rbg_gc_unguard()})): Added. * Fixes * Fixed a bug that signal created by (({GLib::Object.signal_new})) may be GC-ed. [GitHub#1166][Reported by Izumi Tsutsui] ==== Ruby/GObjectIntrospection * Improvements * (({GObjectIntrospection::Struct})): Migrated to (({TypedData})). * Improved better function detection. * Added heuristic callback data detection. * Added support for getting flags field value. * (({RBGICallbackData})): Hidden details. * (({rb_gi_callback_data_get_metadata()})): Added. * (({rb_gi_callback_data_get_rb_callback()})): Added. * Added (({to_integer})) to (({to_i})) mapping. [GitHub#1191][Patch by yosuke shiro] ==== Ruby/CairoGObject * Improvements * Added (({gtype})) class methods. ==== Ruby/GIO2 * Improvements * (({Gio::MenuItem#set_attribute_value})): Improved argument conversion. Callers don't need to create (({GLib::Variant})). * (({Gio::Settings.new})): Added support for keyword (({Hash})). [GitHub#1187][Patch by cedlemo] ==== Ruby/Pango * Improvements * (({Pango::Attribute})): Migrated to (({GLib::Boxed})). * (({Pango::Rectangle#dup})): Added. * (({rbpango_attribute_from_ruby()})): Added. * Fixes * Fixed a bug that wrong (({Pango::Attribute})) conversion. [GitHub#1188][Reported by kojix2] ==== Ruby/GdkPixbuf2 * Improvements * (({GdkPixbuf::Pixbuf#subpixbuf})): Added. (({GdkPixbuf::Pixbuf#new_subpixbuf})) is deprecated. * (({GdkPixbuf::Pixbuf#new})): Improved the default (({row_stride})) value. ==== Ruby/GDK3 * Improvements * (({Gdk::Cursor.new})): Added multiple calls with the same value. [GitHub#1195][Reported by kojix2] ==== Ruby/GTK3 * Improvements * Removed needless custom callback handlers. * Dropped GTK+ 3.10 support. * (({Gtk::Application.new})): Changed to all arguments are omittable. * (({Gtk::TextBuffer#insert})): Changed to raise an exception for unknown tag. * Fixes * Fixed a bug that (({Gtk::Version.or_later?})) requires the 3rd argument. * Fixed demo. * [GitHub#1175][GitHub#1176][GitHub#1177][GitHub#1178][GitHub#1183] [GitHub#1184][GitHub#1185] [Reported by kojix2] * [GitHub#1181][GitHub#1186][GitHub#1197][GitHub#1210] [Patch by kojix2] ==== Ruby/Poppler * Improvements * (({Cairo::Context#show_poppler_page})): Added for consistency. ==== Ruby/RSVG2 * Improvements * (({Cairo::Context#show_rsvg_handle})): Added for consistency. ==== Ruby/GStreamer * Improvements * (({Gst::Element.[]})): Added as a shortcut of (({Gst::ElementFactory.make})). * (({Gst::Bus#poll})): Made all arguments omittable. === Thanks * Izumi Tsutsui * okkez * kojix2 * cedlemo * yosuke shiro
Revision 1.12 / (download) - annotate - [select for diffs], Fri Apr 13 16:31:11 2018 UTC (5 years, 7 months ago) by tsutsui
Branch: MAIN
Changes since 1.11: +2 -1
lines
Diff to previous 1.11 (colored)
ruby-gnome2: update to 3.2.4. Upstream changes (from NEWS): == Ruby-GNOME2 3.2.4: 2018-04-09 This is a bug fix release of 3.2.3. === Changes ==== Ruby/GLib2 * Fixes * Fixed a bug that some constants aren't defined. If a content name is the same constant name at the top level such as (({Gtk::Object})), the constant isn't defined. [GitHub#1154][Debian#894816][mikutter#1199] [Reported by Akira Ouchi][Forwarded by HIGUCHI Daisuke] ==== RubyRsvg2 * Improvements * Windows: Upgraded bundled librsvg to 2.42.3. === Thanks * Akira Ouchi * HIGUCHI Daisuke == Ruby-GNOME2 3.2.3: 2018-04-03 This is a bug fix release of 3.2.2. === Changes ==== Ruby/GObjectIntrospection * Fixes * Fixed a crash bug when (({GLib::Bytes})) is passed as an argument. == Ruby-GNOME2 3.2.2: 2018-04-02 This is a release to support Ruby 2.5 on Windows. === Changes ==== All * Windows: Added Ruby 2.5 support. [GitHub#1148][Reported by Andy Meneely] * Red Hat: Use (({pkgconfig(name)})) style. [GitHub#1117][Patch by Mamoru TASAKA] ==== Ruby/GLib2 * Improvements * (({GLib::Bytes#to_s})): Changed to return a frozen string to reduce data copy. * Migrated to (({TypedData})) from (({Data})). ==== Ruby/GObjectIntrospection * Improvements * Added (({nil})) argument check. * (({GObjectIntrospection::Loader#rubyish_method_name})): Added (({:n_in_args_offset})) option. * Suppressed a needless copy of (({GLib::Bytes})). * Added filename array support. [GitHub#1151][Patch by cedlemo] * Fixes * Fixed a overflow bug on 32bit. [Debian#766020][Reported by Mario Lang] [GitHub#1137][Forwarded by HIGUCHI Daisuke] ==== Ruby/GTK2 * Fixes * Fix the wrong number of arguments. [GitHub#1133][Reported by Mamoru TASAKA] ==== Ruby/GDK3 * Improvements * Ensured loading GDK 3. [GitHub#1126][Patch by cedlemo] * Fixes * (({Gdk::Screen.default})): Fixed a GC related crash. * (({Gtk::Widget#style_context})): Fixed a GC related crash. [GitHub#1149][Reported by Valentin Pelloin] ==== Ruby/GTK3 * Improvements * Added a tool palette demo. [GitHub#1116][Patch by cedlemo] * Added a shortcut demo. [GitHub#1120][Patch by cedlemo] * Updated demo. [Reported by Titouan Teyssier] [GitHub#1139][Patch by Titouan Teyssier] * Updated README. [GitHub#1127][Patch by cedlemo] * Fixes * (({Gtk::Container#add_child(child)})): Made workable again. ==== Ruby/Poppler * Fixes * (({Poppler::Page#thumbnail_size})): Fixed return value. [GitHub:rcairo/rcairo#51][Reported by Mamoru TASAKA] ==== Ruby/Gnumeric * Improvements * Improved .typelib for Gnumeric detection. [GitHub#1118][Reported by cedlemo] === Thanks * cedlemo * Mamoru TASAKA * Titouan Teyssier * Mario Lang * HIGUCHI Daisuke * Andy Meneely * Valentin Pelloin
Revision 1.11 / (download) - annotate - [select for diffs], Sun Jan 24 05:03:24 2016 UTC (7 years, 10 months ago) by tsutsui
Branch: MAIN
CVS Tags: pkgsrc-2018Q1-base,
pkgsrc-2018Q1,
pkgsrc-2017Q4-base,
pkgsrc-2017Q4,
pkgsrc-2017Q3-base,
pkgsrc-2017Q3,
pkgsrc-2017Q2-base,
pkgsrc-2017Q2,
pkgsrc-2017Q1-base,
pkgsrc-2017Q1,
pkgsrc-2016Q4-base,
pkgsrc-2016Q4,
pkgsrc-2016Q3-base,
pkgsrc-2016Q3,
pkgsrc-2016Q2-base,
pkgsrc-2016Q2,
pkgsrc-2016Q1-base,
pkgsrc-2016Q1
Changes since 1.10: +491 -10
lines
Diff to previous 1.10 (colored)
Switch ruby-gnome2 packages to using gem. Bump PKGREVISIONs to denote gem'fy and PLIST changes. Also take maintainership. Discussed with and ok'ed by wiz@ on pkgsrc-users@: http://mail-index.netbsd.org/pkgsrc-users/2016/01/thread1.html#022813
Revision 1.10 / (download) - annotate - [select for diffs], Mon Oct 12 03:09:33 2009 UTC (14 years, 1 month ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2015Q4-base,
pkgsrc-2015Q4,
pkgsrc-2015Q3-base,
pkgsrc-2015Q3,
pkgsrc-2015Q2-base,
pkgsrc-2015Q2,
pkgsrc-2015Q1-base,
pkgsrc-2015Q1,
pkgsrc-2014Q4-base,
pkgsrc-2014Q4,
pkgsrc-2014Q3-base,
pkgsrc-2014Q3,
pkgsrc-2014Q2-base,
pkgsrc-2014Q2,
pkgsrc-2014Q1-base,
pkgsrc-2014Q1,
pkgsrc-2013Q4-base,
pkgsrc-2013Q4,
pkgsrc-2013Q3-base,
pkgsrc-2013Q3,
pkgsrc-2013Q2-base,
pkgsrc-2013Q2,
pkgsrc-2013Q1-base,
pkgsrc-2013Q1,
pkgsrc-2012Q4-base,
pkgsrc-2012Q4,
pkgsrc-2012Q3-base,
pkgsrc-2012Q3,
pkgsrc-2012Q2-base,
pkgsrc-2012Q2,
pkgsrc-2012Q1-base,
pkgsrc-2012Q1,
pkgsrc-2011Q4-base,
pkgsrc-2011Q4,
pkgsrc-2011Q3-base,
pkgsrc-2011Q3,
pkgsrc-2011Q2-base,
pkgsrc-2011Q2,
pkgsrc-2011Q1-base,
pkgsrc-2011Q1,
pkgsrc-2010Q4-base,
pkgsrc-2010Q4,
pkgsrc-2010Q3-base,
pkgsrc-2010Q3,
pkgsrc-2010Q2-base,
pkgsrc-2010Q2,
pkgsrc-2010Q1-base,
pkgsrc-2010Q1,
pkgsrc-2009Q4-base,
pkgsrc-2009Q4
Changes since 1.9: +2 -2
lines
Diff to previous 1.9 (colored)
Update ruby-gnome2 to 0.19.3. == Ruby-GNOME2 0.19.3: 2009-09-24 NOTE: 0.19.x releases are development series. This release is a bug fix release of 0.19.2. === Changes ===== Ruby/GLib2 * Bug fix: * really fix 'empty $(vendorarchdir) related build problem on CentOS 5.3 x86_64.' [Simon Arnaud, Kouhei Sutou] === Thanks * Simon Arnaud == Ruby-GNOME2 0.19.2: 2009-09-23 NOTE: 0.19.x releases are development series. This release is a bug fix release of 0.19.1. === Changes ==== Ruby/GLib2 * Bug fixes: * empty $(vendorarchdir) related build problem on CentOS 5.3 x86_64. [Toshiyuki Suzumura, Kouhei Sutou] * [#2862022] fix multi thread blocking with Ruby 1.8.6-p368 or later and 1.8.7-p173 or later. [Roy Wright, Andrea Dallera, Kouhei Sutou] * [Debian #502262] work Ruby thread with GTK+. [Johan Walles, Kouhei Sutou] ==== Ruby/GTK2 * Bug fixes: * [#2679744] fix a typo: Gtk::Widget#set_scroll_adjustment -> Gtk::Widget#set_scroll_adjustments. [Kentaro Fukuchi, Kouhei Sutou] ==== Ruby/GtkMozEmbed * Bug fixes: * fix .pc detection. [OBATA Akio, Kouhei Sutou] === Thanks * OBATA Akio * Toshiyuki Suzumura * Roy Wright * Andrea Dallera * Johan Walles * Kentaro Fukuchi
Revision 1.9 / (download) - annotate - [select for diffs], Wed Aug 12 12:43:11 2009 UTC (14 years, 3 months ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2009Q3-base,
pkgsrc-2009Q3
Changes since 1.8: +5 -1
lines
Diff to previous 1.8 (colored)
Update ruby-gnome2 to 0.19.1. This release is a bug fix release of 0.19.0. === Changes ==== Ruby/GTK2 * use RUBYARCHDIR [OBATA Akio] * #2814953: install missing headers [Mamoru Tasaka] ==== Ruby/GLib2 * Bug fixes: * avoid object allocation while GC [OBATA Akio, Kouhei Sutou] * use RUBYARCHDIR [OBATA Akio] * mkmf-gnome2.rb add "-I$(vendorarchdir)" to $CPPFLAGS. [OBATA Akio, Kouhei Sutou] ==== Ruby/ATK * use RUBYARCHDIR [OBATA Akio] ==== Ruby/Pango * use RUBYARCHDIR [OBATA Akio] * use gem version rcairo as fallback [OBATA Akio] ==== Ruby/Libart * use RUBYARCHDIR [OBATA Akio] ==== Ruby/GdkPixbuf * use gem version rcairo as fallback [OBATA Akio] ==== Ruby/GnomePrint * install rblibgnomeprintversion.h [OBATA Akio, Kouhei Sutou] ==== Ruby/GtkMozEmbeded * fix header generation error caused by missing file [OBATA Akio] ==== Ruby/VTE * support VTE 0.20 [Kouhei Sutou] ==== Ruby/PanelApplet * #2815036: re-support Ruby 1.8.6. [Mamoru Tasaka, Kouhei Sutou] ==== Ruby/Libglade2 * Debian#519786: fix GC related SEGV when a widget in glade is removed by hand. [Arnaud Cornet, Kouhei Sutou] === Thanks * OBATA Akio * Mamoru Tasaka * Arnaud Cornet
Revision 1.8 / (download) - annotate - [select for diffs], Sun Jun 14 18:25:06 2009 UTC (14 years, 5 months ago) by joerg
Branch: MAIN
CVS Tags: pkgsrc-2009Q2-base,
pkgsrc-2009Q2
Changes since 1.7: +1 -2
lines
Diff to previous 1.7 (colored)
Remove @dirrm entries from PLISTs
Revision 1.7 / (download) - annotate - [select for diffs], Wed Oct 22 10:42:03 2008 UTC (15 years, 1 month ago) by obache
Branch: MAIN
CVS Tags: pkgsrc-2009Q1-base,
pkgsrc-2009Q1,
pkgsrc-2008Q4-base,
pkgsrc-2008Q4
Changes since 1.6: +3 -1
lines
Diff to previous 1.6 (colored)
Update ruby-gnome2 to 0.18.0. == Ruby-GNOME2 0.18.0: 2008-09-30 This release fixes some memory leak bugs and has new experimental packages. === Changes Ruby/GLib: * mkmf-gnome2.rb: add check_cairo. [Kouhei Sutou] * fixed memory leaks. [Kouhei Sutou] * [#2110165] Gdk::Pixbuf memory leak * install glib-enum-types.h. [Andy Spencer] * [#2106938] Install glib-enum-types.h Ruby/GTK2: * add GTK+ 2.12 related bindings. [Guillaume Cottenceau] * fixed initialize order. [Kouhei Sutou] * [#2113491] Incorrect initialize order (compiling with mingw) Ruby/GooCanvas [NEW][EXPERIMENTAL]: * added. [Kouhei Sutou] Ruby/Pango: * fixed memory leaks. [Kouhei Sutou] Ruby/GtkSourceView2 [NEW][EXPERIMENTAL]: * add. [yselkowitz]
Revision 1.6 / (download) - annotate - [select for diffs], Thu Jun 19 15:15:06 2008 UTC (15 years, 5 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2008Q3-base,
pkgsrc-2008Q3,
pkgsrc-2008Q2-base,
pkgsrc-2008Q2,
cwrapper,
cube-native-xorg-base,
cube-native-xorg
Changes since 1.5: +5 -5
lines
Diff to previous 1.5 (colored)
Update to ruby-gnome2-gtk to 0.17.0rc1 to build with newer gnome packages.
Revision 1.5 / (download) - annotate - [select for diffs], Mon Jan 29 06:42:34 2007 UTC (16 years, 10 months ago) by minskim
Branch: MAIN
CVS Tags: pkgsrc-2008Q1-base,
pkgsrc-2008Q1,
pkgsrc-2007Q4-base,
pkgsrc-2007Q4,
pkgsrc-2007Q3-base,
pkgsrc-2007Q3,
pkgsrc-2007Q2-base,
pkgsrc-2007Q2,
pkgsrc-2007Q1-base,
pkgsrc-2007Q1
Changes since 1.4: +1 -3
lines
Diff to previous 1.4 (colored)
Update ruby-gnome2* to 0.16.0. Changes: * Fixed serious bugs (depends on GC) * Support GTK+-2.10 and the latest version of each libraries. * Don't include Ruby/GStreamer and Ruby/Libgda. We cancel to support Ruby/GStreamer and Ruby/Libgda. * Cancel to support ruby-1.6.x and GTK+-2.4 or earlier.
Revision 1.4 / (download) - annotate - [select for diffs], Thu Sep 7 15:58:00 2006 UTC (17 years, 3 months ago) by taca
Branch: MAIN
CVS Tags: pkgsrc-2006Q4-base,
pkgsrc-2006Q4,
pkgsrc-2006Q3-base,
pkgsrc-2006Q3
Changes since 1.3: +2 -1
lines
Diff to previous 1.3 (colored)
Remove ${RUBY_SITELIBDIR}/gtk2 directory when deleting package.
Revision 1.3 / (download) - annotate - [select for diffs], Tue Jul 25 16:49:05 2006 UTC (17 years, 4 months ago) by minskim
Branch: MAIN
Changes since 1.2: +2 -1
lines
Diff to previous 1.2 (colored)
Update ruby-gnome2 to 0.15. Patch provided by Dieter Roelants in PR 34064. Changes: Ruby/GLib * Improve signal handlers with pthread ruby(--enable-pthread). [Sjoerd Simons] * Added new fundamental object for other bindings. [Sjoerd Simons] * GLib::Source#remove? -> GLib::Soruce.remove? [Kouhei Sutou] * Added new macros (GLIST2ARYF, GLIST2ARY2F, GSLIST2ARYF, GLIST2ARY2F, G_PROTECT_CALLBACK) [Masao Mutoh] * Added GLib.win32_locale, GLib, win32_locale_filename_from_utf8 [Kouhei Sutou] * Improve memory management [Kouhei Sutou, Sjoerd Simons, Masahiro Sakai, Masao Mutoh] * Other improvement and fix bugs. [Sjoerd Simons, Joao Pedrosa, Kouhei Sutou, Masahiro Sakai, Masao Mutoh] Ruby/ATK * Improved cygwin support. [Masao Mutoh] * Fix a bug. [Masahiro Sakai] Ruby/Pango * Fix some bugs. [Laurent Sansonetti, Masao Mutoh] * Added Pango::Layout#markup=, Pango::AttrAbsoluteSize? [Masao Mutoh] Ruby/GdkPixbuf * Fix a bug. [NISHI Takao] * Code cleanup [Masao Mutoh] Ruby/GTK * Improve signal handlers. [Masahiro Sakai] * Added Gtk::Widget#set_widget, #set_requisition. [Daniel Chokola] * Added Gtk::Dialog#get_response. [Masao Mutoh] * Other improvement and fix bugs [Mario Steele, Tilman Sauerbeck, Geoff Youngs, Masahiro Sakai, Kouhei Sutou, Masao Mutoh] Ruby/GNOME * Follow Ruby/GLib2 change(GRClosure). [Kouhei Sutou] Ruby/GnomeCanvas * Code cleanup [Kouhei Sutou, Masao Mutoh] Ruby/Libart * None. Ruby/PanelApplet * Fixed a bug [Patch #1431855]
Revision 1.2 / (download) - annotate - [select for diffs], Sun Jan 15 16:12:55 2006 UTC (17 years, 10 months ago) by minskim
Branch: MAIN
CVS Tags: pkgsrc-2006Q2-base,
pkgsrc-2006Q2,
pkgsrc-2006Q1-base,
pkgsrc-2006Q1
Changes since 1.1: +4 -4
lines
Diff to previous 1.1 (colored)
Use RUBY_SITEARCHLIBDIR and RUBY_DLEXT in PLIST to build on more platforms. Patches from dieter Roelants and Takahiro Kambe.
Revision 1.1.1.1 / (download) - annotate - [select for diffs] (vendor branch), Sun Jan 8 03:47:23 2006 UTC (17 years, 11 months ago) by minskim
Branch: TNF
CVS Tags: pkgsrc-base
Changes since 1.1: +0 -0
lines
Diff to previous 1.1 (colored)
Import ruby-gnome2-gtk from pkgsrc-wip. Packaged by Dieter Roelants. Ruby-GNOME 2 is a set of Ruby language bindings for the various application development libraries included with the GNOME/GTK+ environment. Ruby/GTK2 is a Ruby binding of GTK+-2.0.x.
Revision 1.1 / (download) - annotate - [select for diffs], Sun Jan 8 03:47:23 2006 UTC (17 years, 11 months ago) by minskim
Branch: MAIN
Initial revision