The NetBSD Project

CVS log for pkgsrc/x11/qt5/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / x11 / qt5

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.20: download - view: text, markup, annotated - select for diffs
Sat Mar 26 20:37:09 2022 UTC (2 years, 8 months ago) by tnn
Branches: MAIN
CVS tags: pkgsrc-2024Q3-base, pkgsrc-2024Q3, pkgsrc-2024Q2-base, pkgsrc-2024Q2, pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, pkgsrc-2023Q3-base, pkgsrc-2023Q3, pkgsrc-2023Q2-base, pkgsrc-2023Q2, pkgsrc-2023Q1-base, pkgsrc-2023Q1, pkgsrc-2022Q4-base, pkgsrc-2022Q4, pkgsrc-2022Q3-base, pkgsrc-2022Q3, pkgsrc-2022Q2-base, pkgsrc-2022Q2, pkgsrc-2022Q1-base, pkgsrc-2022Q1, HEAD
Diff to: previous 1.19: preferred, colored
Changes since revision 1.19: +5 -2 lines
qt5: omit wayland dependency in meta package if not supported

Revision 1.19: download - view: text, markup, annotated - select for diffs
Tue Jan 21 20:25:36 2020 UTC (4 years, 10 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2021Q4-base, pkgsrc-2021Q4, pkgsrc-2021Q3-base, pkgsrc-2021Q3, pkgsrc-2021Q2-base, pkgsrc-2021Q2, pkgsrc-2021Q1-base, pkgsrc-2021Q1, pkgsrc-2020Q4-base, pkgsrc-2020Q4, pkgsrc-2020Q3-base, pkgsrc-2020Q3, pkgsrc-2020Q2-base, pkgsrc-2020Q2, pkgsrc-2020Q1-base, pkgsrc-2020Q1
Diff to: previous 1.18: preferred, colored
Changes since revision 1.18: +2 -1 lines
qt5: updated to 5.14.0

New Features in Qt 5.14

Qt 3D Module
Overhauled the threading architecture. This includes the removal of the aspect thread.
Overhauled the frontend/backend node sync.
Enabled QTransform to have access to the world matrix.
Introduced Scene3DView.
Scene3D is now in sync with QtQuick, and can render as an underlay without an FBO.

Qt Bluetooth Module
Introduced a new, optional Win32 backend with support for Windows 7 and 8. This backend is not built by default, nor is it part of the pre-built packages.
QLowEnergyController: Introduced AuthorizationError.
Added the ability to include multiple manufacturer data entries per manufacturer ID.

Qt Core Module
Added support in QCalendar for calendars other than Gregorian, by implementation of suitable backends.
Added backends to implement the Gregorian, Jalali (Persian), Islamic Civil, Milankovic, and Julian calendars. We look forward to other contributions.
Added QColorConstants, a namespace providing constexpr QColor instances that don't cost any runtime overhead.

Qt GUI Module
Updated High-DPI support:
Introduced non-integer scale factors (for example, a scale factor of 150%) that applications can opt-in to use. Use QGuiApplication::highDpiScaleFactorRoundingPolicy or QT_SCALE_FACTOR_ROUNDING_POLICY to set the rounding policy.
Added the QT_ENABLE_HIGHDPI_SCALING environment variable, enabling high-DPI scaling based on display DPI. This replaces QT_AUTO_SCREEN_SCALE_FACTOR (now deprecated), and corresponds to the Qt::AA_EnableHighDpiScaling application attribute.
Added cross-platform support for the QT_FONT_DPI environment variable, for the purpose of developing and testing with specific DPI values.
Added color-space support for images; reading and writing color-spaces from JPEG, PNG, WebP and TIFF images, and performing color-space transformation on images.
Improvements to QTextDocument and QTextTable styling:
Added per-edge border styling via QTextTableCellFormat.
Added border-collapse mode.
Added support for (partial) HTML table style import and export.
Added support for reading and writing Markdown format to QTextDocument, as an alternative to HTML.

Qt Multimedia Module
Added QVideoFrame::Format_YUV422P.
Introduced support for the GStreamer OpenGL plugin.

Qt Network Module
Introduced the HTTP/2 Configuration API.
Introduced network connectivity monitoring.
Added support for Kerberos proxy authentication.

Qt QML Module
Added qmlRegisterSingletonInstance() function. This allows to expose a QObject as a singleton to QML, without having to create a factory function as required by qmlRegisterSingletonType(). It is meant as a type safe replacement of setContextProperty() in common usages.
Added qmlRegisterAnonymousType() as a replacement for qmlRegisterType(). It allows to specify the URI and major version, which enables better tooling support.
Added an experimental -U option to qmllint. When set, access to unqualified identifiers generates warnings.

Qt Quick Module
Added a preview of the graphics API independent scenegraph renderer as an opt-in feature. This allows running qualifying Qt Quick applications on top of Vulkan, Metal, or Direct3D 11, instead of OpenGL. Currently supported platforms:
Windows 10 (Direct3D)
Linux with X11/xcb (Vulkan)
macOS (Metal or Vulkan with MoltenVK)
Android 7.0+ (Vulkan)
Added support for the Markdown format (including CommonMark and GitHub dialects) to Text and TextEdit as an alternative to HTML. This includes the GitHub checklist extension, allowing to toggle checkboxes in a TextEdit.
Switched TextEdit to use an I-beam cursor by default, and a pointing-hand cursor when hovering over a checkbox or a link. Default cursors can be overridden.
Added WheelHandler, an event handler for the mouse wheel, and optionally for emulated mouse wheel events coming from a trackpad.
Added BoundaryRule in Qt.labs.animation: a PropertyValueInterceptor that restricts the range of values a numeric property can have, applies "resistance" when overshooting a value, and provides the ability to animate it back to its normal range. It's particularly useful in combination with WheelHandler, providing physics similar to Flickable.
Added currentFrame and frameCount properties to Image and BorderImage, just as AnimatedImage has; for example, this allows choosing an individual icon from an .ICO file that contains multiple icons.
Added PathPolyline and PathMultiline as additional ways of drawing and/or filling arbitrary polygons and sets of polygons with Qt Quick Shapes.

Qt Serial Bus Module
Added operators to compare QCanBusDevice::Filter for equality or inequality.
Added the QCanBusDevice::OperationError and QCanBusDevice::TimeoutError codes to signal operation and timeout errors.
Added the QCanBusDevice::busStatus() function to query the bus status from the CAN bus device.
Added the QCanBusDevice::resetController() function to release the CAN controller from bus off state.
SocketCAN: Added the configuration parameter QCanBusDevice::ProtocolKey to use another protocol inside the protocol family PF_CAN.
SocketCAN: If libsocketcan is available, the CAN bus bitrate can be retrieved and set at runtime.
PeakCAN: Added support for PCAN-USB devices on macOS by using the MacCAN library.
Exposed the underlying QIODevice used for Modbus communication. This enables, for example, setting the serial port hardware flow control (RTS/CTS).

Qt Test Module
Introduced initMain() function to perform any initialization that must happen before QApplication exists.

Qt WebEngine Module
Updated to Chromium 77.
Added a new API to control the life-cycle of QWebEnginePage.

Qt Widgets Module
Added support for the Markdown format (including CommonMark and GitHub dialects) to QTextEdit and QTextBrowser as an alternative to HTML. This includes the GitHub checklist extension, allowing to toggle checkboxes if the widget is editable. QTextBrowser::setSource() detects Markdown based on the file extension.

Revision 1.18: download - view: text, markup, annotated - select for diffs
Tue Nov 5 14:58:43 2019 UTC (5 years ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4
Diff to: previous 1.17: preferred, colored
Changes since revision 1.17: +3 -1 lines
qt5: updated to 5.13.2

Qt 5.13.2 Released

We have released Qt 5.13.2 today. As a patch release, Qt 5.13.2 does not add any new functionality but provides many bug fixes and other improvements.

Compared to Qt 5.13.1, the new Qt 5.13.2 contains more than 200 bug fixes. For details of the most important changes, please check the Change files of Qt 5.13.2.

Revision 1.17: download - view: text, markup, annotated - select for diffs
Mon Sep 2 09:40:15 2019 UTC (5 years, 3 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q3-base, pkgsrc-2019Q3
Diff to: previous 1.16: preferred, colored
Changes since revision 1.16: +2 -1 lines
qt5: depend on qt5-qtspeech

Revision 1.16: download - view: text, markup, annotated - select for diffs
Tue Mar 26 11:14:16 2019 UTC (5 years, 8 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2019Q2-base, pkgsrc-2019Q2, pkgsrc-2019Q1-base, pkgsrc-2019Q1
Diff to: previous 1.15: preferred, colored
Changes since revision 1.15: +2 -1 lines
qt5: updated to 5.12.2

5.12.2:
While not adding new features, the Qt 5.12.2 release provides a number of bug
fixes and other improvements.

Compared to Qt 5.12.1, the new Qt 5.12.2 contains more than 250 bug fixes. For
details of the most important changes, please check the Change files of Qt
5.12.2.

With Qt 5.12.2 we bring back widely asked MinGW 32 bit prebuild binaries in
addition to 64 bit ones.

Qt 5.12 LTS will receive many more patch releases throughout the coming years
and we recommend all active developed projects to migrate to Qt 5.12 LTS. Qt
5.9 LTS is currently in ‘Strict’ phase and receives only the selected important
bug and security fixes, while Qt 5.12 LTS is currently receiving all the bug
fixes. With Qt 5.6 Support ending in March 2019 all active projects still using
Qt 5.6 LTS should now migrate to a later version of Qt.

Revision 1.15: download - view: text, markup, annotated - select for diffs
Wed Dec 26 11:48:27 2018 UTC (5 years, 11 months ago) by ryoon
Branches: MAIN
CVS tags: pkgsrc-2018Q4-base, pkgsrc-2018Q4
Diff to: previous 1.14: preferred, colored
Changes since revision 1.14: +1 -3 lines
Fix LICENSE and make pkglint happier

Revision 1.14: download - view: text, markup, annotated - select for diffs
Tue Dec 18 09:57:17 2018 UTC (5 years, 11 months ago) by adam
Branches: MAIN
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +1 -2 lines
qt5: updated to 5.12.0

Just in time for the end of the year, we have released Qt 5.12 LTS today. This is a long-term-supported (LTS) release that we will support for 3 years to come. We have had a strong focus on quality and fixed more than 2000 bugs since the last Qt LTS version, Qt 5.9.7 – make that over 5000 bugfixes since Qt 5.6.3. Of course, this is only the start, and we will work hard on continuously improving the quality of Qt 5.12 in upcoming patches

Revision 1.13: download - view: text, markup, annotated - select for diffs
Sat Oct 6 22:41:22 2018 UTC (6 years, 1 month ago) by adam
Branches: MAIN
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +4 -1 lines
Added x11/qt5-qtcharts, x11/qt5-qtnetworkauth

Revision 1.12: download - view: text, markup, annotated - select for diffs
Thu Mar 1 20:09:49 2018 UTC (6 years, 9 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2018Q3-base, pkgsrc-2018Q3, pkgsrc-2018Q2-base, pkgsrc-2018Q2, pkgsrc-2018Q1-base, pkgsrc-2018Q1
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -1 lines
qt5: updated to 5.10.1

5.10.1:
Bug fix release.

Revision 1.11: download - view: text, markup, annotated - select for diffs
Wed Jan 17 19:30:46 2018 UTC (6 years, 10 months ago) by markd
Branches: MAIN
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +2 -9 lines
qt5: update to 5.10.0

2+ years worth of bug fixes and feature enhancements

Revision 1.10: download - view: text, markup, annotated - select for diffs
Tue Dec 5 19:57:46 2017 UTC (6 years, 11 months ago) by joerg
Branches: MAIN
CVS tags: pkgsrc-2017Q4-base, pkgsrc-2017Q4
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +2 -2 lines
Revert last, qt5-websockets is not spelled like that.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Mon Dec 4 08:40:48 2017 UTC (7 years ago) by adam
Branches: MAIN
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
Fixed typo

Revision 1.8: download - view: text, markup, annotated - select for diffs
Wed Mar 2 23:03:59 2016 UTC (8 years, 9 months ago) by ryoon
Branches: MAIN
CVS tags: pkgsrc-2017Q3-base, pkgsrc-2017Q3, pkgsrc-2017Q2-base, pkgsrc-2017Q2, pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4, pkgsrc-2016Q3-base, pkgsrc-2016Q3, pkgsrc-2016Q2-base, pkgsrc-2016Q2, pkgsrc-2016Q1-base, pkgsrc-2016Q1
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +2 -1 lines
Use RPATH instead of RUNPATH to fix library not found error from Qt5 apps
Bump PKGREVISION

Revision 1.7: download - view: text, markup, annotated - select for diffs
Thu Oct 29 10:57:43 2015 UTC (9 years, 1 month ago) by jperkin
Branches: MAIN
CVS tags: pkgsrc-2015Q4-base, pkgsrc-2015Q4
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +2 -2 lines
Fix PKGNAME for qt5-websockets.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Mon Oct 26 19:03:59 2015 UTC (9 years, 1 month ago) by adam
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +3 -4 lines
Changes 5.5.1:

Qt Bluetooth
Bluetooth Low Energy API final release (5.4 was featuring tech preview).
Bluetooth Low Energy Support for Android (requires Android v18+) added.
Bluetooth Classic and Low Energy support for iOS and OS X.

Qt Core
You can now have Q_PROPERTY and Q_INVOKABLE within a Q_GADGET, and there is a way to query the QMetaObject of such gadget using the QMetaTYpe system.
Added Q_ENUM to replace Q_ENUMS which allow to get a QMetaEnum at compile time using QMetaEnum::fromType<T>. Such enums are now automatically registered as metatype, and can be converted to string within QVariant, or are printed as string by qDebug()

Qt GUI
Windows packages are all built with -opengl dynamic. No OpenGL-only or ANGLE-only builds are provided anymore.
On Windows the OpenGL implementation to use can now be configured based on the GPU vendor and driver version using JSON configuration files. This allows shipping fine-grained card and driver blacklists with the apps, when necessary.
QOpenGLWidget is now supported in iOS.
QImage: 8-bit alpha map and grayscale formats.
QImageReader: EXIF orientation can now be read though the transformation method, and applied on read to JPEGs if wanted.

Qt Multimedia
GStreamer 1.0 support. Note that the default is still 0.10. 1.0 support can be enabled by configuring Qt with '-gstreamer 1.0'.
New video filtering framework to integrate frameworks like OpenCV or compute APIs such as OpenCL or CUDA with VideoOutput elements.
New API to control camera viewfinder settings
Improved camera support on iOS (focus, zoom, exposure, viewfinder/image settings)
The QML MediaPlayer is now rendered in an OpenGL texture on iOS. This means VideoOutput supports advanced transformation, shader effects and doesn't have to be always on top of other items anymore.

Qt NFC
Neard based backend for Linux added.

Qt Network
New SSL back-end for iOS and OS X based on Secure Transport. Note that in Qt 5.6 this will become the default SSL: back-end on these platforms.
Support for libproxy
Support for TLS PSK ciphersuites
Support for elliptic curve certificates
Ability to select specific curves when using elliptic curve ciphersuites.

QPA
Added support for the Raspberry Pi 2.
Added support for the ODROID-XU3.
On supported desktops, the xcb plugin now uses the D-Bus based org.kde.StatusNotifier protocol for system tray icons, and org.freedesktop.Notifications for notifications.
KMS/DRM backend for EGLFS. This replaces the now deprecated KMS platform plugin. It allows running apps with eglfs on the console on systems with Mesa and devices that come with drm support.
EGLFS has a plugin-based backend mechanism in addition to the existing, statically compiled-in solution. Most compiled-in hooks are converted to be dynamically loaded plugins that are built based on configure time tests. This reduces the reliance on the device makespecs for RPi, i.MX6 and Mali-based devices.
Input handling is now unified for EGLFS and LinuxFB, avoiding the need to launch and configure LinuxFB-based apps differently than when using EGLFS.
tslib is now better integrated with EGLFS and LinuxFB to provide support for resistive single-touch touchscreens often used in industrial environments.
xcb is refactored to move GLX and EGL support into plugins. No more ifdefs, allowing building both backends.
Added a TUIO Touch plugin for receiving remote touch events via UDP.
Added a libinput plugin.
iOS: you can now use QFileDialog to browse system photos using a native image picker dialog by setting directory to QStandardPaths::PicturesLocation. Selected photos can be loaded using QFile.

Qt QML
It is now possible to conveniently expose custom C++ value types into the JavaScript environment of QML and QJSEngine.
Support for JavaScript typed arrays
Various performance improvements, notably QJSValue
Added convenience qJsEngine(QObject*) getter function.

Qt Quick
Windows now defaults to the threaded Qt Quick render loop when using desktop OpenGL (opengl32.dll).
QQuickWidget is now supported in iOS.
QQuickRenderControl supports threaded rendering.
Improved behavior of Flickable on OS X trackpads using pixel deltas from native gestures.
PinchArea handles native pinch gestures when the OS provides them (so far only on OS X). Otherwise it relies on touch events, as before.
Added a smart zoom signal to PinchArea to react to that gesture on an OS X trackpad.
MouseArea now has a scrollGestureEnabled property to control whether native scroll gestures from the OS will be handled by the wheel signal handler.

Qt Quick Controls
Qt Quick Extras (formerly Qt Quick Enterprise Controls) was added under the QtQuick.Extras import.
TreeView control for QAbstractItemModel-derived models. Supports QItemSelectionModel selection.

Qt WebEngine
Updated Chromium snapshot to version 40
WebEngineProfile for control of storage and cache paths and related policies.
Added support for javascript Geolocation API with QtLocation as a backend
Added API for managing downloading of files
Added API for controlling cache and cookie paths and policy
Added API for WebEngine settings
Added API for injecting user scripts
Various experimental QML API has been promoted to public
Added QtWebChannel integration API over Chromium IPC

Qt WebView
Added native implementations for Mac OS X.
Added API for running JavaScript (Requires API 19+ on Android).
Added API for setting the HTML content.
Added API for load status notifications.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Tue Dec 30 17:23:45 2014 UTC (9 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2, pkgsrc-2015Q1-base, pkgsrc-2015Q1
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +8 -4 lines
Changes 5.4.0:
Chromium-based browser engine Qt WebEngine
Qt WebView for showing web content using the native OS web engine on mobile
Full support on Qt for Windows Store Apps, including WinRT and Windows Phone 8.1
Improved Compliance with iOS 8 and Xcode 6
Improved OS X 10.10 ‘Yosemite’ support and new Mac AppStore signing
High-DPI support for Windows and OS X
Dynamic GL switching between OpenGL and ANGLE on Windows
Mix OpenGL and Qt Quick with QOpenGLWidget
Android Look-and-Feel for Qt Quick Controls
Qt Creator 3.3 with new Qt Quick Designer
Bluetooth now supports BlueZ5 with tech preview on Bluetooth LE

Revision 1.4: download - view: text, markup, annotated - select for diffs
Wed Apr 23 07:05:31 2014 UTC (10 years, 7 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4, pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +1 -2 lines
Changes 5.2.1:
It provides many improvements over Qt 5.2.0 as well as packages Qt Creator 3.0.1. As a patch release, it does not add new features and remains binary compatible with Qt 5.2.0.

Revision 1.3: download - view: text, markup, annotated - select for diffs
Wed Feb 12 23:18:55 2014 UTC (10 years, 9 months ago) by tron
Branches: MAIN
CVS tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +2 -2 lines
Recursive PKGREVISION bump for OpenSSL API version bump.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Sat Jan 4 11:58:39 2014 UTC (10 years, 11 months ago) by wiz
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -1 lines
Bump PKGREVISION.

libxcb-1.10 has one major library version change, for libxcb-sync.so
(from 0 to 1) and qt5 is the only package I could find that uses
this particular library.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Fri Dec 13 14:38:34 2013 UTC (10 years, 11 months ago) by ryoon
Branches: MAIN
CVS tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4
Import Qt5 5.2.0rc1 packages and qt5 input module from uim

Only tested on NetBSD/amd64 6.99.28.

ToDo:
* inputmethod/qt5-ibus from Qt5 should be created

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>