[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / qt5-qtsensors

File: [cvs.NetBSD.org] / pkgsrc / x11 / qt5-qtsensors / Makefile (download)

Revision 1.9, Tue Dec 30 17:23:47 2014 UTC (9 years, 3 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1
Changes since 1.8: +5 -8 lines

Changes 5.4.0:
Chromium-based browser engine Qt WebEngine
Qt WebView for showing web content using the native OS web engine on mobile
Full support on Qt for Windows Store Apps, including WinRT and Windows Phone 8.1
Improved Compliance with iOS 8 and Xcode 6
Improved OS X 10.10 ãàϺosemiteãàsupport and new Mac AppStore signing
High-DPI support for Windows and OS X
Dynamic GL switching between OpenGL and ANGLE on Windows
Mix OpenGL and Qt Quick with QOpenGLWidget
Android Look-and-Feel for Qt Quick Controls
Qt Creator 3.3 with new Qt Quick Designer
Bluetooth now supports BlueZ5 with tech preview on Bluetooth LE

# $NetBSD: Makefile,v 1.9 2014/12/30 17:23:47 adam Exp $

DISTNAME=	qtsensors-opensource-src-${QTVERSION}
PKGNAME=	qt5-qtsensors-${QTVERSION}
COMMENT=	Qt5 module for Sensors

BUILD_TARGET=		sub-src
MAKE_ENV+=		QTDIR=${QTDIR}

INSTALL_ENV+=		INSTALL_ROOT=${DESTDIR}
INSTALLATION_DIRS+=	lib/pkgconfig

.include "../../x11/qt5-qtbase/Makefile.common"

post-install:
.for i in Qt5Sensors.pc
	cd ${DESTDIR}${PREFIX}/lib/pkgconfig && \
	ln -f -s ${QTPREFIX}/lib/pkgconfig/${i} ${i}
.endfor

.include "../../x11/qt5-qtdeclarative/buildlink3.mk"
.include "../../x11/qt5-qtsvg/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"