The NetBSD Project

CVS log for pkgsrc/x11/qt5-dbus/Attic/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / x11 / qt5-dbus

Request diff between arbitrary revisions


Keyword substitution: kv
Default branch: MAIN


Revision 1.15
Mon Oct 26 19:03:59 2015 UTC (9 years, 1 month ago) by adam
Branches: MAIN
CVS tags: HEAD
FILE REMOVED
Changes since revision 1.14: +1 -1 lines
Changes 5.5.1:

Qt Bluetooth
Bluetooth Low Energy API final release (5.4 was featuring tech preview).
Bluetooth Low Energy Support for Android (requires Android v18+) added.
Bluetooth Classic and Low Energy support for iOS and OS X.

Qt Core
You can now have Q_PROPERTY and Q_INVOKABLE within a Q_GADGET, and there is a way to query the QMetaObject of such gadget using the QMetaTYpe system.
Added Q_ENUM to replace Q_ENUMS which allow to get a QMetaEnum at compile time using QMetaEnum::fromType<T>. Such enums are now automatically registered as metatype, and can be converted to string within QVariant, or are printed as string by qDebug()

Qt GUI
Windows packages are all built with -opengl dynamic. No OpenGL-only or ANGLE-only builds are provided anymore.
On Windows the OpenGL implementation to use can now be configured based on the GPU vendor and driver version using JSON configuration files. This allows shipping fine-grained card and driver blacklists with the apps, when necessary.
QOpenGLWidget is now supported in iOS.
QImage: 8-bit alpha map and grayscale formats.
QImageReader: EXIF orientation can now be read though the transformation method, and applied on read to JPEGs if wanted.

Qt Multimedia
GStreamer 1.0 support. Note that the default is still 0.10. 1.0 support can be enabled by configuring Qt with '-gstreamer 1.0'.
New video filtering framework to integrate frameworks like OpenCV or compute APIs such as OpenCL or CUDA with VideoOutput elements.
New API to control camera viewfinder settings
Improved camera support on iOS (focus, zoom, exposure, viewfinder/image settings)
The QML MediaPlayer is now rendered in an OpenGL texture on iOS. This means VideoOutput supports advanced transformation, shader effects and doesn't have to be always on top of other items anymore.

Qt NFC
Neard based backend for Linux added.

Qt Network
New SSL back-end for iOS and OS X based on Secure Transport. Note that in Qt 5.6 this will become the default SSL: back-end on these platforms.
Support for libproxy
Support for TLS PSK ciphersuites
Support for elliptic curve certificates
Ability to select specific curves when using elliptic curve ciphersuites.

QPA
Added support for the Raspberry Pi 2.
Added support for the ODROID-XU3.
On supported desktops, the xcb plugin now uses the D-Bus based org.kde.StatusNotifier protocol for system tray icons, and org.freedesktop.Notifications for notifications.
KMS/DRM backend for EGLFS. This replaces the now deprecated KMS platform plugin. It allows running apps with eglfs on the console on systems with Mesa and devices that come with drm support.
EGLFS has a plugin-based backend mechanism in addition to the existing, statically compiled-in solution. Most compiled-in hooks are converted to be dynamically loaded plugins that are built based on configure time tests. This reduces the reliance on the device makespecs for RPi, i.MX6 and Mali-based devices.
Input handling is now unified for EGLFS and LinuxFB, avoiding the need to launch and configure LinuxFB-based apps differently than when using EGLFS.
tslib is now better integrated with EGLFS and LinuxFB to provide support for resistive single-touch touchscreens often used in industrial environments.
xcb is refactored to move GLX and EGL support into plugins. No more ifdefs, allowing building both backends.
Added a TUIO Touch plugin for receiving remote touch events via UDP.
Added a libinput plugin.
iOS: you can now use QFileDialog to browse system photos using a native image picker dialog by setting directory to QStandardPaths::PicturesLocation. Selected photos can be loaded using QFile.

Qt QML
It is now possible to conveniently expose custom C++ value types into the JavaScript environment of QML and QJSEngine.
Support for JavaScript typed arrays
Various performance improvements, notably QJSValue
Added convenience qJsEngine(QObject*) getter function.

Qt Quick
Windows now defaults to the threaded Qt Quick render loop when using desktop OpenGL (opengl32.dll).
QQuickWidget is now supported in iOS.
QQuickRenderControl supports threaded rendering.
Improved behavior of Flickable on OS X trackpads using pixel deltas from native gestures.
PinchArea handles native pinch gestures when the OS provides them (so far only on OS X). Otherwise it relies on touch events, as before.
Added a smart zoom signal to PinchArea to react to that gesture on an OS X trackpad.
MouseArea now has a scrollGestureEnabled property to control whether native scroll gestures from the OS will be handled by the wheel signal handler.

Qt Quick Controls
Qt Quick Extras (formerly Qt Quick Enterprise Controls) was added under the QtQuick.Extras import.
TreeView control for QAbstractItemModel-derived models. Supports QItemSelectionModel selection.

Qt WebEngine
Updated Chromium snapshot to version 40
WebEngineProfile for control of storage and cache paths and related policies.
Added support for javascript Geolocation API with QtLocation as a backend
Added API for managing downloading of files
Added API for controlling cache and cookie paths and policy
Added API for WebEngine settings
Added API for injecting user scripts
Various experimental QML API has been promoted to public
Added QtWebChannel integration API over Chromium IPC

Qt WebView
Added native implementations for Mac OS X.
Added API for running JavaScript (Requires API 19+ on Android).
Added API for setting the HTML content.
Added API for load status notifications.

Revision 1.14: download - view: text, markup, annotated - select for diffs
Sat Oct 10 01:57:57 2015 UTC (9 years, 1 month ago) by ryoon
Branches: MAIN
Diff to: previous 1.13: preferred, colored
Changes since revision 1.13: +2 -2 lines
Recursive revbump from textproc/icu

Revision 1.13: download - view: text, markup, annotated - select for diffs
Sat Apr 25 14:25:17 2015 UTC (9 years, 7 months ago) by tnn
Branches: MAIN
CVS tags: pkgsrc-2015Q3-base, pkgsrc-2015Q3, pkgsrc-2015Q2-base, pkgsrc-2015Q2
Diff to: previous 1.12: preferred, colored
Changes since revision 1.12: +2 -2 lines
Recursive revbump following MesaLib update, categories p through x.

Revision 1.12: download - view: text, markup, annotated - select for diffs
Mon Apr 6 08:17:18 2015 UTC (9 years, 7 months ago) by adam
Branches: MAIN
Diff to: previous 1.11: preferred, colored
Changes since revision 1.11: +2 -1 lines
Revbump after updating textproc/icu

Revision 1.11: download - view: text, markup, annotated - select for diffs
Tue Dec 30 17:23:45 2014 UTC (9 years, 11 months ago) by adam
Branches: MAIN
CVS tags: pkgsrc-2015Q1-base, pkgsrc-2015Q1
Diff to: previous 1.10: preferred, colored
Changes since revision 1.10: +13 -12 lines
Changes 5.4.0:
Chromium-based browser engine Qt WebEngine
Qt WebView for showing web content using the native OS web engine on mobile
Full support on Qt for Windows Store Apps, including WinRT and Windows Phone 8.1
Improved Compliance with iOS 8 and Xcode 6
Improved OS X 10.10 ‘Yosemite’ support and new Mac AppStore signing
High-DPI support for Windows and OS X
Dynamic GL switching between OpenGL and ANGLE on Windows
Mix OpenGL and Qt Quick with QOpenGLWidget
Android Look-and-Feel for Qt Quick Controls
Qt Creator 3.3 with new Qt Quick Designer
Bluetooth now supports BlueZ5 with tech preview on Bluetooth LE

Revision 1.10: download - view: text, markup, annotated - select for diffs
Thu Dec 25 13:51:13 2014 UTC (9 years, 11 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2014Q4-base, pkgsrc-2014Q4
Diff to: previous 1.9: preferred, colored
Changes since revision 1.9: +7 -16 lines
Improve qt5 build structure, from Niclas Rosenvik:
Allow multiple BUILD_DIRS (but Makefile.common must be included later)
Adds installation of some cmake files and gets rid of many manual
installation rules.
Bump PKGREVISION where PLIST changed.

Revision 1.9: download - view: text, markup, annotated - select for diffs
Tue Oct 7 16:47:16 2014 UTC (10 years, 1 month ago) by adam
Branches: MAIN
Diff to: previous 1.8: preferred, colored
Changes since revision 1.8: +2 -2 lines
Revbump after updating libwebp and icu

Revision 1.8: download - view: text, markup, annotated - select for diffs
Thu May 1 12:50:39 2014 UTC (10 years, 7 months ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2014Q3-base, pkgsrc-2014Q3, pkgsrc-2014Q2-base, pkgsrc-2014Q2
Diff to: previous 1.7: preferred, colored
Changes since revision 1.7: +14 -1 lines
This is an ugly hack:

qdbuscpp2xml and qdbusxml2cpp should be built and installed, because
they are referenced from Qt5DBusConfigExtras.cmake, and cmake
fails to find qtdbus if they are not installed.
I didn't manage to build them though, and the only customers so far
didn't need their functionality - so install scripts that call 'false'.

Bump PKGREVISION.

Please fix properly :)

Revision 1.7: download - view: text, markup, annotated - select for diffs
Wed Apr 23 07:05:31 2014 UTC (10 years, 7 months ago) by adam
Branches: MAIN
Diff to: previous 1.6: preferred, colored
Changes since revision 1.6: +1 -2 lines
Changes 5.2.1:
It provides many improvements over Qt 5.2.0 as well as packages Qt Creator 3.0.1. As a patch release, it does not add new features and remains binary compatible with Qt 5.2.0.

Revision 1.6: download - view: text, markup, annotated - select for diffs
Wed Apr 9 07:26:57 2014 UTC (10 years, 7 months ago) by obache
Branches: MAIN
Diff to: previous 1.5: preferred, colored
Changes since revision 1.5: +2 -2 lines
recursive bump from icu shlib major bump.

Revision 1.5: download - view: text, markup, annotated - select for diffs
Wed Feb 12 23:18:55 2014 UTC (10 years, 9 months ago) by tron
Branches: MAIN
CVS tags: pkgsrc-2014Q1-base, pkgsrc-2014Q1
Diff to: previous 1.4: preferred, colored
Changes since revision 1.4: +2 -2 lines
Recursive PKGREVISION bump for OpenSSL API version bump.

Revision 1.4: download - view: text, markup, annotated - select for diffs
Mon Feb 3 16:17:12 2014 UTC (10 years, 10 months ago) by ryoon
Branches: MAIN
Diff to: previous 1.3: preferred, colored
Changes since revision 1.3: +2 -2 lines
Recursive revbump from libxkbcommon 0.4.0 update

Revision 1.3: download - view: text, markup, annotated - select for diffs
Wed Jan 29 13:01:53 2014 UTC (10 years, 10 months ago) by ryoon
Branches: MAIN
Diff to: previous 1.2: preferred, colored
Changes since revision 1.2: +3 -1 lines
Restrict lib/dbus-1.0/include/dbus/dbus-arch-deps.h buildlink
Avoid errors in non-qt5-dbus packages.

Revision 1.2: download - view: text, markup, annotated - select for diffs
Sat Jan 4 11:58:39 2014 UTC (10 years, 11 months ago) by wiz
Branches: MAIN
Diff to: previous 1.1: preferred, colored
Changes since revision 1.1: +2 -1 lines
Bump PKGREVISION.

libxcb-1.10 has one major library version change, for libxcb-sync.so
(from 0 to 1) and qt5 is the only package I could find that uses
this particular library.

Revision 1.1: download - view: text, markup, annotated - select for diffs
Fri Dec 13 14:38:34 2013 UTC (10 years, 11 months ago) by ryoon
Branches: MAIN
CVS tags: pkgsrc-2013Q4-base, pkgsrc-2013Q4
Import Qt5 5.2.0rc1 packages and qt5 input module from uim

Only tested on NetBSD/amd64 6.99.28.

ToDo:
* inputmethod/qt5-ibus from Qt5 should be created

Diff request

This form allows you to request diffs between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.

Log view options

CVSweb <webmaster@jp.NetBSD.org>