[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / qt4-mng

File: [cvs.NetBSD.org] / pkgsrc / x11 / qt4-mng / Makefile (download)

Revision 1.25, Sun Jul 7 18:13:56 2013 UTC (10 years, 8 months ago) by adam
Branch: MAIN
CVS Tags: pkgsrc-2013Q3-base, pkgsrc-2013Q3
Changes since 1.24: +1 -2 lines

Qt 4.8.5 provides overall close to 400 improvements, for example:
35 fixes to Qt Core module
65 fixes to Qt Gui module
21 Mac OS X specific fixes
15 Windows specific fixes
8 Linux/X11 specific fixes
Webkit upgrade to 2.2.4 (minor improvements)
Change all shmget calls to user-only memory (security)
Several important fixes for the VxWorks port in the Qt Enterprise version

# $NetBSD: Makefile,v 1.25 2013/07/07 18:13:56 adam Exp $

PKGNAME=	qt4-mng-${QTVERSION}
COMMENT=	QT MNG image format plugin

.include "../../x11/qt4-libs/Makefile.common"
CONFIGURE_ARGS+=	-I${QTDIR}/include
CONFIGURE_ARGS+=	-L${QTDIR}/lib

BUILD_QT4=		yes

do-build:
	cd ${WRKSRC}/src/tools/bootstrap && env ${MAKE_ENV} ${GMAKE}
	cd ${WRKSRC}/src/tools/moc && env ${MAKE_ENV} ${GMAKE}
	cd ${WRKSRC}/src/plugins/imageformats/mng && env ${MAKE_ENV} ${GMAKE}

IMGFMTDIR=	${QTPREFIX}/plugins/imageformats

INSTALLATION_DIRS=	${IMGFMTDIR}

do-install:
	${LIBTOOL} --mode=install ${INSTALL_LIB} \
		${WRKSRC}/plugins/imageformats/libqmng.la ${DESTDIR}${IMGFMTDIR}

.include "../../x11/qt4-libs/buildlink3.mk"
.include "../../x11/qt4-tools/buildlink3.mk"
.include "../../graphics/mng/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"