[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / py-kiwi

File: [cvs.NetBSD.org] / pkgsrc / x11 / py-kiwi / Attic / Makefile (download)

Revision 1.14, Sat Feb 4 10:36:53 2012 UTC (12 years, 2 months ago) by obache
Branch: MAIN
Changes since 1.13: +19 -9 lines

Update py-kiwi to 1.9.29.

kiwi-1.9.29 22-july-2011
    - Remove support for gazpacho in favor of GtkBuilder
    - Use new gtk entries with icon instead of our old IconEntry
    - Improvements to ObjectList

kiwi-1.9.28 01-september-2010
    - Remove support for gazpacho in favor of GtkBuilder
    - Use new gtk entries with icon instead of our old IconEntry
    - Improvements to ObjectList

kiwi-1.9.27 01-september-2010
    - Remove use of obsolete gtk.Tooltips (Ronaldo Maia)
    - Add api to set the number of digits in NumberSearchFilter (Gabriel
      Gerga)

kiwi-1.9.26-2 15-december-2009
    - Added workaround for set_text method in KiwiEntry when using gtk > 2.18.
      (George Kussumoto).

kiwi-1.9.26 14-july-2009
    - Added custom sort function for objectlists. (Ronaldo Maia)
    - Added decimal digits searching in Advanced Search.  (Ronaldo Maia)
    - Fixed sv_SE thousand separators. (Ronaldo Maia)
    - Minor bugfixes

kiwi-1.9.25 15-april-2009
    - Added Advanced Search in search dialogs. (Romaia Maia)
    - Fixed overwriting of custom cmdclass (Severin Heiniger, #3781)
    - Minor bugfixes

kiwi-1.9.24 27-jan-2009
    - Fixed currency formating (Ronaldo Maia)
    - Fixed ComboEntry value updating (Ronaldo Maia, #3673)
    - Added multi-line capability example (Ronaldo Maia)
    - Added multi-line capability in ComboEntry options (Ronaldo Maia, #3843)
    - Fixed ComboEntry toggle button and popup position (Ronaldo Maia, #3841)
    - Added initial support for loading GtkBuilder files (Johan Dahlin)

kiwi-1.9.23 10-sep-2008
    - Added support for multiple colors in ColoredColumn (Ronaldo Maia)
    - Fixed glade-3 plugin (Johan Dahlin)
    - Minor bug fixes

# $NetBSD: Makefile,v 1.14 2012/02/04 10:36:53 obache Exp $
#

DISTNAME=	kiwi-1.9.29
PKGNAME=	${PYPKGPREFIX}-${DISTNAME}
CATEGORIES=	x11 python
MASTER_SITES=	${MASTER_SITE_GNOME:=sources/kiwi/1.9/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.async.com.br/projects/kiwi/
COMMENT=	Framework and a set of enhanced PyGTK widgets
LICENSE=	gnu-lgpl-v2.1 # or later

DEPENDS+=	${PYPKGPREFIX}-setuptools>=0.6c6:../../devel/py-setuptools

PKG_DESTDIR_SUPPORT=	user-destdir

USE_LANGUAGES=		#none
USE_PKGLOCALEDIR=	yes
USE_TOOLS+=		msgfmt

PYTHON_VERSIONS_ACCEPTED=	27 26 25

SUBST_CLASSES+=		localedir
SUBST_STAGE.localedir=	pre-configure
SUBST_FILES.localedir=	setup.py
SUBST_SED.localedir=	-e 's|share/locale|${PKGLOCALEDIR}/locale|'

# tarball contains neither api nor howto.
post-install:
	rmdir ${DESTDIR}${PREFIX}/share/doc/kiwi/api || true
	rmdir ${DESTDIR}${PREFIX}/share/doc/kiwi/howto || true

.include "../../lang/python/application.mk"
.include "../../lang/python/distutils.mk"
BUILDLINK_API_DEPENDS.pygtk2+=	${PYPKGPREFIX}-gtk2>=2.18
.include "../../x11/py-gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"