File:  [cvs.NetBSD.org] / pkgsrc / x11 / py-gtk2 / Makefile
Revision 1.128: download - view: text, annotated - select for diffs
Mon Oct 12 21:52:04 2020 UTC (4 years, 6 months ago) by bacon
Branches: MAIN
CVS tags: HEAD
math/blas, math/lapack: Install interchangeable BLAS system

Install the new interchangeable BLAS system created by Thomas Orgis,
currently supporting Netlib BLAS/LAPACK, OpenBLAS, cblas, lapacke, and
Apple's Accelerate.framework.  This system allows the user to select any
BLAS implementation without modifying packages or using package options, by
setting PKGSRC_BLAS_TYPES in mk.conf. See mk/blas.buildlink3.mk for details.

This commit should not alter behavior of existing packages as the system
defaults to Netlib BLAS/LAPACK, which until now has been the only supported
implementation.

Details:

Add new mk/blas.buildlink3.mk for inclusion in dependent packages
Install compatible Netlib math/blas and math/lapack packages
Update math/blas and math/lapack MAINTAINER approved by adam@
OpenBLAS, cblas, and lapacke will follow in separate commits
Update direct dependents to use mk/blas.buildlink3.mk
Perform recursive revbump

# $NetBSD: Makefile,v 1.128 2020/10/12 21:52:04 bacon Exp $

DISTNAME=	pygtk-2.24.0
PKGNAME=	${PYPKGPREFIX}-${DISTNAME:S/pygtk/gtk2/}
PKGREVISION=	35
CATEGORIES=	x11 python
MASTER_SITES=	${MASTER_SITE_GNOME:=sources/pygtk/2.24/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	http://www.pygtk.org/
COMMENT=	Python bindings for GTK+2
LICENSE=	gnu-lgpl-v2.1

CONFLICTS=	${PYPKGPREFIX}-gtk<0.6.10

# IOError: [Errno 2] No such file or directory: 'gtk-types.defs'
MAKE_JOBS_SAFE=	no

USE_LIBTOOL=		YES
PKGCONFIG_OVERRIDE+=	pygtk-2.0.pc.in
GNU_CONFIGURE=		YES
CONFIGURE_ENV+=		PYTHON=${PYTHONBIN:Q}
USE_TOOLS+=		gmake pkg-config

PY_PATCHPLIST=	YES
PYTHON_VERSIONS_ACCEPTED=	27 # not yet ported as of 2.24.0

REPLACE_PYTHON+=	examples/atk/atk-demo.py
REPLACE_PYTHON+=	examples/glade/autoconnect.py
REPLACE_PYTHON+=	examples/glade/glade-demo.py
REPLACE_PYTHON+=	examples/gtk/customtreemodel.py
REPLACE_PYTHON+=	examples/ide/browse.py
REPLACE_PYTHON+=	examples/ide/edit.py
REPLACE_PYTHON+=	examples/ide/gtkcons.py
REPLACE_PYTHON+=	examples/ide/gtkdb.py
REPLACE_PYTHON+=	examples/ide/gtkprof.py
REPLACE_PYTHON+=	examples/ide/pyide.py
REPLACE_PYTHON+=	examples/pango/extentdemo.py
REPLACE_PYTHON+=	examples/pango/pangocairo-simple.py
REPLACE_PYTHON+=	examples/pango/utf8-demo.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/appwindow.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/buttonbox.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/changedisplay.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/colorsel.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/dialogs.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/dnd.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/editable_cells.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/entry_completion.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/expander.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/hypertext.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/images.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/infobar.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/list_store.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/menu.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/panes.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/pixbufs.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/sizegroup.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/statusicon.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/stock_browser.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/textscroll.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/textview.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/tooltip.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/tree_store.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/treemodel.py
REPLACE_PYTHON+=	examples/pygtk-demo/demos/ui_manager.py
REPLACE_PYTHON+=	examples/pygtk-demo/pygtk-demo.py
REPLACE_PYTHON+=	examples/simple/dnd.py
REPLACE_PYTHON+=	examples/simple/hello.py
REPLACE_PYTHON+=	examples/simple/scribble.py
REPLACE_PYTHON+=	examples/simple/simple.py
REPLACE_PYTHON+=	examples/simple/tooltip.py
REPLACE_PYTHON+=	setup.py
REPLACE_PYTHON+=	tests/runtests.py

.include "options.mk"

.include "../../lang/python/application.mk"
.include "../../lang/python/extension.mk"

.include "../../devel/libglade/buildlink3.mk"
.include "../../graphics/py-cairo/buildlink3.mk"
BUILDLINK_API_DEPENDS.pygobject+=	${PYPKGPREFIX}-gobject>=2.15.3
.include "../../devel/py-gobject/buildlink3.mk"
BUILDLINK_API_DEPENDS.gtk2+=		gtk2+>=2.16.0
.include "../../x11/gtk2/buildlink3.mk"

.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>