[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / mlterm

File: [cvs.NetBSD.org] / pkgsrc / x11 / mlterm / Makefile (download)

Revision 1.91, Sun Aug 11 13:23:34 2013 UTC (10 years, 8 months ago) by tsutsui
Branch: MAIN
Changes since 1.90: +2 -2 lines

Update mlterm to 3.2.2.

pkgsrc changes:

 - remove obsolete post-3.2.1 fixes
 - pull a post 3.2.2 fix for a bug of copy_area() which disabled redrawing
   the margin area. (found after Open Source Conference 2013 Kyoto)

Changes from doc/en/ReleaseNote:

ver 3.2.2
* Support SSH agent authentication and forwarding.
* Support X11 forwarding (no xauth) on win32/libssh2 and java.
* Add "X11 forwarding" checkbox to the connection dialog on win32.
* Change "skip_dialog" option to "show_dialog" and reverse the default behavior.
* Open a pty channel on the same ssh session as the active screen when OPEN_PTY
  or OPEN_SCREEN shortcut key is pressed.
* Bug fixes:
  Fix configure error which --with-gui=xlib,fb option causes. (enbugged at 3.2.1)
  DECALN(ESC#8) resets the screen margins.
  Fix the cursor position in inserting RTL characters after one LTR character.
  Fix segmentation fault of libvte compatible libyrary with synaptic 0.80.
  Fix clipboard operations of copy&paste on multiple windows on win32.
  Fix hangup on x11 forwarding.
  Fix segmentation fault in closing the first window on win32/libssh2.
  Fix the font and position of IME preedit text on win32.

# $NetBSD: Makefile,v 1.91 2013/08/11 13:23:34 tsutsui Exp $

DISTNAME=	mlterm-3.2.2
CATEGORIES=	x11
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=mlterm/}

MAINTAINER=	uebayasi@NetBSD.org
HOMEPAGE=	http://mlterm.sourceforge.net/
COMMENT=	Multilingual terminal emulator
LICENSE=	modified-bsd

# CODESET is only supported on NetBSD in 1.5T and later - see <langinfo.h>
NOT_FOR_PLATFORM=	NetBSD-1.[0-4]*-* NetBSD-1.5[A-S]-*

USE_TOOLS+=		pkg-config msgfmt
USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
USE_PKGLOCALEDIR=	yes

PKG_SYSCONFSUBDIR=	mlterm
EGDIR=			${PREFIX}/share/examples/mlterm
.for f in aafont color font key main menu taafont termcap tfont vaafont vfont \
	xim
CONF_FILES+=		${EGDIR}/${f} ${PKG_SYSCONFDIR}/${f}
.endfor

CONFIGURE_ARGS+=	--with-imagelib=gdk-pixbuf
CONFIGURE_ARGS+=	--without-libiconv-prefix
CONFIGURE_ARGS+=	--without-libintl-prefix
CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFBASEDIR}

INSTALL_MAKE_FLAGS+=	sysconfdir=${PREFIX}/share/examples

.include "../../mk/bsd.prefs.mk"
.include "options.mk"

SUBST_CLASSES+=		link
SUBST_MESSAGE.link=	Fixing hardcoded paths and link options in Makefiles.
SUBST_STAGE.link=	post-patch
SUBST_FILES.link=	Makefile.in */Makefile.in */*/Makefile.in \
			*/*/*/Makefile.in
SUBST_SED.link=		-e 's|(LIBTOOL_LINK).*(LIBS)|& ${X11_LDFLAGS:M*:Q}|g'
SUBST_SED.link+=	-e 's|(LIBTOOL_LINK).*(LIBDIR)|& ${X11_LDFLAGS:M*:Q}|g'
SUBST_SED.link+=	-e 's|/usr/local/|${PREFIX}/|g'
SUBST_SED.link+=	-e 's|/usr/X11R7/|${X11BASE}/|g'

SUBST_CLASSES+=		man
SUBST_MESSAGE.man=	Fixing hardcoded paths in man pages.
SUBST_STAGE.man=	post-patch
SUBST_FILES.man=	man/mlterm.1
SUBST_SED.man=		-e 's|/usr/X11R6/lib/X11/mlterm/|${PKG_SYSCONFDIR}/|g'
SUBST_SED.man+=		-e 's|/usr/X11R6/include/|${X11BASE}/include/|g'

SUBST_CLASSES+=		conf
SUBST_MESSAGE.conf=	Fixing hardcoded paths in config files.
SUBST_STAGE.conf=	post-patch
SUBST_FILES.conf=	etc/font-fb
SUBST_SED.conf=		-e 's|/usr/X11R7/|${X11BASE}/|g'
SUBST_SED.conf+=	-e 's|/usr/pkg/|${PREFIX}/|g'

BUILDLINK_DEPMETHOD.libXt?=	build

INSTALLATION_DIRS=	share/doc/mlterm share/doc/mlterm/en share/doc/mlterm/ja

post-install:
.for f in FAQ PROTOCOL README.bidi README.fb README.indic README.xim
	${INSTALL_DATA} ${WRKSRC}/doc/en/${f} \
		${DESTDIR}${PREFIX}/share/doc/mlterm/en
.endfor
.for f in BUGS FAQ README.aafont README.comb README.confapp README.fb \
		README.fontproto README.ja README.pty README.server \
		README.tate README.utf8 README.xim
	${INSTALL_DATA} ${WRKSRC}/doc/ja/${f} \
		${DESTDIR}${PREFIX}/share/doc/mlterm/ja
.endfor

.include "../../converters/libiconv/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../graphics/gdk-pixbuf2/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../x11/libSM/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXt/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"