[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / mlterm

File: [cvs.NetBSD.org] / pkgsrc / x11 / mlterm / Makefile (download)

Revision 1.81, Sun Mar 10 16:12:57 2013 UTC (11 years, 1 month ago) by tsutsui
Branch: MAIN
Changes since 1.80: +2 -3 lines

Update mlterm to 3.1.8.

Changes per doc/en/ReleaseNote:

ver 3.1.8
* Support framebuffer on FreeBSD. (Experimental)
* 'key' configuration file accepts Button1 - Button5.
* Remove "conf_menu_path_1", "conf_menu_path_2", "conf_menu_path_3" and
  "button3_behavior" options which are integrated to shortcuts.
  [Migration]
  (~/.mlterm/main)        (~/.mlterm/key)
  conf_menu_path_1=... => Control+Button1="menu:..."
  conf_menu_path_2=... => Control+Button2="menu:..."
  conf_menu_path_2=... => Control+Button3="menu:..."
  button3_behavior=... => Button3="exesel:..."
* Add "set_shortcut" command to configuration protocol.
* Bug fixes:
  Fix the bug of DECCRA.
  Fix the bug which broke input string of "ExecCmd" field of the connection dialog in win32.
  Fix the bug which didn't redraw a part of full-width characters when window is exposed.
  Enable to change "vertical_mode" option dynamically in framebuffer.

# $NetBSD: Makefile,v 1.81 2013/03/10 16:12:57 tsutsui Exp $

DISTNAME=	mlterm-3.1.8
CATEGORIES=	x11
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=mlterm/}

MAINTAINER=	uebayasi@NetBSD.org
HOMEPAGE=	http://mlterm.sourceforge.net/
COMMENT=	Multilingual terminal emulator
LICENSE=	modified-bsd

MAKE_JOBS_SAFE=		no

# CODESET is only supported on NetBSD in 1.5T and later - see <langinfo.h>
NOT_FOR_PLATFORM=	NetBSD-1.[0-4]*-* NetBSD-1.5[A-S]-*

USE_TOOLS+=		pkg-config msgfmt
USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
USE_PKGLOCALEDIR=	yes

PKG_SYSCONFSUBDIR=	mlterm
EGDIR=			${PREFIX}/share/examples/mlterm
.for f in aafont color font key main menu taafont termcap tfont vaafont vfont \
	xim
CONF_FILES+=		${EGDIR}/${f} ${PKG_SYSCONFDIR}/${f}
.endfor

CONFIGURE_ARGS+=	--with-imagelib=gdk-pixbuf
CONFIGURE_ARGS+=	--without-libiconv-prefix
CONFIGURE_ARGS+=	--without-libintl-prefix
CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFBASEDIR}

INSTALL_MAKE_FLAGS+=	sysconfdir=${PREFIX}/share/examples

.include "options.mk"

SUBST_CLASSES+=		link
SUBST_MESSAGE.link=	Fixing hardcoded paths and link options.
SUBST_STAGE.link=	post-patch
SUBST_FILES.link=	Makefile.in */Makefile.in */*/Makefile.in \
			*/*/*/Makefile.in man/mlterm.1
SUBST_SED.link=		-e 's|(LIBTOOL_LINK).*(LIBS)|& ${X11_LDFLAGS:M*:Q}|g'
SUBST_SED.link+=	-e 's|(LIBTOOL_LINK).*(LIBDIR)|& ${X11_LDFLAGS:M*:Q}|g'
SUBST_SED.link+=	-e 's|/usr/local/|${PREFIX}/|g'
SUBST_SED.link+=	-e 's|/usr/X11R7/|${X11BASE}/|g'

BUILDLINK_DEPMETHOD.libXt?=	build

.include "../../converters/libiconv/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../graphics/gdk-pixbuf2/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../x11/libSM/buildlink3.mk"
.include "../../x11/libX11/buildlink3.mk"
.include "../../x11/libXt/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"