[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / mate-panel

File: [cvs.NetBSD.org] / pkgsrc / x11 / mate-panel / Makefile (download)

Revision 1.40, Sun May 2 10:24:53 2021 UTC (2 years, 7 months ago) by nia
Branch: MAIN
Changes since 1.39: +1 -2 lines

*: Use the tools framework for itstool

Now it should be more obvious when a package needs it as a dependency,
as it will fail loudly if it isn't declared as a tool.

While here, some duplicate dependencies on itstool were removed from the
MATE packages

# $NetBSD: Makefile,v 1.40 2021/05/02 10:24:53 nia Exp $

PYTHON_VERSIONS_ACCEPTED=	27
PKGREVISION= 2
.include "../../meta-pkgs/mate/Makefile.common"

DISTNAME=	mate-panel-${VERSION:R}.1
CATEGORIES=	x11

COMMENT=	MATE panel application

TOOL_DEPENDS+=		libxml2-[0-9]*:../../textproc/libxml2 # for xmllint

PKGCONFIG_OVERRIDE+=	libmate-panel-applet/libmatepanelapplet-4.0.pc.in

CONFIGURE_ARGS+=	--with-in-process-applets=all

PYTHON_FOR_BUILD_ONLY=	yes
.include "../../lang/python/tool.mk"

.include "options.mk"

.include "../../devel/glib2/schemas.mk"
.include "../../sysutils/desktop-file-utils/desktopdb.mk"
.include "../../misc/libmateweather/buildlink3.mk"
.include "../../x11/mate-desktop/buildlink3.mk"
.include "../../x11/mate-menus/buildlink3.mk"
.include "../../audio/libcanberra/buildlink3.mk"
.include "../../devel/dconf/buildlink3.mk"
.include "../../devel/glib2/buildlink3.mk"
# The PLIST generated by this package varies, depending on the version
# of libwnck3 it's built against. Newer versions of libwnck3 offer
# window previewing functionality that mate-panel conditionally detects
# and uses, if available, which installs an extra config file.
BUILDLINK_API_DEPENDS.libwnck3+= libwnck3>=3.32.0
.include "../../devel/libwnck3/buildlink3.mk"
.include "../../graphics/librsvg/buildlink3.mk"
.include "../../graphics/hicolor-icon-theme/buildlink3.mk"
.include "../../sysutils/dbus-glib/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"