[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / libxcb

Annotation of pkgsrc/x11/libxcb/Makefile, Revision 1.1.1.1

1.1       drochner    1: # $NetBSD$
                      2: #
                      3:
                      4: DISTNAME=      libxcb-1.1.93
                      5: CATEGORIES=    x11
                      6: MASTER_SITES=  http://xcb.freedesktop.org/dist/
                      7: EXTRACT_SUFX=  .tar.bz2
                      8:
                      9: MAINTAINER=    reed@reedmedia.net
                     10: HOMEPAGE=      http://xcb.freedesktop.org/
                     11: COMMENT=       X protocol C-language Binding
                     12:
                     13: PKG_DESTDIR_SUPPORT=   user-destdir
                     14:
                     15: BUILD_DEPENDS+=                libxslt>=1.1.0:../../textproc/libxslt
                     16:
                     17: GNU_CONFIGURE= yes
                     18: USE_LIBTOOL=   yes
                     19: USE_TOOLS+=    pkg-config automake
                     20:
                     21: CONFIGURE_ARGS+=       --disable-build-docs    # or needs doxygen
                     22: CONFIGURE_ARGS+=       --disable-doxygen
                     23:
                     24: # Adds -Wl,-R to pkgconfig files automatically
                     25: PKGCONFIG_OVERRIDE+=   xcb-composite.pc.in
                     26: PKGCONFIG_OVERRIDE+=   xcb-damage.pc.in
                     27: PKGCONFIG_OVERRIDE+=   xcb-dpms.pc.in
                     28: PKGCONFIG_OVERRIDE+=   xcb-glx.pc.in
                     29: PKGCONFIG_OVERRIDE+=   xcb-randr.pc.in
                     30: PKGCONFIG_OVERRIDE+=   xcb-record.pc.in
                     31: PKGCONFIG_OVERRIDE+=   xcb-render.pc.in
                     32: PKGCONFIG_OVERRIDE+=   xcb-res.pc.in
                     33: PKGCONFIG_OVERRIDE+=   xcb-screensaver.pc.in
                     34: PKGCONFIG_OVERRIDE+=   xcb-shape.pc.in
                     35: PKGCONFIG_OVERRIDE+=   xcb-shm.pc.in
                     36: PKGCONFIG_OVERRIDE+=   xcb-sync.pc.in
                     37: PKGCONFIG_OVERRIDE+=   xcb-xevie.pc.in
                     38: PKGCONFIG_OVERRIDE+=   xcb-xf86dri.pc.in
                     39: PKGCONFIG_OVERRIDE+=   xcb-xfixes.pc.in
                     40: PKGCONFIG_OVERRIDE+=   xcb-xinerama.pc.in
                     41: PKGCONFIG_OVERRIDE+=   xcb-xprint.pc.in
                     42: PKGCONFIG_OVERRIDE+=   xcb-xtest.pc.in
                     43: PKGCONFIG_OVERRIDE+=   xcb-xv.pc.in
                     44: PKGCONFIG_OVERRIDE+=   xcb-xvmc.pc.in
                     45: PKGCONFIG_OVERRIDE+=   xcb.pc.in
                     46:
                     47: # libXdmcp is optional; adds support for XDM-AUTHORIZATION-1 in
                     48: # addition to MIT-MAGIC-COOKIE-1.
                     49:
                     50: BUILDLINK_API_DEPENDS.xcb-proto+=      xcb-proto>=1.1
                     51:
                     52: .include "../../mk/pthread.buildlink3.mk"
                     53:
                     54: ###
                     55: ### XXX Adding this here for redundancy--it very well may not be necessary.
                     56: ###    However, I don't think it could hurt much.  We don't include
                     57: ###    PTHREAD_CFLAGS because it could be -pthread.  My intention here
                     58: ###    is mainly to pass down the appropriate flags should something
                     59: ###    go awry.
                     60: ###
                     61: XTHREADLIB=${${PTHREAD_LDFLAGS} ${PTHREAD_LIBS}:L:M*}
                     62:
                     63: .if empty(PTHREAD_CPPFLAGS)
                     64: XTHREAD_CFLAGS=        -D_REENTRANT            # XXX Is this OK?
                     65: .else
                     66: XTHREAD_CPPFLAGS=      ${PTHREAD_CPPFLAGS}
                     67: .endif
                     68:
                     69: SUBST_CLASSES+=                pc
                     70: SUBST_FILES.pc=                xcb.pc.in
                     71: SUBST_MESSAGE.pc=      Configuring threading in xcb.pc.in.
                     72: SUBST_STAGE.pc=                pre-configure
                     73: SUBST_VARS.pc=         XTHREADLIB XTHREAD_CPPFLAGS
                     74:
                     75: pre-configure:
                     76:        cd ${WRKSRC} && autoreconf -v -i -f
                     77:
                     78: ###
                     79: ### XXX needed to build from scratch, but we're patching right now
                     80: ###    so it's not needed (nor should it ever be, really).
                     81: ###
                     82: #.include "../../devel/gperf/buildlink3.mk"
                     83: .include "../../x11/xcb-proto/buildlink3.mk"
                     84: .include "../../x11/libXdmcp/buildlink3.mk"
                     85: .include "../../x11/libXau/buildlink3.mk"
                     86:
                     87: .include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>