File:  [cvs.NetBSD.org] / pkgsrc / x11 / libunique / Makefile
Revision 1.53: download - view: text, annotated - select for diffs
Tue Nov 14 14:03:14 2023 UTC (17 months, 1 week ago) by wiz
Branches: MAIN
CVS tags: pkgsrc-2024Q1-base, pkgsrc-2024Q1, pkgsrc-2023Q4-base, pkgsrc-2023Q4, HEAD
*: recursive bump for cairo dependency changes

# $NetBSD: Makefile,v 1.53 2023/11/14 14:03:14 wiz Exp $

DISTNAME=	libunique-1.1.6
PKGREVISION=	38
CATEGORIES=	devel
MASTER_SITES=	${MASTER_SITE_GNOME:=sources/libunique/1.1/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://wiki.gnome.org/Attic/LibUnique
COMMENT=	Library for writing single instance applications (deprecated)
LICENSE=	gnu-lgpl-v2.1

GNU_CONFIGURE=		yes
USE_LIBTOOL=		yes
USE_TOOLS+=		pkg-config gmake

PKGCONFIG_OVERRIDE+=	unique.pc.in

BUILDLINK_TRANSFORM+=	rm:-Werror

# Workaround for Upstream Bug#562310.
# for more detail, see also PR#41475.
TOOLS_NOOP+=	gtkdoc-rebase

SUBST_CLASSES+=		g_const
SUBST_STAGE.g_const=	post-configure
SUBST_MESSAGE.g_const=	Replace deprecated G_CONST_RETURN with plain "const".
SUBST_FILES.g_const=	unique/uniqueapp.c
SUBST_FILES.g_const+=	unique/uniquebackend.c
SUBST_FILES.g_const+=	unique/uniquebackend.h
SUBST_FILES.g_const+=	unique/uniqueinternals.h
SUBST_FILES.g_const+=	unique/uniquemessage.c
SUBST_FILES.g_const+=	unique/uniquemessage.h
SUBST_SED.g_const=	-e 's/G_CONST_RETURN /const /g'

.include "../../mk/compiler.mk"

.if !empty(PKGSRC_COMPILER:Mclang)
CFLAGS+=	-Wno-tautological-compare
.endif

.include "options.mk"

.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>