[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / libX11

File: [cvs.NetBSD.org] / pkgsrc / x11 / libX11 / Makefile (download)

Revision 1.15, Thu Jul 24 01:07:31 2008 UTC (15 years, 9 months ago) by bjs
Branch: MAIN
CVS Tags: cube-native-xorg-base, cube-native-xorg
Changes since 1.14: +2 -2 lines


Properly define XTHREAD_CFLAGS/XTHREADLIB on NetBSD:  We do not
want -pthread in XTHREAD_CFLAGS, as this will end up linking everything
against libpthread.  Thus, in keeping with our gcc specfile, define
_REENTRANT in XTHREAD_CFLAGS instead.  XTHREADLIB is now
-pthread, not -lpthread.

While here, update to head of libX11-1.1 branch in GIT (with the
exception of some unicode changes which caused mkpatches to choke).

changes:

 - IM: Respect XMODIFIERS for Thai locale (bug #15719)
 - Bug #15884: Remove useless sleep()'s from the connection code.
 - NLS: Make UTF-8 the default for Russian
 - ConnDis: properly cast 'addr' before accessing it as a byte array.
 - added error check in Xcms color file parser; closes bug #15305
 - Fix missing error condition in cmsColNm.c, also.

Bump PKGREVISION.

# $NetBSD: Makefile,v 1.15 2008/07/24 01:07:31 bjs Exp $
#

DISTNAME=		libX11-1.1.4
PKGREVISION=		2
CATEGORIES=		x11 devel
MASTER_SITES=		${MASTER_SITE_XORG:=lib/}
EXTRACT_SUFX=		.tar.bz2

MAINTAINER=		joerg@NetBSD.org
HOMEPAGE=		http://xorg.freedesktop.org/
COMMENT=		Base X libraries from modular Xorg X11

PKG_INSTALLATION_TYPES=	overwrite pkgviews
PKG_DESTDIR_SUPPORT=	user-destdir

MAKE_JOBS_SAFE=		no

USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes
USE_TOOLS+=		gmake pkg-config

CONFIGURE_ARGS+=	--enable-man-pages=3
CONFIGURE_ARGS+=	--without-xcb
PKGCONFIG_OVERRIDE+=	x11.pc.in

.include "../../mk/bsd.prefs.mk"

.if ${OPSYS} == "NetBSD"
CONFIGURE_ARGS+=	--disable-malloc0returnsnull
.endif

.if !empty(USE_CROSS_COMPILE:M[yY][eE][sS])
MAKE_ENV+=	CC_FOR_BUILD=${NATIVE_CC:Q} CPPFLAGS_FOR_BUILD=-I${PREFIX}/include
.endif

CPPFLAGS.OSF1+=		-pthread # Required by compiler if including pthread.h

.include "../../mk/compiler.mk"
.if !empty(PKGSRC_COMPILER:Mhp)
CONFIGURE_ENV+=		ac_cv_path_RAWCPP="cc -E -Uunix -"
.endif

.include "../../x11/bigreqsproto/buildlink3.mk"
.include "../../x11/inputproto/buildlink3.mk"
.include "../../x11/kbproto/buildlink3.mk"
.include "../../x11/libXau/buildlink3.mk"
.include "../../x11/libXdmcp/buildlink3.mk"
.include "../../x11/xcmiscproto/buildlink3.mk"
.include "../../x11/xextproto/buildlink3.mk"
.include "../../x11/xf86bigfontproto/buildlink3.mk"
.include "../../x11/xproto/buildlink3.mk"
.include "../../x11/xtrans/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"