# $NetBSD: Makefile,v 1.73 2013/01/26 21:36:55 adam Exp $
#
DISTNAME= lablgtk-2.16.0
PKGREVISION= 6
CATEGORIES= x11
MASTER_SITES= http://forge.ocamlcore.org/frs/download.php/979/
MAINTAINER= jaapb@NetBSD.org
HOMEPAGE= http://lablgtk.forge.ocamlcore.org/
COMMENT= GTK+ 2.x bindings for Objective Caml
# for installed files; more restrictions on applications/
LICENSE= gnu-lgpl-v2
GNU_CONFIGURE= yes
USE_TOOLS+= gmake pkg-config
MAKE_JOBS_SAFE= no
BUILD_TARGET= world
BUILDLINK_DEPMETHOD.ocaml= full
CONFLICTS= lablgtk2-2.*{,nb*}
.include "../../mk/bsd.prefs.mk"
# Stub libraries for functions missing from base system.
PLIST_VARS+= stubs opt
.if ${OPSYS} == "Darwin" || ${OPSYS} == "DragonFly" || \
${OPSYS} == "NetBSD" || ${OPSYS} == "FreeBSD" || \
${OPSYS} == "SunOS" || ${OPSYS} == "Linux"
PLIST.stubs= yes
.endif
.if (${MACHINE_ARCH} == "i386") || (${MACHINE_ARCH} == "powerpc") || \
(${MACHINE_ARCH} == "sparc") || (${MACHINE_ARCH} == "x86_64")
PLIST.opt= yes
.endif
.include "options.mk"
INSTALLATION_DIRS+= lib/ocaml/site-lib
.include "../../lang/ocaml/buildlink3.mk"
.include "../../devel/ocaml-findlib/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"
CVSweb <webmaster@jp.NetBSD.org>