[BACK]Return to PLIST CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / kdesignerplugin

File: [cvs.NetBSD.org] / pkgsrc / x11 / kdesignerplugin / PLIST (download)

Revision 1.6, Mon Nov 11 09:21:39 2019 UTC (4 years, 4 months ago) by markd
Branch: MAIN
CVS Tags: pkgsrc-2020Q1-base, pkgsrc-2020Q1, pkgsrc-2019Q4-base, pkgsrc-2019Q4
Changes since 1.5: +1 -33 lines

KDE Frameworks update to 5.64.0

5.62.0

KActivitiesStats
  Add Term::Type::files() and Term::Type::directories() to filter only
  directories or excluding them
  Add @since 5.62 for newly added setters
  Add proper logging using ECMQtDeclareLoggingCategory
  Add setter to Type, Activity, Agent and UrlFilter query fields
  Use special values constants in terms.cpp
  Allow date range filtering of resource events using Date Term

KActivities
  [kactivities] Use new activities icon

KConfigWidgets
  Add option to build Qt Designer plugin (BUILD_DESIGNERPLUGIN, default ON)
  [KColorSchemeManager] Optimize preview generation

KDesignerPlugin
  Deprecate kgendesignerplugin, drop bundle plugim for all KF5 widgets

Kirigami
  Replace the custom overflow button with PrivateActionToolButton in
  ActionToolBar
  If a submenu action has an icon set, make sure to also display it
  [Separator] Match Breeze borders' color
  Add Kirigami ListSectionHeader component
  Fix context menu button for pages not showing up
  Fix PrivateActionToolButton with menu not clearing checked state properly
  allow to set custom icon for the left drawer handle
  Rework the visibleActions logic in SwipeListItem
  Allow usage of QQC2 actions on Kirigami components and now make K.Action
  based on QQC2.Action
  Kirigami.Icon: Fix loading bigger images when source is a URL
  Add icon used by Kirigami.AboutPage

KItemViews
  Add option to build Qt Designer plugin (BUILD_DESIGNERPLUGIN, default ON)

KTextWidgets
  Add option to build Qt Designer plugin (BUILD_DESIGNERPLUGIN, default ON)

KWidgetsAddons
  [KMessageWidget] Pass widget to standardIcon()
  Add option to build Qt Designer plugin (BUILD_DESIGNERPLUGIN, default ON)

KWindowSystem
  KWindowSystem: add cmake option KWINDOWSYSTEM_NO_WIDGETS
  Deprecate slideWindow(QWidget *widget)
  Add KWindowSystem::setMainWindow(QWindow *) overload
  KWindowSystem: add setNewStartupId(QWindow *...) overload

KXMLGUI
  Add option to build Qt Designer plugin (BUILD_DESIGNERPLUGIN, default ON)

Plasma Framework
  Make notification icons use outline style
  make the sizing of the toolbuttons more coherent
  Allow applets/containments/wallpaper to defer UIReadyConstraint
  Make notification icons look like bells
  Fix incorrect initial tabs position for vertical tab bars

QQC2StyleBridge
  Prevent dragging QQC2 ComboBox contents outside menu

5.63.0

Framework Integration
  ensure winId() not called on non-native widgets

KConfigWidgets
  Make KColorScheme compatible with QVariant

KDELibs 4 Support
  Support NetworkManager 1.20 and do actually compile the NM backend

Kirigami
  always cache just the last item
  more z
  fix import version in PagePoolAction
  PagePool is Kirigami 2.11
  take into account dragging speed when a flick ends
  Fix copying urls to the clipboard
  check more if we are reparenting an actual Item
  basic support for ListItem actions
  introduce cachePages
  fix compatibility with Qt5.11
  introduce PagePoolAction
  new class: PagePool to manage recycling of pages after they're popped
  make tabbars look better
  some margin on the right
  Revert "Compensate smaller icon sizes on mobile in the ActionButton"
  don't make list items look inactive
  Revert "Remove scaling of iconsize unit for isMobile"
  Layout.fillWidth should be done by the client
  Add template for Kirigami application development
  Add a mode to center actions and omit the title when using a ToolBar style
  Compensate smaller icon sizes on mobile in the ActionButton
  Fixed some undefined properties runtime errors
  Fix ListSectionHeader background color for some color schemes
  Remove custom content item from ActionMenu separator

KItemViews
  [KItemViews] Port to non-deprecated QWheelEvent API

KJobWidgets
  cleanup dbus related objects early enough to avoid hang on program exit

KWidgetsAddons
  Make OK button configurable in KMessageBox::sorry/detailedSorry
  [KCollapsibleGroupBox] Fix QTimeLine::start warning at runtime
  Improve naming of KTitleWidget icon methods
  Add QIcon setters for the password dialogs
  [KWidgetAddons] port to non-deprecated Qt API

KWindowSystem
  Set XCB to required if building the X backend
  Make less use of deprecated enum alias NET::StaysOnTop

KXMLGUI
  Move "Full Screen Mode" item from Settings menu to View menu

Plasma Framework
  Export Plasma core lib log category, add a category to a qWarning
  [pluginloader] Use categorized logging
  make editMode a corona global property
  Honor global animation speed factor
  properly install whole plasmacomponent3
  [Dialog] Apply window type after changing flags
  Change reveal password button logic
  Fix crash on teardown with Applet's ConfigLoader

QQC2StyleBridge
  Fix several build system errors
  take margins from qstyle
  [Tab] Fix sizing

5.64.0

Framework Integration
  Add standard icons to support to all entries in QDialogButtonBox
  ensure winId() not called on non-native widgets

KActivitiesStats
  tests: fix macos build failure
  Windows MSVC compile fix
  Add a utility accessor to get a QUrl from a ResultSet::Result

KConfigWidgets
  Avoid overloading KCModule::changed

KDELibs 4 Support
  KLocale api docs: make it easier to find how to port code away from it

Kirigami
  Ensure that GlobalDrawer topContent always stays on top
  highlight on mouseover only when mode than one page
  Rename Okular Active to Okular Mobile
  items have active focus on tab when they aren't in a view
  Allow contextualActions to flow into the header toolbar
  Fix incorrect Credits model for Kirigami.AboutPage
  Don't show context drawer if all actions are invisible
  Fix Kirigami template image
  keep containers devoid of deleted items
  limit size of the drag margins
  Fix showing menu toolbutton when no drawer is available
  Disable dragging global drawer when in menu mode
  Show menu items tooltip text
  Do not warn about LayoutDirection in SearchField
  Properly check enabled state of Action for ActionToolBar buttons
  Use MenuItem's action property directly in ActionMenuItem
  Allow the global drawer to become a menu if desired
  Be more explicit about action property types

KItemViews
  [RFC] Unify style of new Kirigami.ListSectionHeader and CategoryDrawer

KTextWidgets
  Remove call to no longer needed KIconTheme::assignIconsToContextMenu

KXMLGUI
  fix default shortcut detection

Plasma Framework
  map disabledTextColor to ColorScope
  add DisabledTextColor to Theme
  [PC3/button] Elide text always
  Improve panel options menu entries
  [icons/media.svg] Add 16 & 32px icons, update style
  [PlasmaComponents3] Fix checkable toolbutton background

QQC2StyleBridge
  Do not assign combobox currentIndex as it breaks binding
  Listen to the application style changing

@comment $NetBSD: PLIST,v 1.6 2019/11/11 09:21:39 markd Exp $
bin/kgendesignerplugin
lib/cmake/KF5DesignerPlugin/KF5DesignerPluginConfig.cmake
lib/cmake/KF5DesignerPlugin/KF5DesignerPluginConfigVersion.cmake
lib/cmake/KF5DesignerPlugin/KF5DesignerPluginMacros.cmake
lib/cmake/KF5DesignerPlugin/KF5DesignerPluginTargets-noconfig.cmake
lib/cmake/KF5DesignerPlugin/KF5DesignerPluginTargets.cmake
man/ca/man1/kgendesignerplugin.1
man/de/man1/kgendesignerplugin.1
man/it/man1/kgendesignerplugin.1
man/man1/kgendesignerplugin.1
man/nl/man1/kgendesignerplugin.1
man/pt/man1/kgendesignerplugin.1
man/pt_BR/man1/kgendesignerplugin.1
man/sv/man1/kgendesignerplugin.1
man/uk/man1/kgendesignerplugin.1
share/locale/af/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ar/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/as/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/be/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/be@latin/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/bg/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/bn/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/bn_IN/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/br/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/bs/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ca/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ca@valencia/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/crh/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/cs/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/csb/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/cy/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/da/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/de/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/el/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/en_GB/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/eo/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/es/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/et/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/eu/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/fa/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/fi/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/fr/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/fy/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ga/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/gd/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/gl/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/gu/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ha/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/he/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/hi/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/hne/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/hr/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/hsb/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/hu/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/hy/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ia/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/id/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/is/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/it/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ja/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ka/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/kk/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/km/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/kn/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ko/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ku/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/lb/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/lt/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/lv/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/mai/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/mk/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ml/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/mr/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ms/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/nb/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/nds/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ne/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/nl/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/nn/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/oc/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/or/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/pa/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/pl/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ps/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/pt/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/pt_BR/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ro/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ru/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/se/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/si/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/sk/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/sl/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/sq/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/sr/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/sr@ijekavian/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/sr@ijekavianlatin/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/sr@latin/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/sv/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ta/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/te/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/tg/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/th/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/tr/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/tt/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/ug/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/uk/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/uz/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/uz@cyrillic/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/vi/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/wa/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/xh/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/zh_CN/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/zh_HK/LC_MESSAGES/kdesignerplugin5_qt.qm
share/locale/zh_TW/LC_MESSAGES/kdesignerplugin5_qt.qm