The NetBSD Project

CVS log for pkgsrc/x11/gtk4/Makefile

[BACK] Up to [cvs.NetBSD.org] / pkgsrc / x11 / gtk4

Request diff between arbitrary revisions


Default branch: MAIN
Current tag: pkgsrc-2022Q3-base


Revision 1.16 / (download) - annotate - [select for diffs], Sat Sep 10 09:47:52 2022 UTC (18 months, 2 weeks ago) by wiz
Branch: MAIN
CVS Tags: pkgsrc-2022Q3-base, pkgsrc-2022Q3
Changes since 1.15: +2 -3 lines
Diff to previous 1.15 (colored)

gtk4: update to 4.8.0.

Overview of Changes in 4.8.0, 06-09-2022
========================================

* GtkTreeView:
 - Fix a problem with scrolling animations
 - Fix some event handling problems
 - Drop unreachable code

* GtkText:
 - Respect the no-emoji input hint fully

* GtkEmojiChooser:
 - Fix arrow key navigation

* GtkFontChooser:
 - Improve the handling of OpenType font features

* GtkTreeListModel:
 - Fix handling of collapsed child nodes

* GtkInscription:
 - Fix accessible name

* Theme:
 - Fix placeholder text in HighContrast

* Increase the memory limit for the jpeg loader to 300M

* Miscellaneous memory leak fixes

* Wayland:
 - Refactor handling of text protocol client updates

* Windows:
 - Support high-resolution scroll wheel events
 - Generate GdkWin32.gir
 - Implement color picking

Overview of Changes in 4.7.2, 10-08-2022
========================================

* GtkTextView:
 - Fix child positioning with gutters

* GtkText:
 - Update placeholder visibility when necessary

* GtkPicture:
 - Add a content-fit property

* GtkPopover:
 - Fix a size allocation problem with the arrow

* GtkTreeView:
 - Fix a problem with DND

* GtkTreePopover:
 - Support scrolling

* GtkGridView:
 - Fix issues with rubberband selection

* GtkLabel:
 - Add a tabs property

* GtkSnapshot:
 - Make GtkSnapshot work from bindings

* GtkScrolledWindow:
 - Scroll at a reasonable speed

* GtkPaned:
 - Avoid an infinite loop

* GtkWindow:
 - Improve generation and handling of crossing events

* CSS:
 - Fix handling of certain transform values

* Media support:
 - Add audio support to the ffmpeg backend
 - Avoid oom with pathological jpeg images

* GDK:
 - Fix handling of touchpad hold events
 - Add support for hi-resolution scroll events

* X11:
 - Fix preferred action for DND

* Windows:
 - Fix DND

* List models:
 - Fix items-changed emission
 - Add more list model tests

* Demos:
 - Add a winning sound to game demos
 - Make app icons work uninstalled

Overview of Changes in 4.7.1, 12-07-2022
========================================

* GtkInscription:
 - A new label-like widget for use in list views

* GtkColorChooser:
 - Style improvements

* GtkFontChooser:
 - Improve support for OpenType features a bit

* GtkLabel:
 - Allow selectable labels to be activated via mnemonic

* GtkTextView:
 - Implement GetCharacterExtents for accessibility

* GtkStack:
 - Fix a poblem with stack page accessibility

* GtkListView:
 - Cull listitems that are out of view
 - Make all our list models implement ::n-items and
   ::item-type properties

* Translations:
 - Stop translating property nicks and blurbs
 - Fix extracting translations from ui files

* Debugging:
 - Support GTK_DEBUG=invert-text-dir
 - Allow inspecting inspectors
 - Replace GTK_USE_PORTAL with GDK_DEBUG=portals
 - Improve responsiveness of the inspector

* CSS:
 - Allow fractional letterspacing

* Theme:
 - Improve legibility of selectable labels

* Demos:
 - Improve the font features demo
 - Add demos for GtkInscription

* Wayland:
 - Freeze popups when hidden
 - Only send smooth scroll events for tablet tools
 - Make scaled cursor image have the right size
 - Fix problems with the activation protocol
 - Don't force the HighContrast icon theme
 - Support xdg_toplevel.bounds

* X11:
 - Always update the shadoe size

* Windows:
 - Improve touchpad support by using DirectManipulation
 - Add more directories to the builtin hicolor icon theme


Overview of Changes in 4.7.0, 07-05-2022
========================================

* GtkTextView:
 - Reduce overdraws

* GtkViewport:
 - Default scroll-to-focus to TRUE

* GtkText:
 - Stop blinking when we lose focus

* GtkSearchEntry:
 - Make search delay configurable

* GtkPopoverMenu:
 - Fix RTL positioning of buttons

* GtkLabel:
 - Fix focus keynav with links

* GtkFileChooser:
 - Prevent undesirable completion popups
 - Fix a corner case in save mode
 - Keep the portal filechooser alive long enough

* GtkCheckButton:
 - Allow setting a custom child

* GtkEditableLabel:
 - Make the :editing property writable

* GtkColumnView:
 - Various optimizations to improve scrolling performance

* GtkTreeStore:
 - Allow populating tree stores from ui files

* GtkBoxLayout:
 - Avoid infinite loops

* CSS:
 - Optimize reordering within the same parent

* Emoji:
 - Update to CLDR v40 / Unicode 14
 - Add more locales

* Input:
 - Add scroll unit handling
 - Handle display changes in GtkIMMultiContext
 - Always populate GDK_AXIS_X/Y in event history
 - Don't crash for large compose tables

* Accessibility:
 - Fix a crash at start when orca is running

* Theme:
 - Refresh icons
 - Fix selection in vertical spin buttons
 - Fix selection in editable labels

* gdk:
 - Optimize pixel format conversions
 - Use EGL_KHR_swap_buffers_with_damage for NVidia

* gsk:
 - Handle large viewports
 - Prepare texture libraries for glyphy rendering
 - Don't leak big glyphs in the glyph cache
 - Align offscreen rendering with th pixel grid
 - Check for half-float support before using it

* Wayland:
 - Use xdg-activation protocol
 - Fix text caret coordinates
 - Fix on-screen keyboard activation

* MacOS:
 - Fix sluggish and reversed scrolling
 - Improve monitor detection
 - Event handling fixes
 - Fix keyboard input on popovers
 - Support OpenGL-based video playback
 - Suport fullscreen
 - Improve native filechoooser size allocation
 - Use CALayer and IOSurface for rendering
 - Use a per-monitor CVDisplayLink
 - Fix kinetic scrolling
 - Improve window placement
 - Improve multi-monitor handling
 - Start applications in the foreground
 - Fix cursor blink time

* Windows:
 - Fix preedit window placement on HiDPI

* Tools:
 - gtk4-builder-tool: Don't require a display for all commands
 - gtk4-builder-tool: Add a screenshot command
 - gtk4-node-editor: Install this utility

* Debugging:
 - inspector: Show more application data
 - inspector: Allow viewing PangoAttrList properties

* Documentation:
 - Use the gtk-builder-tool to generate screenshots

* Build:
 - Fix cross-compilation
 - Fix build on aarch64
 - Fix build with gcc 12

This form allows you to request diff's between any two revisions of a file. You may select a symbolic revision name using the selection box or you may type in a numeric name using the type-in text box.




CVSweb <webmaster@jp.NetBSD.org>