[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / gnustep-preferences

File: [cvs.NetBSD.org] / pkgsrc / x11 / gnustep-preferences / Attic / Makefile (download)

Revision 1.48, Sun Dec 4 05:17:45 2016 UTC (7 years, 3 months ago) by ryoon
Branch: MAIN
CVS Tags: pkgsrc-2017Q1-base, pkgsrc-2017Q1, pkgsrc-2016Q4-base, pkgsrc-2016Q4
Changes since 1.47: +2 -2 lines

Recursive revbump from textproc/icu 58.1

# $NetBSD: Makefile,v 1.48 2016/12/04 05:17:45 ryoon Exp $

DISTNAME=	Preferences-1.2.0
PKGNAME=	gnustep-${DISTNAME:S/P/p/}
PKGREVISION=	29
CATEGORIES=	x11 gnustep
MASTER_SITES=	${MASTER_SITE_SOURCEFORGE:=prefsapp/}
EXTRACT_SUFX=	.tar.bz2

MAINTAINER=	adam@NetBSD.org
HOMEPAGE=	http://prefsapp.sourceforge.net/
COMMENT=	Application for setting preferences for the GNUstep system
LICENSE=	gnu-gpl-v2

USE_LANGUAGES=	objc

NO_CONFIGURE=	YES
USE_TOOLS+=	gmake
MAKE_FILE=	GNUmakefile
MAKE_JOBS_SAFE=	NO
MAKE_FLAGS+=	GNUSTEP_USER_DIR=${WRKDIR}/fake_home/GNUstep

FIX_GNUSTEP_INSTALLATION_DIR= yes
SUBST_FILES.gnustep_installation_dir+=	GNUmakefile.preamble
SUBST_FILES.gnustep_installation_dir+=	PrefsModule/GNUmakefile.preamble
SUBST_FILES.gnustep_installation_dir+=	Modules/Keyboard/GNUmakefile
SUBST_SED.gnustep_installation_dir+=	-e 's|\$$(GNUSTEP_SYSTEM_ROOT)/Library/Preferences|$${DESTDIR}${GNUSTEP_LIB_DIR}/Preferences|'

.include "../../mk/compiler.mk"

.if !empty(PKGSRC_COMPILER:Mclang)
_WRAP_EXTRA_ARGS.CC+=	-Wno-unused-const-variable
CWRAPPERS_APPEND.cc+=	-Wno-unused-const-variable
.endif

.include "../../x11/gnustep-back/buildlink3.mk"
.include "../../mk/pthread.buildlink3.mk"
.include "../../mk/bsd.pkg.mk"