[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / gnopernicus

File: [cvs.NetBSD.org] / pkgsrc / x11 / gnopernicus / Attic / Makefile (download)

Revision 1.13, Thu Apr 1 19:04:27 2004 UTC (20 years ago) by jmmv
Branch: MAIN
Changes since 1.12: +3 -4 lines

Update to 0.8.1:

Changes in 0.8.1
================

Translation:

    Update Basque, Arabic, Greek, Welsh and British translations.

Changes in 0.8.0
================

Translation:

    Update translations for Ukrainian, German, Arabic, Italian, Mongolian,
    Greek, Canadian English.

Changes in 0.7.6
================

Miscellanous
    * Report caret-moved events for non-focused objects.

UI:
    * Notify user when he moves to a new table.

Changes in 0.7.5
================

Miscellanous
    * Filter events for watched object.

UI:
    * add a function to unwatch all watched objects.
    * better presentation for tables.

Changes in 0.7.4
================
Presentation
    * Store presentation items in XML files, not not in gconf keys.

UI
    * Map shutup function on control-left key.

Changes in 0.7.3
================
Braille
    *  Support for devices created by HandyTech.

UI
    * Possibility to add a watch a specified object (to receive all event for
    that object).

GUI
    * Add option to permite a crosswire on without a cursor when the
    magnifier is active.
    * Presentation is now a collection of predefined profiles.

Miscellanous
    * Made non-case sensitive a braille device command line value.

Changes in 0.7.2
================

Magnifier:
    * Make sure that the coordinates are set ok in case of a change of
      resolution.
    * Zoomer's coordinates are from (0,0) to (x-display-size - 1,y-display-size - 1)
      (not from (1,1) to (x-display-size, y-display-size) as before)

# $NetBSD: Makefile,v 1.13 2004/04/01 19:04:27 jmmv Exp $
#

DISTNAME=		gnopernicus-0.8.1
CATEGORIES=		x11
MASTER_SITES=		${MASTER_SITE_GNOME:=sources/gnopernicus/0.8/}
EXTRACT_SUFX=		.tar.bz2

MAINTAINER=		xtraeme@NetBSD.org
HOMEPAGE=		http://www.gnome.org/
COMMENT=		Collection of accessibility apps for GNOME 2

BUILD_USES_MSGFMT=	yes
DEPENDS=		gnome2-dirs>=1.5:../../misc/gnome2-dirs

USE_BUILDLINK3=		yes
USE_GNU_TOOLS+=		make
USE_PKGINSTALL=		yes
USE_PKGLOCALEDIR=	yes
USE_LIBTOOL=		yes
USE_X11=		yes
GNU_CONFIGURE=		yes

CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR}
PKG_SYSCONFSUBDIR=	gnopernicus
OWN_DIRS+=		${PKG_SYSCONFDIR}/translation_tables
EGDIR=			${PREFIX}/share/examples/gnopernicus

CONF_FILES=		${EGDIR}/translation_tables/de.a2b \
			${PKG_SYSCONFDIR}/translation_tables/de.a2b
CONF_FILES+=		${EGDIR}/translation_tables/en_US.a2b \
			${PKG_SYSCONFDIR}/translation_tables/en_US.a2b
CONF_FILES+=		${EGDIR}/translation_tables/es.a2b \
			${PKG_SYSCONFDIR}/translation_tables/es.a2b
CONF_FILES+=		${EGDIR}/translation_tables/sv.a2b \
			${PKG_SYSCONFDIR}/translation_tables/sv.a2b

.include "../../mk/bsd.prefs.mk"

BUILD_DEFS+=		USE_INET6

.if !empty(USE_INET6:M[Yy][Ee][Ss])
CONFIGURE_ARGS+=	--enable-ipv6
.else
CONFIGURE_ARGS+=	--disable-ipv6
.endif

CONFIGURE_ARGS+=	--disable-gtk-doc

PKGCONFIG_OVERRIDE+=    gnopernicus-1.0.pc.in

GCONF2_SCHEMAS+=	brlmonitor.schemas
GCONF2_SCHEMAS+=	gnopernicus.schemas
GCONF2_SCHEMAS+=	remote.schemas

.include "../../audio/gnome-speech/buildlink3.mk"
.include "../../devel/at-spi/buildlink3.mk"
.include "../../devel/GConf2/schemas.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/libgnome/buildlink3.mk"
.include "../../devel/libgnomeui/buildlink3.mk"
.include "../../devel/pkgconfig/buildlink3.mk"
.include "../../textproc/intltool/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../textproc/scrollkeeper/omf.mk"
.include "../../x11/gnome-mag/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"