File:  [cvs.NetBSD.org] / pkgsrc / x11 / gnopernicus / Attic / Makefile
Revision 1.46: download - view: text, annotated - select for diffs
Wed Jul 5 05:37:47 2006 UTC (18 years, 8 months ago) by jlam
Branches: MAIN
CVS tags: HEAD
Sweep pkgsrc and convert packages that included intltool/buildlink3.mk
to use instead "USE_TOOLS+=intltool".  Remove now unused
intltool/buildlink3.mk

# $NetBSD: Makefile,v 1.46 2006/07/05 05:37:47 jlam Exp $
#

DISTNAME=		gnopernicus-1.0.3
PKGREVISION=		1
CATEGORIES=		x11
MASTER_SITES=		${MASTER_SITE_GNOME:=sources/gnopernicus/1.0/}
EXTRACT_SUFX=		.tar.bz2

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://www.gnome.org/
COMMENT=		Collection of accessibility apps for GNOME 2

USE_DIRS+=		gnome2-1.5
USE_TOOLS+=		gmake intltool msgfmt pkg-config
USE_PKGLOCALEDIR=	yes
USE_LIBTOOL=		yes
GNU_CONFIGURE=		yes

CONFIGURE_ARGS+=	--sysconfdir=${PKG_SYSCONFDIR:Q}
CONFIGURE_ARGS+=	--with-sysconfsubdir=
PKG_SYSCONFSUBDIR=	gnopernicus
OWN_DIRS+=		${PKG_SYSCONFDIR}/translation_tables
EGDIR=			${PREFIX}/share/examples/gnopernicus

CONF_FILES=		${EGDIR}/translation_tables/de.a2b \
			${PKG_SYSCONFDIR}/translation_tables/de.a2b
CONF_FILES+=		${EGDIR}/translation_tables/en_US.a2b \
			${PKG_SYSCONFDIR}/translation_tables/en_US.a2b
CONF_FILES+=		${EGDIR}/translation_tables/es.a2b \
			${PKG_SYSCONFDIR}/translation_tables/es.a2b
CONF_FILES+=		${EGDIR}/translation_tables/sv.a2b \
			${PKG_SYSCONFDIR}/translation_tables/sv.a2b
INSTALL_MAKE_FLAGS+=	${MAKE_FLAGS}
INSTALL_MAKE_FLAGS+=	translationdir=${EGDIR}/translation_tables

PKG_OPTIONS_VAR=	PKG_OPTIONS.gnopernicus
PKG_SUPPORTED_OPTIONS=	inet6

.include "../../mk/bsd.options.mk"

.if !empty(PKG_OPTIONS:Minet6)
CONFIGURE_ARGS+=	--enable-ipv6
.else
CONFIGURE_ARGS+=	--disable-ipv6
.endif

CONFIGURE_ARGS+=	--disable-gtk-doc

PKGCONFIG_OVERRIDE+=    gnopernicus-1.0.pc.in

GCONF2_SCHEMAS+=	brlmonitor.schemas
GCONF2_SCHEMAS+=	gnopernicus.schemas
GCONF2_SCHEMAS+=	remote.schemas

BUILDLINK_API_DEPENDS.glib2+=	glib2>=2.4.1

.include "../../audio/gnome-speech/buildlink3.mk"
.include "../../devel/at-spi/buildlink3.mk"
.include "../../devel/GConf2/schemas.mk"
.include "../../devel/glib2/buildlink3.mk"
.include "../../devel/libglade2/buildlink3.mk"
.include "../../devel/libgnome/buildlink3.mk"
.include "../../devel/libgnomeui/buildlink3.mk"
.include "../../textproc/libxml2/buildlink3.mk"
.include "../../textproc/scrollkeeper/omf.mk"
.include "../../x11/gnome-mag/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>