File:  [cvs.NetBSD.org] / pkgsrc / x11 / gnome-themes / Makefile
Revision 1.48: download - view: text, annotated - select for diffs
Wed Jul 5 05:37:47 2006 UTC (18 years, 8 months ago) by jlam
Branches: MAIN
CVS tags: HEAD
Sweep pkgsrc and convert packages that included intltool/buildlink3.mk
to use instead "USE_TOOLS+=intltool".  Remove now unused
intltool/buildlink3.mk

# $NetBSD: Makefile,v 1.48 2006/07/05 05:37:47 jlam Exp $
#

DISTNAME=		gnome-themes-2.14.0
PKGREVISION=		1
CATEGORIES=		x11
MASTER_SITES=		${MASTER_SITE_GNOME:=sources/gnome-themes/2.14/}
EXTRACT_SUFX=		.tar.bz2

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://www.gnome.org/
COMMENT=		Collection of themes and icons for GNOME 2

CONFLICTS+=		clearlooks-metacity-[0-9]*

USE_DIRS+=		gnome2-1.5 theme-1.0
USE_TOOLS+=		gmake intltool msgfmt pkg-config
USE_LIBTOOL=		yes
USE_PKGLOCALEDIR=	yes
GNU_CONFIGURE=		yes

pre-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Smokey-Red
.for f in 96x96/filesystems 72x72/filesystems 64x64/filesystems \
    48x48/filesystems 48x48/emblems
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Smokey-Red/${f}
.endfor
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Smokey-Blue
.for f in 96x96/filesystems 72x72/filesystems 64x64/filesystems \
    48x48/emblems
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Smokey-Blue/${f}
.endfor
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Sandy
.for f in 96x96/filesystems 72x72/filesystems 48x48/filesystems \
    36x36/filesystems 24x24/filesystems 12x12/filesystems
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Sandy/${f}
.endfor
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/LowContrastLargePrint/48x48
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/HighContrastLargePrintInverse/48x48
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/HighContrastLargePrint/48x48
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Flat-Blue
.for f in 96x96/filesystems 72x72/filesystems 72x72/devices 48x48/filesystems \
    48x48/emblems 48x48/devices 36x36/filesystems 36x36/emblems \
    24x24/filesystems 24x24/emblems 20x20/filesystems \
    192x192/filesystems 12x12/filesystems 12x12/emblems scalable/emblems
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Flat-Blue/${f}
.endfor
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Crux
.for f in 96x96/filesystems 96x96/emblems 72x72/filesystems 72x72/emblems \
    48x48/filesystems 48x48/emblems 36x36/filesystems \
    24x24/filesystems 192x192/filesystems 12x12/filesystems
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Crux/${f}
.endfor

.include "../../devel/libgnomeui/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../wm/metacity/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../x11/gtk2-engines/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"

CVSweb <webmaster@jp.NetBSD.org>