[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / gnome-themes

File: [cvs.NetBSD.org] / pkgsrc / x11 / gnome-themes / Makefile (download)

Revision 1.43, Sat Mar 4 21:31:09 2006 UTC (17 years, 9 months ago) by jlam
Branch: MAIN
Changes since 1.42: +2 -2 lines

Point MAINTAINER to pkgsrc-users@NetBSD.org in the case where no
developer is officially maintaining the package.

The rationale for changing this from "tech-pkg" to "pkgsrc-users" is
that it implies that any user can try to maintain the package (by
submitting patches to the mailing list).  Since the folks most likely
to care about the package are the folks that want to use it or are
already using it, this would leverage the energy of users who aren't
developers.

# $NetBSD: Makefile,v 1.43 2006/03/04 21:31:09 jlam Exp $
#

DISTNAME=		gnome-themes-2.12.3
CATEGORIES=		x11
MASTER_SITES=		${MASTER_SITE_GNOME:=sources/gnome-themes/2.12/}
EXTRACT_SUFX=		.tar.bz2

MAINTAINER=		pkgsrc-users@NetBSD.org
HOMEPAGE=		http://www.gnome.org/
COMMENT=		Collection of themes and icons for GNOME 2

CONFLICTS+=		clearlooks-metacity-[0-9]*

BUILD_USES_MSGFMT=	yes

USE_DIRS+=		gnome2-1.5 theme-1.0
USE_TOOLS+=		gmake pkg-config
USE_LIBTOOL=		yes
USE_PKGLOCALEDIR=	yes
GNU_CONFIGURE=		yes

pre-install:
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Smokey-Red
.for f in 96x96/filesystems 72x72/filesystems 64x64/filesystems \
    48x48/filesystems 48x48/emblems
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Smokey-Red/${f}
.endfor
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Smokey-Blue
.for f in 96x96/filesystems 72x72/filesystems 64x64/filesystems \
    48x48/emblems
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Smokey-Blue/${f}
.endfor
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Sandy
.for f in 96x96/filesystems 72x72/filesystems 48x48/filesystems \
    36x36/filesystems 24x24/filesystems 12x12/filesystems
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Sandy/${f}
.endfor
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/LowContrastLargePrint/48x48
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/HighContrastLargePrintInverse/48x48
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/HighContrastLargePrint/48x48
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Flat-Blue
.for f in 96x96/filesystems 72x72/filesystems 72x72/devices 48x48/filesystems \
    48x48/emblems 48x48/devices 36x36/filesystems 36x36/emblems \
    24x24/filesystems 24x24/emblems 20x20/filesystems \
    192x192/filesystems 12x12/filesystems 12x12/emblems scalable/emblems
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Flat-Blue/${f}
.endfor
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Crux
.for f in 96x96/filesystems 96x96/emblems 72x72/filesystems 72x72/emblems \
    48x48/filesystems 48x48/emblems 36x36/filesystems \
    24x24/filesystems 192x192/filesystems 12x12/filesystems
	${INSTALL_DATA_DIR} ${PREFIX}/share/icons/Crux/${f}
.endfor

.include "../../devel/libgnomeui/buildlink3.mk"
.include "../../devel/gettext-lib/buildlink3.mk"
.include "../../textproc/intltool/buildlink3.mk"
.include "../../wm/metacity/buildlink3.mk"
.include "../../x11/gtk2/buildlink3.mk"
.include "../../x11/gtk2-engines/buildlink3.mk"

.include "../../mk/bsd.pkg.mk"