[BACK]Return to Makefile CVS log [TXT][DIR] Up to [cvs.NetBSD.org] / pkgsrc / x11 / gnome-sharp

File: [cvs.NetBSD.org] / pkgsrc / x11 / gnome-sharp / Attic / Makefile (download)

Revision 1.82, Wed Sep 11 11:53:40 2019 UTC (14 months, 2 weeks ago) by nia
Branch: MAIN
CVS Tags: pkgsrc-2019Q4-base, pkgsrc-2019Q4, pkgsrc-2019Q3-base, pkgsrc-2019Q3
Changes since 1.81: +2 -2 lines

Use https for mono-project.com.

# $NetBSD: Makefile,v 1.82 2019/09/11 11:53:40 nia Exp $
#

DISTNAME=	gnome-sharp-2.24.2
PKGREVISION=	58
CATEGORIES=	x11
MASTER_SITES=	${MASTER_SITE_GNOME:=sources/gnome-sharp/2.24/}

MAINTAINER=	pkgsrc-users@NetBSD.org
HOMEPAGE=	https://www.mono-project.com/GtkSharp
COMMENT=	C\# bindings for the GNOME platform
LICENSE=	gnu-lgpl-v2.1

GNU_CONFIGURE=		yes
USE_PKGLOCALEDIR=	yes
USE_LIBTOOL=		yes
USE_TOOLS+=		gmake pkg-config
MAKE_JOBS_SAFE=		no

.include "../../mk/bsd.prefs.mk"
.if ${OPSYS} == NetBSD
.  if !empty(OS_VERSION:M5.99.*) || !empty(OS_VERSION:M[6789].*)
CONFIGURE_ENV+=		EXTRACSDEFINES=-define:TIMET_IS_64BITS
.  else
CONFIGURE_ENV+=		EXTRACSDEFINES=-define:TIMET_IS_32BITS
.  endif
.endif

PKGCONFIG_OVERRIDE+=	art/art-sharp-2.0.pc.in
PKGCONFIG_OVERRIDE+=	gconf/GConf/gconf-sharp-2.0.pc.in
PKGCONFIG_OVERRIDE+=	gconf/GConf.PropertyEditors/gconf-sharp-peditors-2.0.pc.in
PKGCONFIG_OVERRIDE+=	gnome/gnome-sharp-2.0.pc.in
PKGCONFIG_OVERRIDE+=	gnomevfs/gnome-vfs-sharp-2.0.pc.in

SUBST_CLASSES=		pc
SUBST_STAGE.pc=		pre-configure
SUBST_FILES.pc=		${PKGCONFIG_OVERRIDE}
SUBST_SED.pc=		-e "s|\$${pcfiledir}/../..|@prefix@|g"
SUBST_MESSAGE.pc=	Fixing hardcoded paths.

BUILDLINK_API_DEPENDS.libgnomeui+=	libgnomeui>=2.23.0
.include "../../devel/libgnomeui/buildlink3.mk"
BUILDLINK_API_DEPENDS.libart+=		libart>=2.3.20
.include "../../graphics/libart/buildlink3.mk"
BUILDLINK_API_DEPENDS.libgnomecanvas+=	libgnomecanvas>=2.20.0
.include "../../graphics/libgnomecanvas/buildlink3.mk"
.include "../../lang/mono/buildlink3.mk"
BUILDLINK_API_DEPENDS.gnome-vfs+=	gnome-vfs>=2.22.0
.include "../../sysutils/gnome-vfs/buildlink3.mk"
BUILDLINK_API_DEPENDS.gtk2+=		gtk2+>=2.13.0
.include "../../x11/gtk2/buildlink3.mk"
BUILDLINK_API_DEPENDS.gtk-sharp+=	gtk-sharp>=2.12.2
.include "../../x11/gtk-sharp/buildlink3.mk"
.include "../../mk/bsd.pkg.mk"